]> git.pld-linux.org Git - packages/jquery-fancybox.git/blob - jquery-fancybox.spec
- package demo
[packages/jquery-fancybox.git] / jquery-fancybox.spec
1 Summary:        Fancybox - Fancy lightbox alternative
2 Name:           jquery-fancybox
3 Version:        1.3.1
4 Release:        0.4
5 License:        MIT / GPL v2
6 Group:          Applications/WWW
7 Source0:        http://fancybox.googlecode.com/files/jquery.fancybox-%{version}.zip
8 # Source0-md5:  d72d950a798ffaa83750dfd6e4a0e382
9 URL:            http://www.fancybox.net/
10 BuildRequires:  rpmbuild(macros) > 1.268
11 Requires:       jquery >= 1.3
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _appdir         %{_datadir}/jquery
16
17 %description
18 FancyBox is a tool for displaying images, html content and multi-media
19 in a Mac-style "lightbox" that floats overtop of web page.
20
21 Features include:
22 - Can display images, HTML elements, SWF movies, Iframes and also Ajax
23   requests
24 - Customizable through settings and CSS
25 - Groups related items and adds navigation.
26 - If the mouse wheel plugin is included in the page then FancyBox will
27   respond to mouse wheel events as well
28 - Support fancy transitions by using easing plugin
29 - Adds a nice drop shadow under the zoomed item
30
31 %package demo
32 Summary:        Demo for jQuery.fancybox
33 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu jQuery.fancybox
34 Group:          Development
35 Requires:       %{name} = %{version}-%{release}
36
37 %description demo
38 Demonstrations and samples for jQuery.fancybox.
39
40 %prep
41 %setup -qn jquery.fancybox-%{version}
42
43 find '(' -name '*.js' -o -name '*.html' -o -name '*.txt' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
44
45 mv fancybox/jquery.fancybox{-%{version},}.css
46 mv fancybox/jquery.fancybox{-%{version}.pack,}.js
47
48 # source
49 install -d demo src
50 mv fancybox/jquery.fancybox-%{version}.js src/jquery.fancybox.js
51
52 # deps - rename for now
53 mv fancybox/jquery.easing{-1.3.pack,}.js # ? not used?
54 mv fancybox/jquery.mousewheel{-3.0.2.pack,}.js
55
56 # adjust demos to work offline
57 mv index.html style.css ajax.txt example demo
58 ln -s %{_appdir}/jquery.js demo
59 ln -s %{_appdir}/fancybox demo
60
61 sed -i -e '
62         s,./fancybox/jquery.fancybox-1.3.1.js,fancybox/jquery.fancybox.js,
63         s,./fancybox/jquery.fancybox-1.3.1.css,fancybox/jquery.fancybox.css,
64
65         s,http://code.jquery.com/jquery-1.4.2.min.js,jquery.js,
66
67         s,./fancybox/jquery.mousewheel-3.0.2.pack.js,fancybox/jquery.mousewheel.js,
68
69         s,./example/,example/,g
70 ' demo/index.html
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
75 cp -a fancybox $RPM_BUILD_ROOT%{_appdir}
76 cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %{_appdir}/fancybox
84
85 %files demo
86 %defattr(644,root,root,755)
87 %{_examplesdir}/%{name}-%{version}
This page took 0.484154 seconds and 3 git commands to generate.