]> git.pld-linux.org Git - packages/jquery-fancybox.git/blob - jquery-fancybox.spec
55aa027a3aa18d4c3afd35862045fd89fe98a1d5
[packages/jquery-fancybox.git] / jquery-fancybox.spec
1 Summary:        Fancybox - Fancy lightbox alternative
2 Name:           jquery-fancybox
3 Version:        1.3.1
4 Release:        0.4
5 License:        MIT / GPL v2
6 Group:          Applications/WWW
7 Source0:        http://fancybox.googlecode.com/files/jquery.fancybox-%{version}.zip
8 # Source0-md5:  d72d950a798ffaa83750dfd6e4a0e382
9 URL:            http://www.fancybox.net/
10 BuildRequires:  rpmbuild(macros) > 1.268
11 BuildRequires:  unzip
12 Requires:       jquery >= 1.3
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _appdir         %{_datadir}/jquery
17
18 %description
19 FancyBox is a tool for displaying images, html content and multi-media
20 in a Mac-style "lightbox" that floats overtop of web page.
21
22 Features include:
23 - Can display images, HTML elements, SWF movies, Iframes and also Ajax
24   requests
25 - Customizable through settings and CSS
26 - Groups related items and adds navigation.
27 - If the mouse wheel plugin is included in the page then FancyBox will
28   respond to mouse wheel events as well
29 - Support fancy transitions by using easing plugin
30 - Adds a nice drop shadow under the zoomed item
31
32 %package demo
33 Summary:        Demo for jQuery.fancybox
34 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu jQuery.fancybox
35 Group:          Development
36 Requires:       %{name} = %{version}-%{release}
37
38 %description demo
39 Demonstrations and samples for jQuery.fancybox.
40
41 %prep
42 %setup -qn jquery.fancybox-%{version}
43
44 find '(' -name '*.js' -o -name '*.html' -o -name '*.txt' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
45
46 mv fancybox/jquery.fancybox{-%{version},}.css
47 mv fancybox/jquery.fancybox{-%{version}.pack,}.js
48
49 # source
50 install -d demo src
51 mv fancybox/jquery.fancybox-%{version}.js src/jquery.fancybox.js
52
53 # deps - rename for now
54 mv fancybox/jquery.easing{-1.3.pack,}.js # ? not used?
55 mv fancybox/jquery.mousewheel{-3.0.2.pack,}.js
56
57 # adjust demos to work offline
58 mv index.html style.css ajax.txt example demo
59 ln -s %{_appdir}/jquery.js demo
60 ln -s %{_appdir}/fancybox demo
61
62 sed -i -e '
63         s,./fancybox/jquery.fancybox-1.3.1.js,fancybox/jquery.fancybox.js,
64         s,./fancybox/jquery.fancybox-1.3.1.css,fancybox/jquery.fancybox.css,
65
66         s,http://code.jquery.com/jquery-1.4.2.min.js,jquery.js,
67
68         s,./fancybox/jquery.mousewheel-3.0.2.pack.js,fancybox/jquery.mousewheel.js,
69
70         s,./example/,example/,g
71 ' demo/index.html
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
76 cp -a fancybox $RPM_BUILD_ROOT%{_appdir}
77 cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %{_appdir}/fancybox
85
86 %files demo
87 %defattr(644,root,root,755)
88 %{_examplesdir}/%{name}-%{version}
This page took 0.104394 seconds and 2 git commands to generate.