]> git.pld-linux.org Git - packages/jquery-fancybox.git/blame - jquery-fancybox.spec
- typo
[packages/jquery-fancybox.git] / jquery-fancybox.spec
CommitLineData
6c3387e9
ER
1Summary: Fancybox - Fancy lightbox alternative
2Name: jquery-fancybox
3Version: 1.3.1
6545f82b
ER
4Release: 0.4
5License: MIT / GPL v2
6c3387e9
ER
6Group: Applications/WWW
7Source0: http://fancybox.googlecode.com/files/jquery.fancybox-%{version}.zip
8# Source0-md5: d72d950a798ffaa83750dfd6e4a0e382
9URL: http://www.fancybox.net/
d6800788 10BuildRequires: rpmbuild(macros) >= 1.268
9fc9fbf6 11BuildRequires: unzip
6c3387e9
ER
12Requires: jquery >= 1.3
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%define _appdir %{_datadir}/jquery
17
18%description
19FancyBox is a tool for displaying images, html content and multi-media
20in a Mac-style "lightbox" that floats overtop of web page.
21
6545f82b 22Features include:
6c3387e9
ER
23- Can display images, HTML elements, SWF movies, Iframes and also Ajax
24 requests
25- Customizable through settings and CSS
26- Groups related items and adds navigation.
27- If the mouse wheel plugin is included in the page then FancyBox will
28 respond to mouse wheel events as well
29- Support fancy transitions by using easing plugin
30- Adds a nice drop shadow under the zoomed item
31
32%package demo
33Summary: Demo for jQuery.fancybox
34Summary(pl.UTF-8): Pliki demonstracyjne dla pakietu jQuery.fancybox
35Group: Development
36Requires: %{name} = %{version}-%{release}
37
38%description demo
39Demonstrations and samples for jQuery.fancybox.
40
41%prep
42%setup -qn jquery.fancybox-%{version}
43
44find '(' -name '*.js' -o -name '*.html' -o -name '*.txt' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
45
46mv fancybox/jquery.fancybox{-%{version},}.css
47mv fancybox/jquery.fancybox{-%{version}.pack,}.js
6545f82b
ER
48
49# source
50install -d demo src
51mv fancybox/jquery.fancybox-%{version}.js src/jquery.fancybox.js
52
53# deps - rename for now
54mv fancybox/jquery.easing{-1.3.pack,}.js # ? not used?
6c3387e9 55mv fancybox/jquery.mousewheel{-3.0.2.pack,}.js
6545f82b
ER
56
57# adjust demos to work offline
58mv index.html style.css ajax.txt example demo
59ln -s %{_appdir}/jquery.js demo
60ln -s %{_appdir}/fancybox demo
61
62sed -i -e '
63 s,./fancybox/jquery.fancybox-1.3.1.js,fancybox/jquery.fancybox.js,
64 s,./fancybox/jquery.fancybox-1.3.1.css,fancybox/jquery.fancybox.css,
65
66 s,http://code.jquery.com/jquery-1.4.2.min.js,jquery.js,
67
68 s,./fancybox/jquery.mousewheel-3.0.2.pack.js,fancybox/jquery.mousewheel.js,
69
70 s,./example/,example/,g
71' demo/index.html
6c3387e9
ER
72
73%install
74rm -rf $RPM_BUILD_ROOT
75install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
76cp -a fancybox $RPM_BUILD_ROOT%{_appdir}
6545f82b 77cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
6c3387e9
ER
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%files
83%defattr(644,root,root,755)
84%{_appdir}/fancybox
85
86%files demo
87%defattr(644,root,root,755)
88%{_examplesdir}/%{name}-%{version}
This page took 0.043336 seconds and 4 git commands to generate.