]> git.pld-linux.org Git - packages/jquery-fancybox.git/blame - jquery-fancybox.spec
- package demo
[packages/jquery-fancybox.git] / jquery-fancybox.spec
CommitLineData
6c3387e9
ER
1Summary: Fancybox - Fancy lightbox alternative
2Name: jquery-fancybox
3Version: 1.3.1
6545f82b
ER
4Release: 0.4
5License: MIT / GPL v2
6c3387e9
ER
6Group: Applications/WWW
7Source0: http://fancybox.googlecode.com/files/jquery.fancybox-%{version}.zip
8# Source0-md5: d72d950a798ffaa83750dfd6e4a0e382
9URL: http://www.fancybox.net/
10BuildRequires: rpmbuild(macros) > 1.268
11Requires: jquery >= 1.3
12BuildArch: noarch
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%define _appdir %{_datadir}/jquery
16
17%description
18FancyBox is a tool for displaying images, html content and multi-media
19in a Mac-style "lightbox" that floats overtop of web page.
20
6545f82b 21Features include:
6c3387e9
ER
22- Can display images, HTML elements, SWF movies, Iframes and also Ajax
23 requests
24- Customizable through settings and CSS
25- Groups related items and adds navigation.
26- If the mouse wheel plugin is included in the page then FancyBox will
27 respond to mouse wheel events as well
28- Support fancy transitions by using easing plugin
29- Adds a nice drop shadow under the zoomed item
30
31%package demo
32Summary: Demo for jQuery.fancybox
33Summary(pl.UTF-8): Pliki demonstracyjne dla pakietu jQuery.fancybox
34Group: Development
35Requires: %{name} = %{version}-%{release}
36
37%description demo
38Demonstrations and samples for jQuery.fancybox.
39
40%prep
41%setup -qn jquery.fancybox-%{version}
42
43find '(' -name '*.js' -o -name '*.html' -o -name '*.txt' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
44
45mv fancybox/jquery.fancybox{-%{version},}.css
46mv fancybox/jquery.fancybox{-%{version}.pack,}.js
6545f82b
ER
47
48# source
49install -d demo src
50mv fancybox/jquery.fancybox-%{version}.js src/jquery.fancybox.js
51
52# deps - rename for now
53mv fancybox/jquery.easing{-1.3.pack,}.js # ? not used?
6c3387e9 54mv fancybox/jquery.mousewheel{-3.0.2.pack,}.js
6545f82b
ER
55
56# adjust demos to work offline
57mv index.html style.css ajax.txt example demo
58ln -s %{_appdir}/jquery.js demo
59ln -s %{_appdir}/fancybox demo
60
61sed -i -e '
62 s,./fancybox/jquery.fancybox-1.3.1.js,fancybox/jquery.fancybox.js,
63 s,./fancybox/jquery.fancybox-1.3.1.css,fancybox/jquery.fancybox.css,
64
65 s,http://code.jquery.com/jquery-1.4.2.min.js,jquery.js,
66
67 s,./fancybox/jquery.mousewheel-3.0.2.pack.js,fancybox/jquery.mousewheel.js,
68
69 s,./example/,example/,g
70' demo/index.html
6c3387e9
ER
71
72%install
73rm -rf $RPM_BUILD_ROOT
74install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
75cp -a fancybox $RPM_BUILD_ROOT%{_appdir}
6545f82b 76cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
6c3387e9
ER
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(644,root,root,755)
83%{_appdir}/fancybox
84
85%files demo
86%defattr(644,root,root,755)
87%{_examplesdir}/%{name}-%{version}
This page took 0.057044 seconds and 4 git commands to generate.