]> git.pld-linux.org Git - packages/jquery-datepicker.git/commitdiff
- try alternate calendar view patch AC-branch master auto/ac/jquery-datepicker-2_1_2-0_108_4 auto/th/jquery-datepicker-2_1_2-0_108_4
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 22 Nov 2011 10:33:56 +0000 (10:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    alt-view.patch -> 1.1
    jquery-datepicker.spec -> 1.6

alt-view.patch [new file with mode: 0644]
jquery-datepicker.spec

diff --git a/alt-view.patch b/alt-view.patch
new file mode 100644 (file)
index 0000000..6654bf6
--- /dev/null
@@ -0,0 +1,75 @@
+--- trunk/demo/scripts/jquery.datePicker.js    2011-11-22 11:15:26.912614656 +0200
++++ trunk/demo/scripts/jquery.datePicker.js    2011-11-22 11:13:47.781893200 +0200
+@@ -852,15 +852,7 @@
+                                                               $('<h2></h2>'),
+                                                               $('<div class="dp-nav-prev"></div>')
+                                                                       .append(
+-                                                                              $('<a class="dp-nav-prev-year" href="#" title="' + $.dpText.TEXT_PREV_YEAR + '">&lt;&lt;</a>')
+-                                                                                      .bind(
+-                                                                                              'click',
+-                                                                                              function()
+-                                                                                              {
+-                                                                                                      return c._displayNewMonth.call(c, this, 0, -1);
+-                                                                                              }
+-                                                                                      ),
+-                                                                              $('<a class="dp-nav-prev-month" href="#" title="' + $.dpText.TEXT_PREV_MONTH + '">&lt;</a>')
++                                                                              $('<a class="dp-nav-prev-month" href="#" title="' + $.dpText.TEXT_PREV_MONTH + '"></a>')
+                                                                                       .bind(
+                                                                                               'click',
+                                                                                               function()
+@@ -871,24 +863,37 @@
+                                                                       ),
+                                                               $('<div class="dp-nav-next"></div>')
+                                                                       .append(
+-                                                                              $('<a class="dp-nav-next-year" href="#" title="' + $.dpText.TEXT_NEXT_YEAR + '">&gt;&gt;</a>')
++                                                                              $('<a class="dp-nav-next-month" href="#" title="' + $.dpText.TEXT_NEXT_MONTH + '"></a>')
+                                                                                       .bind(
+                                                                                               'click',
+                                                                                               function()
+                                                                                               {
+-                                                                                                      return c._displayNewMonth.call(c, this, 0, 1);
++                                                                                                      return c._displayNewMonth.call(c, this, 1, 0);
+                                                                                               }
+-                                                                                      ),
+-                                                                              $('<a class="dp-nav-next-month" href="#" title="' + $.dpText.TEXT_NEXT_MONTH + '">&gt;</a>')
++                                                                                      )
++                                                                      ),
++                                                              $('<div class="dp-calendar"></div>'),
++                                                              $('<div class="dp-bottom"></div>').append(
++                                    $('<div class="dp-bottom-prev"><a class="dp-nav-prev-year" href="#" title="' + $.dpText.TEXT_PREV_YEAR + '">'+(c.displayedYear-1)+'</a></div>')
++                                        .bind(
++                                            'click',
++                                            function()
++                                            {
++                                                return c._displayNewMonth.call(c, this, 0, -1);
++                                            }
++                                        )
++                                ).append(
++                                                                              $('<div class="dp-bottom-next"><a class="dp-nav-next-year" href="#" title="' + $.dpText.TEXT_NEXT_YEAR + '">'+(c.displayedYear+1)+'</a></div>')
+                                                                                       .bind(
+                                                                                               'click',
+                                                                                               function()
+                                                                                               {
+-                                                                                                      return c._displayNewMonth.call(c, this, 1, 0);
++                                                                                                      return c._displayNewMonth.call(c, this, 0, 1);
+                                                                                               }
+                                                                                       )
+-                                                                      ),
+-                                                              $('<div class="dp-calendar"></div>')
++                                                                      )
++                                
++                                
+                                                       )
+                                                       .bgIframe()
+                                               );
+@@ -1122,6 +1127,10 @@
+                                               }
+                                       }
+                               }
++                $('.dp-nav-next-year', this.context).text(this.displayedYear+1);
++                $('.dp-nav-prev-year', this.context).text(this.displayedYear-1);
++                
++                
+                               this._applyRenderCallbacks();
+                       },
+                       _closeCalendar : function(programatic, ele)
index b1b5458c3ea8af5722a7b3f39e80b5ad7217e6a7..4d4081fbaffd6d497dc09037582666c29ea7c109 100644 (file)
@@ -1,5 +1,5 @@
 %define                svnrev  108
-%define                rel             3
+%define                rel             4
 %define                plugin  datepicker
 Summary:       A flexible unobtrusive calendar component for jQuery
 Name:          jquery-%{plugin}
@@ -14,9 +14,10 @@ Source0:     %{name}-%{version}.tar.bz2
 # Source0-md5: df393f932ff6d5a37d4a0856c1cbb216
 Source1:       http://www.kelvinluck.com/assets/jquery/datePicker/v2/demo/scripts/jquery.datePicker.js
 # Source1-md5: 43dbc8fe7ec22688e268068982477c9c
+Patch0:                alt-view.patch
 URL:           http://www.kelvinluck.com/assets/jquery/datePicker/v2/demo/
 BuildRequires: js
-BuildRequires: rpmbuild(macros) >= 1.565
+BuildRequires: rpmbuild(macros) >= 1.553
 BuildRequires: yuicompressor
 Requires:      jquery >= 1.2.1
 Requires:      jquery-methods
@@ -42,13 +43,15 @@ Demonstrations and samples for jQuery.datePicker.
 
 %prep
 %setup -q
-cp -p %{SOURCE1} dist
+cp -p %{SOURCE1} demo/scripts/jquery.datePicker.js
+%undos -f js
+%patch0 -p1
 
 %build
 install -d build
 
 # compress .js
-js=dist/jquery.datePicker.js
+js=demo/scripts/jquery.datePicker.js
 out=build/jquery.datePicker.js
 %if 0%{!?debug:1}
 yuicompressor --charset UTF-8 $js -o $out
This page took 0.061259 seconds and 4 git commands to generate.