]> git.pld-linux.org Git - packages/john.git/commitdiff
- disable some inlining on x8664
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 21 Jul 2013 11:26:48 +0000 (13:26 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 21 Jul 2013 11:26:48 +0000 (13:26 +0200)
john.spec
no-inline.patch [new file with mode: 0644]

index 756e804c0238ab4279a132a8ef1cbc954e349087..710f012a610bf8c9ff67afd33d0e05daebfea405 100644 (file)
--- a/john.spec
+++ b/john.spec
@@ -45,6 +45,7 @@ Patch1:               optflags.patch
 Patch2:                http://www.openwall.com/john/g/%{name}-1.7.9-jumbo-7.diff.gz
 # Patch2-md5:  b953fcb7f743eeeb5f938a28c352b8ef
 Patch3:                %{name}-jumbo-optflags.patch
+Patch4:                no-inline.patch
 URL:           http://www.openwall.com/john/
 %{?with_jumbopatch:BuildRequires: openssl-devel >= 0.9.7}
 BuildRequires: rpmbuild(macros) >= 1.213
@@ -87,6 +88,9 @@ Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
 %{!?with_jumbopatch:%patch1 -p1}
 %{?with_jumbopatch:%patch2 -p1}
 %{?with_jumbopatch:%patch3 -p1}
+%ifarch %{x8664}
+%patch4 -p1
+%endif
 
 %{__rm} doc/INSTALL
 
diff --git a/no-inline.patch b/no-inline.patch
new file mode 100644 (file)
index 0000000..b327479
--- /dev/null
@@ -0,0 +1,38 @@
+--- john-1.7.9/src/MD5_std.c~  2013-07-21 13:22:20.285649779 +0200
++++ john-1.7.9/src/MD5_std.c   2013-07-21 13:22:44.392541796 +0200
+@@ -472,12 +472,14 @@
+ /*
+  * x86-64 implies a fairly recent CPU, so presumably its L1 instruction cache
+  * is large enough.
+- */
+ #ifdef __x86_64__
+ #define MAYBE_INLINE_BODY MAYBE_INLINE
+ #else
++ */
+ #define MAYBE_INLINE_BODY
++/*
+ #endif
++ */
+ #if !MD5_X2
+--- john-1.7.9/src/lotus5_fmt_plug.c~  2013-07-21 13:25:04.637186087 +0200
++++ john-1.7.9/src/lotus5_fmt_plug.c   2013-07-21 13:25:41.664198855 +0200
+@@ -155,7 +155,7 @@
+ /*Beginning of private functions*/
+ /* Takes the plaintext password and generates the second row of our
+  * working matrix for the final call to the mixing function*/
+-void MAYBE_INLINE
++void
+ lotus_transform_password (unsigned char *i1, unsigned char *o1,
+     unsigned char *i2, unsigned char *o2)
+ {
+@@ -173,7 +173,7 @@
+ }
+ /* The mixing function: perturbs the first three rows of the matrix*/
+-void MAYBE_INLINE lotus_mix (unsigned char *m1, unsigned char *m2)
++void lotus_mix (unsigned char *m1, unsigned char *m2)
+ {
+   int i, j;
+   unsigned char p1, p2;
This page took 0.053695 seconds and 4 git commands to generate.