]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- updated to 1.7.4
[packages/john.git] / john.spec
1 #
2 # Conditional build:
3 %bcond_with jumbopatch  # This patch integrates lots of contributed
4                         # patches adding support for over 30 
5                         # of additional hash types, and more. 
6
7 %ifarch i586 i686 athlon pentium2 pentium3 pentium4
8 %define do_mmx 1
9 %else
10 %define do_mmx 0
11 %endif
12 %ifarch i586 i686
13 %define do_mmxfb 1
14 %define optmmxfb        -DCPU_FALLBACK=1
15 %else
16 %define do_mmxfb 0
17 %undefine optmmxfb
18 %endif
19 Summary:        Password cracker
20 Summary(pl.UTF-8):      Łamacz haseł
21 Name:           john
22 Version:        1.7.4
23 Release:        1
24 License:        GPL
25 Group:          Applications/System
26 Source0:        http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
27 # Source0-md5:  da5c9689f49eda1fc4297b6720ee24db
28 Patch0:         %{name}-mailer.patch
29 %{?with_jumbopatch:Patch1:              http://www.openwall.com/john/contrib/john-%{version}-jumbo-2.diff.gz}
30 URL:            http://www.openwall.com/john/
31 BuildRequires:  rpmbuild(macros) >= 1.213
32 %{?with_jumbopatch:BuildRequires:        openssl-devel >= 0.9.7}
33 Requires:       words
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 John the Ripper is a fast password cracker, currently available for
38 many flavors of Unix (11 are officially supported, not counting
39 different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
40 requires a contributed patch). Its primary purpose is to detect weak
41 Unix passwords. Besides several crypt(3) password hash types most
42 commonly found on various Unix flavors, supported out of the box are
43 Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
44 contributed patches.
45
46 %description -l pl.UTF-8
47 John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
48 rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
49 architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
50 łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
51 Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
52 na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
53 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %{?with_jumbopatch:%patch1 -p1}
59
60 %build
61 cd src
62
63 %if %{do_mmxfb}
64 %{__make} linux-x86-any \
65         CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
66         CC="%{__cc}"
67 mv ../run/john ../run/john-non-mmx
68 %{__make} clean
69 %endif
70
71 %ifarch %{ix86}
72         %if %{do_mmx}
73                 TARG=linux-x86-mmx
74         %else
75                 TARG=linux-x86-any
76         %endif
77 %else
78         %ifarch alpha
79                 TARG=linux-alpha
80         %else
81                 %ifarch sparc sparcv9
82                         TARG=linux-sparc
83                 %else
84                         %ifarch %{x8664}
85                                 TARG=linux-x86-64
86                         %else
87                                 TARG=generic
88                         %endif
89                 %endif
90         %endif
91 %endif
92
93 %{__make} $TARG \
94         CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}" \
95         CC="%{__cc}"
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
101 install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
102 install run/john $RPM_BUILD_ROOT%{_bindir}
103 %if %{do_mmxfb}
104 install -d $RPM_BUILD_ROOT%{_libdir}/john
105 install run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
106 %endif
107
108 rm -f doc/INSTALL
109
110 cd $RPM_BUILD_ROOT%{_bindir}
111 ln -sf john unafs
112 ln -sf john unique
113 ln -sf john unshadow
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc doc/* run/mailer
121 %attr(755,root,root) %{_bindir}/*
122 %if %{do_mmxfb}
123 %dir %{_libdir}/john
124 %attr(755,root,root) %{_libdir}/john/john-non-mmx
125 %endif
126 %{_datadir}/john
This page took 0.073097 seconds and 4 git commands to generate.