]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- release 2 to rebuild with ac
[packages/john.git] / john.spec
1 #
2 # Conditional build:
3 # _with_mmx     - MMX optimization
4 # Optimization must be chosen at compile time :(
5 # Maybe some patch...? But not yet.
6 #
7 %ifarch athlon
8 %define _with_mmx 1
9 %endif
10 Summary:        Password cracker
11 Summary(pl):    £amacz hase³
12 Name:           john
13 Version:        1.6.34
14 Release:        2
15 License:        GPL
16 Group:          Applications/System
17 Source0:        http://www.openwall.com/john/%{name}-1.6.tar.gz
18 # Source0-md5:  aae782f160041b2bdc624b0a84054e32
19 Patch0:         %{name}-%{version}.patch
20 Patch1:         %{name}-1.6.PLD.diff
21 Patch2:         %{name}-1.6.ini.diff
22 Patch3:         %{name}-1.6.makefile.diff
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 John the Ripper is a password cracker, currently available for UNIX,
27 DOS, WinNT/Win95. Its primary purpose is to detect weak UNIX
28 passwords. It has been tested with Linux x86/Alpha/SPARC, FreeBSD x86,
29 OpenBSD x86, Solaris 2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and
30 IRIX.
31
32 %description -l pl
33 John The Ripper jest "³amaczem" hase³ dostêpnym dla systemów UNIX,
34 DOS, WinNT/Win95. G³ównym jego zadaniem jest wykrywanie "s³abych"
35 hase³. By³ testowany z Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86,
36 Solaris 2.x SPARC i x86, Digital UNIX, AIX, HP-UX oraz IRIX.
37
38 %prep
39 %setup -q -n %{name}-1.6
40 %patch0 -p1
41 %patch1 -p1
42 #%patch2 -p1
43 #%patch3 -p1
44
45 %build
46 cd src
47 COPT="%{rpmcflags}"
48
49 # bleh... MMX code must be chosen at compile time :(
50 # cannot use MMX for generic i586 nor i686 (Pentium/Pentium Pro have no MMX)
51 # K6 optimization exists only in Makefile
52 %ifarch %{ix86}
53         %if %{?_with_mmx:1}%{!?_with_mmx:0}
54                 TARG=linux-x86-mmx-elf
55         %else
56                 TARG=linux-x86-any-elf
57         %endif
58 %else
59         %ifarch alpha
60                 TARG=linux-alpha
61         %else
62                 %ifarch sparc sparc64
63                         TARG=linux-sparc
64                 %else
65                         TARG=generic
66                 %endif
67         %endif
68 %endif
69
70 %{__make} OPT="$COPT" CC="%{__cc}" $TARG
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/john}
75 install run/{*.chr,john.conf} $RPM_BUILD_ROOT%{_libdir}/john
76 install run/john $RPM_BUILD_ROOT%{_bindir}
77
78 rm -f doc/INSTALL
79
80 cd $RPM_BUILD_ROOT%{_bindir}
81 ln -sf john unafs
82 ln -sf john unique
83 ln -sf john unshadow
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc doc/* run/mailer
91 %attr(755,root,root) %{_bindir}/*
92 %{_libdir}/john
This page took 0.102398 seconds and 4 git commands to generate.