]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- dropped obsolete K6 comment, updated sparc* targets
[packages/john.git] / john.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx     # MMX optimization
4 # Optimization must be chosen at compile time :(
5 # Maybe some patch...? But not yet.
6 #
7 %ifarch athlon
8 %define with_mmx 1
9 %endif
10 Summary:        Password cracker
11 Summary(pl):    £amacz hase³
12 Name:           john
13 Version:        1.7
14 Release:        0.2
15 License:        GPL
16 Group:          Applications/System
17 Source0:        http://www.openwall.com/john/d/%{name}-%{version}.tar.bz2
18 # Source0-md5:  615b912caa677eec790e28745a12b2ae
19 Patch0:         %{name}-mailer.patch
20 URL:            http://www.openwall.com/john/
21 BuildRequires:  rpmbuild(macros) >= 1.213
22 BuildRequires:  sed >= 4.0
23 Requires:       words
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 John the Ripper is a password cracker, currently available for UNIX,
28 DOS, WinNT/Win95. Its primary purpose is to detect weak UNIX
29 passwords. It has been tested with Linux x86/Alpha/SPARC, FreeBSD x86,
30 OpenBSD x86, Solaris 2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and
31 IRIX.
32
33 %description -l pl
34 John The Ripper jest "³amaczem" hase³ dostêpnym dla systemów UNIX,
35 DOS, WinNT/Win95. G³ównym jego zadaniem jest wykrywanie "s³abych"
36 hase³. By³ testowany z Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86,
37 Solaris 2.x SPARC i x86, Digital UNIX, AIX, HP-UX oraz IRIX.
38
39 %prep
40 %setup -q 
41 %patch0 -p1
42
43 sed -i -e 's/CLK_TCK/CLOCKS_PER_SEC/g' src/*.c
44
45 %build
46 cd src
47
48 # bleh... MMX code must be chosen at compile time :(
49 # cannot use MMX for generic i586 nor i686 (Pentium/Pentium Pro have no MMX)
50 %ifarch %{ix86}
51         %if %{with mmx}
52                 TARG=linux-x86-mmx
53         %else
54                 TARG=linux-x86-any
55         %endif
56 %else
57         %ifarch alpha
58                 TARG=linux-alpha
59         %else
60                 %ifarch sparc sparcv9
61                         TARG=linux-sparc
62                 %else
63                         %ifarch %{x8664}
64                                 TARG=linux-x86-64
65                         %else
66                                 TARG=generic
67                         %endif  
68                 %endif
69         %endif
70 %endif
71
72 %{__make} $TARG \
73         CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
74         CC="%{__cc}"
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
80 install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
81 install run/john $RPM_BUILD_ROOT%{_bindir}
82
83 rm -f doc/INSTALL
84
85 cd $RPM_BUILD_ROOT%{_bindir}
86 ln -sf john unafs
87 ln -sf john unique
88 ln -sf john unshadow
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc doc/* run/mailer
96 %attr(755,root,root) %{_bindir}/*
97 %{_datadir}/john
This page took 0.107277 seconds and 3 git commands to generate.