]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- updated to 1.7.3.1
[packages/john.git] / john.spec
1 #
2 %ifarch i586 i686 athlon pentium2 pentium3 pentium4
3 %define do_mmx 1
4 %else
5 %define do_mmx 0
6 %endif
7 %ifarch i586 i686
8 %define do_mmxfb 1
9 %define optmmxfb        -DCPU_FALLBACK=1
10 %else
11 %define do_mmxfb 0
12 %undefine optmmxfb
13 %endif
14 Summary:        Password cracker
15 Summary(pl.UTF-8):      Łamacz haseł
16 Name:           john
17 Version:        1.7.3.1
18 Release:        1
19 License:        GPL
20 Group:          Applications/System
21 Source0:        http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
22 # Source0-md5:  4a8de450ff332bd0c7cbc573eb5032d9
23 Patch0:         %{name}-mailer.patch
24 URL:            http://www.openwall.com/john/
25 BuildRequires:  rpmbuild(macros) >= 1.213
26 Requires:       words
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 John the Ripper is a fast password cracker, currently available for
31 many flavors of Unix (11 are officially supported, not counting
32 different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
33 requires a contributed patch). Its primary purpose is to detect weak
34 Unix passwords. Besides several crypt(3) password hash types most
35 commonly found on various Unix flavors, supported out of the box are
36 Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
37 contributed patches.
38
39 %description -l pl.UTF-8
40 John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
41 rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
42 architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
43 łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
44 Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
45 na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
46 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 %build
53 cd src
54
55 %if %{do_mmxfb}
56 %{__make} linux-x86-any \
57         CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
58         CC="%{__cc}"
59 mv ../run/john ../run/john-non-mmx
60 %{__make} clean
61 %endif
62
63 %ifarch %{ix86}
64         %if %{do_mmx}
65                 TARG=linux-x86-mmx
66         %else
67                 TARG=linux-x86-any
68         %endif
69 %else
70         %ifarch alpha
71                 TARG=linux-alpha
72         %else
73                 %ifarch sparc sparcv9
74                         TARG=linux-sparc
75                 %else
76                         %ifarch %{x8664}
77                                 TARG=linux-x86-64
78                         %else
79                                 TARG=generic
80                         %endif
81                 %endif
82         %endif
83 %endif
84
85 %{__make} $TARG \
86         CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}" \
87         CC="%{__cc}"
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
93 install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
94 install run/john $RPM_BUILD_ROOT%{_bindir}
95 %if %{do_mmxfb}
96 install -d $RPM_BUILD_ROOT%{_libdir}/john
97 install run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
98 %endif
99
100 rm -f doc/INSTALL
101
102 cd $RPM_BUILD_ROOT%{_bindir}
103 ln -sf john unafs
104 ln -sf john unique
105 ln -sf john unshadow
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc doc/* run/mailer
113 %attr(755,root,root) %{_bindir}/*
114 %if %{do_mmxfb}
115 %dir %{_libdir}/john
116 %attr(755,root,root) %{_libdir}/john/john-non-mmx
117 %endif
118 %{_datadir}/john
This page took 0.073776 seconds and 3 git commands to generate.