]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
- release 5 (by relup.sh)
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.9.1
9 Release:        5
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://gitlab.com/ixion/ixion
13 Source0:        http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
14 # Source0-md5:  d292f6d62847f2305178459390842eac
15 URL:            https://gitlab.com/ixion/ixion
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  boost-devel >= 1.36
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  mdds-devel >= 0.12.0
22 BuildRequires:  python >= 1:2.7.0
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Ixion aims to provide a library for calculating the results of formula
29 expressions stored in multiple named targets, or "cells". The cells
30 can be referenced from each other, and the library takes care of
31 resolving their dependencies automatically upon calculation. The
32 caller can run the calculation routine either in a single-threaded
33 mode, or a multi-threaded mode. The library also supports
34 re-calculation where the contents of one or more cells have been
35 modified since the last calculation, and a partial calculation of only
36 the affected cells gets performed. It is written entirely in C++, and
37 makes extensive use of the boost library to achieve portability across
38 different platforms.
39
40 %description -l pl.UTF-8
41 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
42 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
43 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
44 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
45 obliczeniach. Procedura obliczająca może być wywołana w trybie
46 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
47 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
48 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
49 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
50 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
51 przenośność na wiele platform.
52
53 %package devel
54 Summary:        Development files for ixion
55 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       boost-devel >= 1.36
59 Requires:       libstdc++-devel
60 Requires:       mdds-devel >= 0.12.0
61
62 %description devel
63 This package contains the header files for developing applications
64 that use ixion.
65
66 %description devel -l pl.UTF-8
67 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
68 ixion.
69
70 %package static
71 Summary:        Static ixion library
72 Summary(pl.UTF-8):      Statyczna biblioteka ixion
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static ixion library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka ixion.
81
82 %package -n python-ixion
83 Summary:        Python interface to ixion library
84 Summary(pl.UTF-8):      Interfejs Pythona do biblioteki ixion
85 Group:          Libraries/Python
86 Requires:       %{name} = %{version}-%{release}
87
88 %description -n python-ixion
89 Python interface to ixion library.
90
91 %description -n python-ixion -l pl.UTF-8
92 Interfejs Pythona do biblioteki ixion.
93
94 %prep
95 %setup -q -n libixion-%{version}
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         --disable-silent-rules \
104         %{?with_static_libs:--enable-static}
105
106 %{__make}
107
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.la
115 %if %{with static_libs}
116 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.a
117 %endif
118 # obsoleted by pkg-config
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS COPYING README
130 %attr(755,root,root) %{_bindir}/ixion-parser
131 %attr(755,root,root) %{_bindir}/ixion-sorter
132 %attr(755,root,root) %{_libdir}/libixion-0.10.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libixion-0.10.so.0
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libixion-0.10.so
138 %{_includedir}/libixion-0.10
139 %{_pkgconfigdir}/libixion-0.10.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libixion-0.10.a
145 %endif
146
147 %files -n python-ixion
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{py_sitedir}/ixion.so
This page took 0.107915 seconds and 3 git commands to generate.