]> git.pld-linux.org Git - packages/ixgbe.git/commitdiff
- updated to 4.1.1 auto/th/ixgbe-4.1.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 4 Jul 2015 12:44:35 +0000 (14:44 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 4 Jul 2015 12:44:35 +0000 (14:44 +0200)
- fixed building with linux 4.1

ixgbe.spec
linux-4.1.patch [new file with mode: 0644]

index cf6384205b76329e65fbbeaff72d7197999b58de..643a1e94cce5c4a655da0ce9e1ec52b7f1f7fc3e 100644 (file)
@@ -9,12 +9,13 @@
 Summary:       Intel(R) 10 Gigabit driver for Linux
 Summary(pl.UTF-8):     Sterownik do karty Intel(R) 10 Gigabit
 Name:          %{pname}%{_alt_kernel}
-Version:       4.0.3
+Version:       4.1.1
 Release:       %{rel}@%{_kernel_ver_str}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
-# Source0-md5: fd81102645a6cbdea727a52f7b9d34f5
+# Source0-md5: a9f21c59f7189d3e0f3e97a8cd812670
+Patch0:                linux-4.1.patch
 URL:           http://sourceforge.net/projects/e1000/
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRequires: rpmbuild(macros) >= 1.701
@@ -77,6 +78,7 @@ EOF\
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
 
 cp src/Makefile src/Makefile.%{name}
 cat > src/Makefile <<'EOF'
@@ -86,7 +88,7 @@ ixgbe_lib.o ixgbe_ethtool.o kcompat.o ixgbe_82598.o \
 ixgbe_82599.o ixgbe_ptp.o ixgbe_x540.o ixgbe_x550.o ixgbe_sriov.o \
 ixgbe_mbx.o ixgbe_dcb.o ixgbe_dcb_82598.o ixgbe_dcb_82599.o \
 ixgbe_sysfs.o ixgbe_procfs.o ixgbe_phy.o ixgbe_fcoe.o \
-ixgbe_dcb_nl.o ixgbe_dcb_nl.o ixgbe_debugfs.o
+ixgbe_dcb_nl.o ixgbe_debugfs.o
 
 EXTRA_CFLAGS+=-DDRIVER_IXGBE
 EXTRA_CFLAGS+=-DIXGBE_PTP
diff --git a/linux-4.1.patch b/linux-4.1.patch
new file mode 100644 (file)
index 0000000..80afa64
--- /dev/null
@@ -0,0 +1,36 @@
+--- ixgbe-4.1.1/src/ixgbe_main.c~      2015-04-30 02:13:22.000000000 +0200
++++ ixgbe-4.1.1/src/ixgbe_main.c       2015-07-04 14:40:47.319817216 +0200
+@@ -9447,7 +9447,11 @@
+       return 0;
+ }
+-#ifdef HAVE_BRIDGE_FILTER
++#ifdef HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
++static int ixgbe_ndo_bridge_getlink(struct sk_buff *skb, u32 pid, u32 seq,
++                                struct net_device *dev, u32 filter_mask,
++                                int nlflags)
++#elif defined(HAVE_BRIDGE_FILTER)
+ static int ixgbe_ndo_bridge_getlink(struct sk_buff *skb, u32 pid, u32 seq,
+                                   struct net_device *dev,
+                                   u32 __always_unused filter_mask)
+@@ -9464,7 +9464,9 @@
+       mode = adapter->bridge_mode;
+-#ifdef HAVE_NDO_FDB_ADD_VID
++#ifdef HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
++      return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0, nlflags);
++#elif defined(HAVE_NDO_FDB_ADD_VID)
+       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0);
+ #else
+       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode);
+--- ixgbe-4.1.1/src/kcompat.h~ 2015-04-30 02:13:22.000000000 +0200
++++ ixgbe-4.1.1/src/kcompat.h  2015-07-04 14:44:02.702152426 +0200
+@@ -4539,6 +4539,7 @@
+ #endif
+ #else
+ #define HAVE_PTP_CLOCK_INFO_GETTIME64
++#define HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
+ #endif /* 4,1,0 */
+ #endif /* _KCOMPAT_H_ */
This page took 0.120274 seconds and 4 git commands to generate.