]> git.pld-linux.org Git - packages/ixgbe.git/commitdiff
- kernel driver for Intel(R) 10 Gigabit adapters based on 82598 chipset auto/ti/ixgbe-1_3_20_3-1
authorhawk <hawk@pld-linux.org>
Mon, 5 May 2008 15:54:49 +0000 (15:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ixgbe.spec -> 1.1

ixgbe.spec [new file with mode: 0644]

diff --git a/ixgbe.spec b/ixgbe.spec
new file mode 100644 (file)
index 0000000..8c934c1
--- /dev/null
@@ -0,0 +1,95 @@
+# Conditional build:
+%bcond_without dist_kernel     # allow non-distribution kernel
+%bcond_without kernel          # don't build kernel modules
+%bcond_with    verbose         # verbose build (V=1)
+
+%ifarch sparc
+%undefine      with_smp
+%endif
+
+%if %{without kernel}
+%undefine with_dist_kernel
+%endif
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+
+%define                rel     1
+%define                pname   ixgbe
+Summary:       Intel(R) PRO/1000 driver for Linux
+Summary(pl.UTF-8):     Sterownik do karty Intel(R) PRO/1000
+Name:          %{pname}%{_alt_kernel}
+Version:       1.3.20.3
+Release:       %{rel}
+License:       GPL v2
+Group:         Base/Kernel
+Source0:       http://dl.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
+# Source0-md5: 3e05fc18095c1278917d53d0c37e00fd
+URL:           http://sourceforge.net/projects/e1000/
+%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
+BuildRequires: rpmbuild(macros) >= 1.379
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This package contains the Linux driver for the Intel(R) 10 Gigabit
+adapters with 82598 chipset.
+
+%description -l pl.UTF-8
+Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych
+z rodziny Intel(R) 10 Gigabit opartych o układ 82598.
+
+%package -n kernel%{_alt_kernel}-net-ixgbe
+Summary:       Intel(R) PRO/1000 driver for Linux
+Summary(pl.UTF-8):     Sterownik do karty Intel(R) PRO/1000
+Release:       %{rel}@%{_kernel_ver_str}
+Group:         Base/Kernel
+Requires(post,postun): /sbin/depmod
+%if %{with dist_kernel}
+%requires_releq_kernel
+Requires(postun):      %releq_kernel
+%endif
+
+%description -n kernel%{_alt_kernel}-net-ixgbe
+This package contains the Linux driver for the Intel(R) 10 Gigabit
+adapters with 82598 chipset.
+
+%description -n kernel%{_alt_kernel}-net-ixgbe -l pl.UTF-8
+Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych
+z rodziny Intel(R) 10 Gigabit opartych o układ 82598.
+
+%prep
+%setup -q -n %{pname}-%{version}
+cat > src/Makefile <<'EOF'
+obj-m := ixgbe.o
+ixgbe-objs := ixgbe_82598.o ixgbe_main.o ixgbe_param.o ixgbe_ethtool.o \
+kcompat.o ixgbe_api.o ixgbe_phy.o ixgbe_common.o
+
+EXTRA_CFLAGS=-DDRIVER_IXGBE
+EOF
+
+%build
+%build_kernel_modules -C src -m %{pname}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%install_kernel_modules -m src/%{pname} -d kernel/drivers/net -n %{pname} -s current
+# blacklist kernel module
+cat > $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/%{pname}.conf <<'EOF'
+blacklist ixgbe
+alias ixgbe ixgbe-current
+EOF
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -n kernel%{_alt_kernel}-net-ixgbe
+%depmod %{_kernel_ver}
+
+%postun        -n kernel%{_alt_kernel}-net-ixgbe
+%depmod %{_kernel_ver}
+
+%files -n kernel%{_alt_kernel}-net-ixgbe
+%defattr(644,root,root,755)
+%doc ixgbe.7 README
+/etc/modprobe.d/%{_kernel_ver}/%{pname}.conf
+/lib/modules/%{_kernel_ver}/kernel/drivers/net/%{pname}*.ko*
This page took 0.025686 seconds and 4 git commands to generate.