]> git.pld-linux.org Git - packages/irqbalance.git/blob - irqbalance.spec
- updated
[packages/irqbalance.git] / irqbalance.spec
1 Summary:        Balancing of IRQs between multiple CPUs
2 Summary(pl):    Rozdzielanie IRQ pomiêdzy wiele procesorów
3 Name:           irqbalance
4 Version:        0.13
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 #Source0:       http://people.redhat.com/arjanv/irqbalance/%{name}-%{version}.tar.gz
9 # Currently no known URL - taken from FC6 src.rpm:
10 Source0:        http://www.blues.gda.pl/SOURCES/%{name}-%{version}.tar.gz
11 # Source0-md5:  837f1d69e9b6ef0a58bbd4cf4e0d7f28
12 Source1:        %{name}.init
13 Patch0:         %{name}-opt.patch
14 Patch1:         %{name}-classes.patch
15 Patch2:         %{name}-norebalance-zeroints.patch
16 Patch3:         %{name}-pie.patch
17 # due to -fpie
18 BuildRequires:  gcc >= 5:3.4
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       rc-scripts
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 irqbalance is a daemon that evenly distributes IRQ load across
26 multiple CPUs for enhanced performance.
27
28 %description -l pl
29 Narzêdzie do rozdzielania przerwañ IRQ pomiêdzy wiele procesorów
30 w celu zwiêkszenia wydajno¶ci systemu.
31
32 %prep
33 %setup -q -n %{name}
34 %patch0 -p1
35 %patch1 -p2
36 %patch2 -p2
37 %patch3 -p2
38
39 %build
40 %{__make} \
41         CC="%{__cc}" \
42         CFLAGS="%{rpmcflags}%{?debug: debug.c -DDEBUG}" \
43         LDFLAGS="%{rpmldflags}"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man1,/etc/rc.d/init.d}
48
49 install %{name} $RPM_BUILD_ROOT%{_sbindir}
50 install %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
51 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /sbin/chkconfig --add irqbalance
58 %service irqbalance restart "irqbalance daemon"
59
60 %preun
61 if [ "$1" = "0" ]; then
62         %service irqbalance stop
63         /sbin/chkconfig --del irqbalance
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changelog TODO
69 %attr(755,root,root) %{_sbindir}/*
70 %{_mandir}/man1/*
71 %attr(754,root,root) /etc/rc.d/init.d/irqbalance
This page took 0.774169 seconds and 3 git commands to generate.