]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
- setuptools epoch
[packages/ipython.git] / ipython.spec
1 # NOTE: Python3 version in 'ipython3.spec'
2 #
3 # Conditional build:
4 %bcond_without  doc     # Sphinx documentation (disable for bootstrap)
5 %bcond_with     tests   # unit tests (need to wait for fulfilling dependencies in PLD)
6
7 Summary:        An enhanced Interactive Python shell
8 Summary(pl.UTF-8):      Interaktywna powłoka języka Python
9 Name:           ipython
10 Version:        5.10.0
11 Release:        3
12 License:        BSD
13 Group:          Applications/Shells
14 Source0:        http://archive.ipython.org/release/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  eae7393ed47415709df3823422571a49
16 Patch0:         %{name}-use-setuptools.patch
17 URL:            http://ipython.org/
18 BuildRequires:  pydoc >= 1:2.7
19 BuildRequires:  python-devel >= 1:2.7
20 BuildRequires:  python-devel-tools >= 1:2.7
21 BuildRequires:  python-modules-sqlite >= 1:2.7
22 BuildRequires:  python-setuptools >= 1:18.5
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.747
25 %if %{with tests}
26 BuildRequires:  python-backports.shutil_get_terminal_size
27 BuildRequires:  python-decorator
28 BuildRequires:  python-ipykernel
29 BuildRequires:  python-mock
30 BuildRequires:  python-nbformat
31 BuildRequires:  python-nose >= 0.10.1
32 BuildRequires:  python-pathlib2
33 BuildRequires:  python-pexpect
34 BuildRequires:  python-pickleshare
35 BuildRequires:  python-prompt_toolkit >= 1.0.4
36 BuildRequires:  python-prompt_toolkit < 2
37 BuildRequires:  python-pygments < 2.6
38 BuildRequires:  python-requests
39 BuildRequires:  python-simplegeneric >= 0.8
40 BuildRequires:  python-testpath
41 BuildRequires:  python-traitlets >= 4.2
42 %endif
43 %if %{with doc}
44 BuildRequires:  python-docutils
45 BuildRequires:  python-ipykernel
46 BuildRequires:  python-sphinx_rtd_theme
47 BuildRequires:  sphinx-pdg-2 >= 1.3
48 %endif
49 Requires:       python-%{name} = %{version}-%{release}
50 Suggests:       python-PyQt5
51 Suggests:       python-zmq
52 BuildArch:      noarch
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 IPython is a free software project which tries to:
57
58 1. Provide an interactive interpreter superior to Python's default.
59 IPython has many features for object introspection, shell access, and
60 its own special command system for adding functionality when working
61 interactively.
62
63 2. Serve as an embeddable, ready to use interpreter for your own
64 programs. IPython can be started with a single call from inside
65 another program, providing access to the current namespace. This can
66 be very useful both for debugging purposes and for situations where a
67 blend of batch-processing and interactive exploration are needed.
68
69 3. Offer a flexible framework which can be used as the base
70 environment for other systems with Python as the underlying language.
71 Specifically scientific environments like Mathematica, IDL and Mathcad
72 inspired its design, but similar ideas can be useful in many fields.
73
74 This package contains IPython shell.
75
76 %description -l pl.UTF-8
77 IPython jest wolnym oprogramowaniem, którego celem jest:
78
79 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
80 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
81 dostęp do powłoki oraz własny system poleceń, który umożliwia
82 rozszerzanie funkcjonalności podczas pracy interaktywnej.
83
84 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
85 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
86 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
87 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
88 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
89 wymagane połączenie przetwarzania wsadowego z interaktywną
90 introspekcją.
91
92 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
93 systemu, którego polecenia opierają się na zasadach języka Python.
94 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
95 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
96 w wielu przypadkach.
97
98 Pakiet ten zawiera powłokę IPython.
99
100 %package -n python-ipython
101 Summary:        An enhanced Interactive Python shell modules
102 Summary(pl.UTF-8):      Moduły interaktywnej powłoki języka Python
103 Group:          Libraries/Python
104 Requires:       pydoc >= 1:2.7
105 Requires:       python-devel-tools >= 1:2.7
106
107 %description -n python-ipython
108 IPython is a free software project which tries to:
109
110 1. Provide an interactive interpreter superior to Python's default.
111 IPython has many features for object introspection, shell access, and
112 its own special command system for adding functionality when working
113 interactively.
114
115 2. Serve as an embeddable, ready to use interpreter for your own
116 programs. IPython can be started with a single call from inside
117 another program, providing access to the current namespace. This can
118 be very useful both for debugging purposes and for situations where a
119 blend of batch-processing and interactive exploration are needed.
120
121 3. Offer a flexible framework which can be used as the base
122 environment for other systems with Python as the underlying language.
123 Specifically scientific environments like Mathematica, IDL and Mathcad
124 inspired its design, but similar ideas can be useful in many fields.
125
126 This package contains IPython modules.
127
128 %description -n python-ipython -l pl.UTF-8
129 IPython jest wolnym oprogramowaniem, którego celem jest:
130
131 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
132 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
133 dostęp do powłoki oraz własny system poleceń, który umożliwia
134 rozszerzanie funkcjonalności podczas pracy interaktywnej.
135
136 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
137 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
138 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
139 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
140 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
141 wymagane połączenie przetwarzania wsadowego z interaktywną
142 introspekcją.
143
144 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
145 systemu, którego polecenia opierają się na zasadach języka Python.
146 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
147 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
148 w wielu przypadkach.
149
150 Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
151
152 %prep
153 %setup -q
154 %patch0 -p1
155
156 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' \
157         examples/Embedding/embed_class_long.py \
158         "examples/IPython Kernel/ipython-get-history.py" \
159         "examples/IPython Kernel/gui"/gui-*.py
160
161 %build
162 %py_build
163
164 %if %{with tests}
165 LC_ALL=C.UTF-8 \
166 PYTHONPATH=$(pwd) \
167 %{__python} IPython/testing/iptest.py IPython
168 %endif
169
170 %if %{with doc}
171 PYTHONPATH=$(pwd) \
172 %{__make} -C docs html \
173         PYTHON=%{__python} \
174         SPHINXBUILD=sphinx-build-2
175 %endif
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
180
181 %py_install
182
183 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
184
185 %py_postclean
186
187 # test suite
188 %{__rm} $RPM_BUILD_ROOT%{_bindir}/iptest*
189 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/IPython/{core/tests,extensions/tests,lib/tests,terminal/tests,testing/tests,utils/tests}
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %files
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_bindir}/ipython
197 %attr(755,root,root) %{_bindir}/ipython2
198 %{_mandir}/man1/ipython.1*
199
200 %files -n python-ipython
201 %defattr(644,root,root,755)
202 %doc COPYING.rst README.rst
203 %{py_sitescriptdir}/IPython
204 %{py_sitescriptdir}/ipython-%{version}-py*.egg-info
205 %{_examplesdir}/%{name}-%{version}
This page took 0.096518 seconds and 3 git commands to generate.