]> git.pld-linux.org Git - packages/iproute2.git/commitdiff
- use libnetlink(3) man from sources (differs only by fixed typo)
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 25 Nov 2011 17:46:24 +0000 (17:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- package tc-hfsc(7) man
- don't package arpd(8) manual as arpd is not packaged here

Changed files:
    iproute2.spec -> 1.210
    libnetlink.3 -> 1.2

iproute2.spec
libnetlink.3 [deleted file]

index 597a935e56c904cbe8a640321ab8c8b85e95f0af..3389c986207d09bb17d884b15c37c0794a42ad83 100644 (file)
@@ -21,7 +21,6 @@ License:      GPL v2+
 Group:         Networking/Admin
 Source0:       http://kernel.org/pub/linux/utils/networking/iproute2/%{name}-%{version}.tar.xz
 # Source0-md5: 810cdc0ddc2409a7af7089588c6c9a68
-Source1:       libnetlink.3
 Patch0:                %{name}-build.patch
 Patch1:                %{name}-arp.patch
 Patch3:                %{name}-iptables.patch
@@ -38,7 +37,7 @@ URL:          http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
 BuildRequires: bison
 BuildRequires: db-devel
 BuildRequires: flex
-BuildRequires: iptables-devel >= 0:1.4.3
+BuildRequires: iptables-devel >= 0:1.4.5
 %if %{with atm}
 BuildRequires: linux-atm-devel
 %endif
@@ -60,6 +59,7 @@ BuildRequires:        texlive-latex
 BuildRequires: texlive-tex-babel
 %endif
 %endif
+Requires:      iptables-libs >= 0:1.4.5
 Obsoletes:     ifstat
 Obsoletes:     iproute
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -156,7 +156,7 @@ Dokumentacja do iproute zawiera "howto" oraz przykłady ustawień.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man{3,8},%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man{3,7,8},%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
 
 install -p ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
 cp -a etc/iproute2/rt_protos \
@@ -165,10 +165,13 @@ cp -a etc/iproute2/rt_protos \
        etc/iproute2/rt_tables \
        $RPM_BUILD_ROOT%{_sysconfdir}
 
+cp -a man/man3/*       $RPM_BUILD_ROOT%{_mandir}/man3
+cp -a man/man7/*       $RPM_BUILD_ROOT%{_mandir}/man7
 cp -a man/man8/*       $RPM_BUILD_ROOT%{_mandir}/man8
 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man3
+# arpd is not packaged here
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/arpd.8
 
 cp -a lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
 cp -a include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
@@ -198,7 +201,6 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_realms
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_scopes
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_tables
-%{_mandir}/man8/arpd.8*
 %{_mandir}/man8/ip.8*
 %{_mandir}/man8/lnstat.8*
 %{_mandir}/man8/routel.8*
@@ -209,6 +211,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/tc
 %dir %{_libdir}/tc
 %attr(755,root,root) %{_libdir}/tc/*.so
+%{_mandir}/man7/tc-hfsc.7*
 %{_mandir}/man8/tc.8*
 %{_mandir}/man8/tc-*.8*
 %endif
diff --git a/libnetlink.3 b/libnetlink.3
deleted file mode 100644 (file)
index 145f38d..0000000
+++ /dev/null
@@ -1,197 +0,0 @@
-.TH libnetlink 3
-.SH NAME
-libnetlink \- A library for accessing the netlink service
-.SH SYNOPSIS
-.nf
-#include <asm/types.h>
-.br
-#include <libnetlink.h>
-.br
-#include <linux/netlink.h>
-.br
-#include <linux/rtnetlink.h>
-.sp
-int rtnl_open(struct rtnl_handle *rth, unsigned subscriptions)
-.sp
-int rtnl_wilddump_request(struct rtnl_handle *rth, int family, int type)
-.sp
-int rtnl_send(struct rtnl_handle *rth, char *buf, int len)
-.sp
-int rtnl_dump_request(struct rtnl_handle *rth, int type, void *req, int len)
-.sp
-int rtnl_dump_filter(struct rtnl_handle *rth,
-                    int (*filter)(struct sockaddr_nl *, struct nlmsghdr *n, void *),
-                    void *arg1,
-                    int (*junk)(struct sockaddr_nl *,struct nlmsghdr *n, void *),
-                    void *arg2)
-.sp
-int rtnl_talk(struct rtnl_handle *rtnl, struct nlmsghdr *n, pid_t peer,
-             unsigned groups, struct nlmsghdr *answer,
-.br
-             int (*junk)(struct sockaddr_nl *,struct nlmsghdr *n, void *),
-.br
-             void *jarg)
-.sp
-int rtnl_listen(struct rtnl_handle *rtnl, 
-             int (*handler)(struct sockaddr_nl *,struct nlmsghdr *n, void *),
-             void *jarg)
-.sp
-int rtnl_from_file(FILE *rtnl, 
-             int (*handler)(struct sockaddr_nl *,struct nlmsghdr *n, void *),
-             void *jarg)
-.sp
-int addattr32(struct nlmsghdr *n, int maxlen, int type, __u32 data)
-.sp
-int addattr_l(struct nlmsghdr *n, int maxlen, int type, void *data, int alen)
-.sp
-int rta_addattr32(struct rtattr *rta, int maxlen, int type, __u32 data)
-.sp
-int rta_addattr_l(struct rtattr *rta, int maxlen, int type, void *data, int alen)
-.SH DESCRIPTION
-libnetlink provides a higher level interface to 
-.BR rtnetlink(7). 
-The read functions return 0 on success and a negative errno on failure.
-The send functions return the amount of data sent, or -1 on error.
-.TP 
-rtnl_open
-Open a rtnetlink socket and save the state into the
-.B rth
-handle. This handle is passed to all subsequent calls. 
-.B subscriptions
-is a bitmap of the rtnetlink multicast groups the socket will be
-a member of.
-
-.TP
-rtnl_wilddump_request
-Request a full dump of the 
-.B type
-database for
-.B family
-addresses.
-.B type
-is a rtnetlink message type. 
-.\" XXX
-
-.TP
-rtnl_dump_request
-Request a full dump of the 
-.B type 
-data buffer into 
-.B buf
-with maximum length of
-.B len.
-.B type
-is a rtnetlink message type.
-
-.TP
-rtnl_dump_filter
-Receive netlink data after a request and filter it.
-The
-.B filter
-callback checks if the received message is wanted. It gets the source
-address of the message, the message itself and
-.B arg1 
-as arguments. 0 as return means that the filter passed, a negative
-value is returned
-by
-.I rtnl_dump_filter 
-in case of error. NULL for 
-.I filter
-means to not use a filter.
-.B junk
-is used to filter messages not destined to the local socket.
-Only one message bundle is received. Unless there is no message 
-pending, this function does not block.
-
-.TP
-rtnl_listen
-Receive netlink data after a request and pass it to 
-.I handler.
-.B handler
-is a callback that gets the message source address, the message itself,
-and the
-.B jarg
-cookie as arguments. It will get called for all received messages.
-Only one message bundle is received. Unless there is no message 
-pending this function does not block.
-
-.TP
-rtnl_from_file
-Works like 
-.I rtnl_listen, 
-but reads a netlink message bundle from the file
-.B file
-and passes the messages to
-.B handler
-for parsing. The file contains raw data as received from a rtnetlink socket.
-.PP
-The following functions are useful to construct custom rtnetlink messages. For
-simple database dumping with filtering it is better to use the higher level
-functions above. See
-.BR rtnetlink(3)
-and
-.BR netlink(3)
-on how to generate a rtnetlink message. The following utility functions
-require a continuous buffer that already contains a netlink message header
-and a rtnetlink request. 
-
-.TP
-rtnl_send
-Send the rtnetlink message in
-.B buf
-of length
-.B len
-to handle
-.B rth.
-
-.TP
-addattr32
-Add a __u32 attribute of type
-.B type
-and with value
-.B data
-to netlink message
-.B n,
-which is part of a buffer of length
-.B maxlen.
-
-.TP
-addattr_l
-Add a variable length attribute of type
-.B type
-and with value
-.B data
-and
-.B alen
-length to netlink message
-.B n,
-which is part of a buffer of length
-.B maxlen.
-.B data 
-is copied.
-
-.TP
-rta_addattr32
-Initialize the rtnetlink attribute
-.B rta
-with a __u32 data value.
-
-.TP
-rta_addattr32
-Initialize the rtnetlink attribute
-.B rta
-with a variable length data value.
-
-.SH BUGS
-The functions sometimes use fprintf and exit when a fatal error occurs.
-This library should be named librtnetlink.
-
-.SH AUTHORS
-netlink/rtnetlink was designed and writen by Alexey Kuznetsov.
-Andi Kleen wrote the man page.
-
-.SH SEE ALSO
-.BR netlink(7),
-.BR rtnetlink(7)
-.br
-/usr/include/linux/rtnetlink.h
This page took 0.231658 seconds and 4 git commands to generate.