]> git.pld-linux.org Git - packages/iproute2.git/commitdiff
- patches for new llh
authorMariusz Mazur <mmazur@pld-linux.org>
Sun, 2 May 2004 09:52:34 +0000 (09:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    iproute2-Makefile.patch -> 1.2
    iproute2-llh.patch -> 1.2

iproute2-Makefile.patch
iproute2-llh.patch

index 8980c6992a146b7d26ac6de5ef1c322eebb6b97b..5c73c30a750b2234e2499200099a5eecc05333d5 100644 (file)
@@ -1,12 +1,17 @@
---- iproute2/Makefile.orig     2002-01-16 00:30:32.000000000 +0100
-+++ iproute2/Makefile  2004-04-04 22:19:16.964825648 +0200
-@@ -4,13 +4,11 @@
- CONFDIR=/etc/iproute2
- DOCDIR=/usr/doc/iproute2
+--- iproute2/misc/Makefile.orig        2002-01-16 00:30:32.000000000 +0100
++++ iproute2/misc/Makefile     2004-04-04 22:23:44.718120960 +0200
+@@ -6,7 +6,7 @@
+ RTSTATOBJ=rtstat.o
  
--KERNEL_INCLUDE=/usr/src/linux/include
--LIBC_INCLUDE=/usr/include
+ ALLOBJ=$(SSOBJ) $(NSTATOBJ) $(IFSTATOBJ) $(RTACCTOBJ) $(ARPDOBJ) $(RTSTATOBJ)
+-TARGETS=ss nstat ifstat rtacct arpd rtstat
++TARGETS=ss nstat ifstat rtacct rtstat
  
+ all: $(TARGETS)
+--- iproute2/Makefile~ 2004-05-01 21:30:53.000000000 +0000
++++ iproute2/Makefile  2004-05-01 21:33:14.000000000 +0000
+@@ -8,7 +8,7 @@
  DEFINES= -DRESOLVE_HOSTNAMES
  
  #options if you have a bind>=4.9.4 libresolv (or, maybe, glibc)
  ADDLIB=
  
  #options if you compile with libc5, and without a bind>=4.9.4 libresolv
-@@ -23,19 +21,9 @@
- #options for ipx
- ADDLIB+=ipx_ntop.o ipx_pton.o
+@@ -24,7 +24,7 @@
  
--ifeq ($(LIBC_INCLUDE)/socketbits.h,$(wildcard $(LIBC_INCLUDE)/socketbits.h))
--  ifeq ($(LIBC_INCLUDE)/net/if_packet.h,$(wildcard $(LIBC_INCLUDE)/net/if_packet.h))
--    GLIBCFIX=-I../include-glibc -include ../include-glibc/glibc-bugs.h
--  endif
--endif
--ifeq ($(LIBC_INCLUDE)/bits/socket.h,$(wildcard $(LIBC_INCLUDE)/bits/socket.h))
--  GLIBCFIX=-I../include-glibc -I/usr/include/db3 -include ../include-glibc/glibc-bugs.h
--endif
--
--
  CC = gcc
 -CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g
--CFLAGS = $(CCOPTS) $(GLIBCFIX) -I$(KERNEL_INCLUDE) -I../include $(DEFINES)
 +CCOPTS = -D_GNU_SOURCE $(OPT) -Wstrict-prototypes -Wall -g
-+CFLAGS = $(CCOPTS) -I../include $(DEFINES)
+ CFLAGS = $(CCOPTS) -I../include $(DEFINES)
  
  LDLIBS += -L../lib -lnetlink -lutil
-@@ -43,20 +31,10 @@
- LIBNETLINK=../lib/libnetlink.a ../lib/libutil.a
--all: check-kernel
--      @set -e; \
-+all:
-       for i in $(SUBDIRS); \
-       do $(MAKE) -C $$i; done
--check-kernel:
--ifeq ($(KERNEL_INCLUDE),)
--      @echo "Please, set correct KERNEL_INCLUDE"; false
--else
--      @set -e; \
--      if [ ! -r $(KERNEL_INCLUDE)/linux/autoconf.h ]; then \
--              echo "Please, compile the kernel first"; false; fi
--endif
--
- install: all
-       install -m 0755 -d $(DESTDIR)$(SBINDIR)
-       install -m 0755 -d $(DESTDIR)$(CONFDIR)
---- iproute2/misc/Makefile.orig        2002-01-16 00:30:32.000000000 +0100
-+++ iproute2/misc/Makefile     2004-04-04 22:23:44.718120960 +0200
-@@ -6,7 +6,7 @@
- RTSTATOBJ=rtstat.o
- ALLOBJ=$(SSOBJ) $(NSTATOBJ) $(IFSTATOBJ) $(RTACCTOBJ) $(ARPDOBJ) $(RTSTATOBJ)
--TARGETS=ss nstat ifstat rtacct arpd rtstat
-+TARGETS=ss nstat ifstat rtacct rtstat
- all: $(TARGETS)
index 250e648ee08807f584f416c6ac1503aa3e27a3c2..e40c20599c413ce568aa6715844e3ab78d54571c 100644 (file)
---- iproute2/include/rt_names.h.orig   2000-04-16 19:42:50.000000000 +0200
-+++ iproute2/include/rt_names.h        2004-04-04 22:27:06.235485664 +0200
+diff -urN iproute2.orig/Makefile iproute2/Makefile
+--- iproute2.orig/Makefile     2002-01-15 23:30:32.000000000 +0000
++++ iproute2/Makefile  2004-05-01 15:46:50.000000000 +0000
+@@ -4,7 +4,5 @@
+ CONFDIR=/etc/iproute2
+ DOCDIR=/usr/doc/iproute2
+-KERNEL_INCLUDE=/usr/src/linux/include
+-LIBC_INCLUDE=/usr/include
+ DEFINES= -DRESOLVE_HOSTNAMES
+@@ -23,19 +22,11 @@
+ #options for ipx
+ ADDLIB+=ipx_ntop.o ipx_pton.o
+-ifeq ($(LIBC_INCLUDE)/socketbits.h,$(wildcard $(LIBC_INCLUDE)/socketbits.h))
+-  ifeq ($(LIBC_INCLUDE)/net/if_packet.h,$(wildcard $(LIBC_INCLUDE)/net/if_packet.h))
+-    GLIBCFIX=-I../include-glibc -include ../include-glibc/glibc-bugs.h
+-  endif
+-endif
+-ifeq ($(LIBC_INCLUDE)/bits/socket.h,$(wildcard $(LIBC_INCLUDE)/bits/socket.h))
+-  GLIBCFIX=-I../include-glibc -I/usr/include/db3 -include ../include-glibc/glibc-bugs.h
+-endif
+ CC = gcc
+ CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g
+-CFLAGS = $(CCOPTS) $(GLIBCFIX) -I$(KERNEL_INCLUDE) -I../include $(DEFINES)
++CFLAGS = $(CCOPTS) -I../include $(DEFINES)
+ LDLIBS += -L../lib -lnetlink -lutil
+@@ -43,19 +34,11 @@
+ LIBNETLINK=../lib/libnetlink.a ../lib/libutil.a
+-all: check-kernel
++all:
+       @set -e; \
+       for i in $(SUBDIRS); \
+       do $(MAKE) -C $$i; done
+-check-kernel:
+-ifeq ($(KERNEL_INCLUDE),)
+-      @echo "Please, set correct KERNEL_INCLUDE"; false
+-else
+-      @set -e; \
+-      if [ ! -r $(KERNEL_INCLUDE)/linux/autoconf.h ]; then \
+-              echo "Please, compile the kernel first"; false; fi
+-endif
+ install: all
+       install -m 0755 -d $(DESTDIR)$(SBINDIR)
+diff -urN iproute2.orig/include/rt_names.h iproute2/include/rt_names.h
+--- iproute2.orig/include/rt_names.h   2000-04-16 17:42:50.000000000 +0000
++++ iproute2/include/rt_names.h        2004-05-01 15:50:25.000000000 +0000
 @@ -1,6 +1,8 @@
  #ifndef RT_NAMES_H_
  #define RT_NAMES_H_ 1
  
-+#include <asm/types.h>
++#include <asm/byteorder.h>
 +
  const char* rtnl_rtprot_n2a(int id, char *buf, int len);
  const char* rtnl_rtscope_n2a(int id, char *buf, int len);
  const char* rtnl_rttable_n2a(int id, char *buf, int len);
---- iproute2/include/utils.h.orig      2002-01-08 20:41:16.000000000 +0100
-+++ iproute2/include/utils.h   2004-04-04 22:27:25.495557688 +0200
-@@ -1,6 +1,7 @@
- #ifndef __UTILS_H__
- #define __UTILS_H__ 1
-+#include <asm/byteorder.h>
- #include <asm/types.h>
- #include <resolv.h>
---- iproute2/lib/rt_names.c.orig       2000-04-16 19:42:52.000000000 +0200
-+++ iproute2/lib/rt_names.c    2004-04-04 22:33:06.876659872 +0200
+diff -urN iproute2.orig/lib/rt_names.c iproute2/lib/rt_names.c
+--- iproute2.orig/lib/rt_names.c       2000-04-16 17:42:52.000000000 +0000
++++ iproute2/lib/rt_names.c    2004-05-01 15:49:52.000000000 +0000
 @@ -16,6 +16,7 @@
  #include <fcntl.h>
  #include <string.h>
  #include <sys/time.h>
-+#include "rt_names.h"
++#include <asm/byteorder.h>
  
  static void rtnl_tab_initialize(char *file, char **tab, int size)
  {
-@@ -79,7 +80,7 @@
-                           rtnl_rtprot_tab, 256);
- }
--char * rtnl_rtprot_n2a(int id, char *buf, int len)
-+const char * rtnl_rtprot_n2a(int id, char *buf, int len)
- {
-       if (id<0 || id>=256) {
-               snprintf(buf, len, "%d", id);
-@@ -95,7 +96,7 @@
-       return buf;
- }
--int rtnl_rtprot_a2n(__u32 *id, char *arg)
-+int rtnl_rtprot_a2n(int *id, char *arg)
- {
-       static char *cache = NULL;
-       static unsigned long res;
-@@ -146,7 +147,7 @@
-                           rtnl_rtscope_tab, 256);
- }
--char * rtnl_rtscope_n2a(int id, char *buf, int len)
-+const char * rtnl_rtscope_n2a(int id, char *buf, int len)
- {
-       if (id<0 || id>=256) {
-               snprintf(buf, len, "%d", id);
-@@ -162,7 +163,7 @@
-       return buf;
- }
--int rtnl_rtscope_a2n(__u32 *id, char *arg)
-+int rtnl_rtscope_a2n(int *id, char *arg)
- {
-       static char *cache = NULL;
-       static unsigned long res;
-@@ -209,7 +210,7 @@
-                           rtnl_rtrealm_tab, 256);
- }
--char * rtnl_rtrealm_n2a(int id, char *buf, int len)
-+const char * rtnl_rtrealm_n2a(int id, char *buf, int len)
- {
-       if (id<0 || id>=256) {
-               snprintf(buf, len, "%d", id);
-@@ -275,7 +276,7 @@
-                           rtnl_rttable_tab, 256);
- }
--char * rtnl_rttable_n2a(int id, char *buf, int len)
-+const char * rtnl_rttable_n2a(int id, char *buf, int len)
- {
-       if (id<0 || id>=256) {
-               snprintf(buf, len, "%d", id);
-@@ -291,7 +292,7 @@
-       return buf;
- }
--int rtnl_rttable_a2n(__u32 *id, char *arg)
-+int rtnl_rttable_a2n(int *id, char *arg)
- {
-       static char *cache = NULL;
-       static unsigned long res;
-@@ -337,7 +338,7 @@
-                           rtnl_rtdsfield_tab, 256);
- }
--char * rtnl_dsfield_n2a(int id, char *buf, int len)
-+const char * rtnl_dsfield_n2a(int id, char *buf, int len)
- {
-       if (id<0 || id>=256) {
-               snprintf(buf, len, "%d", id);
---- iproute2/misc/rtstat.c.orig        2001-12-24 22:44:30.000000000 +0100
-+++ iproute2/misc/rtstat.c     2004-04-04 22:34:44.865763264 +0200
-@@ -14,6 +14,7 @@
-  */
- #include <stdio.h>
-+#include <stdlib.h>
+diff -urN iproute2.orig/misc/arpd.c iproute2/misc/arpd.c
+--- iproute2.orig/misc/arpd.c  2002-01-10 04:02:26.000000000 +0000
++++ iproute2/misc/arpd.c       2004-05-01 17:19:54.000000000 +0000
+@@ -16,7 +16,7 @@
  #include <unistd.h>
- #include <getopt.h>
---- iproute2/misc/ssfilter.y.orig      2001-12-25 21:07:50.000000000 +0100
-+++ iproute2/misc/ssfilter.y   2004-04-04 22:40:40.134754168 +0200
-@@ -1,6 +1,7 @@
- %{
- #include <stdio.h>
-+#include <stdlib.h>
- #include <malloc.h>
- #include <string.h>
- #include "ssfilter.h"
+ #include <stdlib.h>
+ #include <netdb.h>
+-#include <db.h>
++#include <db_185.h>
+ #include <sys/ioctl.h>
+ #include <sys/poll.h>
+ #include <errno.h>
+@@ -28,6 +28,7 @@
+ #include <signal.h>
+ #include <linux/if.h>
+ #include <linux/if_arp.h>
++#include <linux/if_ether.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <linux/if_packet.h>
This page took 0.161763 seconds and 4 git commands to generate.