]> git.pld-linux.org Git - packages/iproute2.git/commitdiff
- new
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 16 Jun 2004 19:12:51 +0000 (19:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    iproute2-build.patch -> 1.1

iproute2-build.patch [new file with mode: 0644]

diff --git a/iproute2-build.patch b/iproute2-build.patch
new file mode 100644 (file)
index 0000000..b1a46d5
--- /dev/null
@@ -0,0 +1,63 @@
+diff -urN iproute2-2.6.7.org/include/rt_names.h iproute2-2.6.7/include/rt_names.h
+--- iproute2-2.6.7.org/include/rt_names.h      2004-06-16 21:07:09.457517808 +0200
++++ iproute2-2.6.7/include/rt_names.h  2004-06-16 21:12:26.790275896 +0200
+@@ -1,6 +1,8 @@
+ #ifndef RT_NAMES_H_
+ #define RT_NAMES_H_ 1
++#include <asm/byteorder.h>
++
+ const char* rtnl_rtprot_n2a(int id, char *buf, int len);
+ const char* rtnl_rtscope_n2a(int id, char *buf, int len);
+ const char* rtnl_rttable_n2a(int id, char *buf, int len);
+diff -urN iproute2-2.6.7.org/lib/rt_names.c iproute2-2.6.7/lib/rt_names.c
+--- iproute2-2.6.7.org/lib/rt_names.c  2004-06-16 21:07:09.400526472 +0200
++++ iproute2-2.6.7/lib/rt_names.c      2004-06-16 21:10:48.897157912 +0200
+@@ -16,6 +16,7 @@
+ #include <fcntl.h>
+ #include <string.h>
+ #include <sys/time.h>
++#include <asm/byteorder.h>
+ static void rtnl_tab_initialize(char *file, char **tab, int size)
+ {
+diff -urN iproute2-2.6.7.org/Makefile iproute2-2.6.7/Makefile
+--- iproute2-2.6.7.org/Makefile        2004-06-16 21:07:09.445519632 +0200
++++ iproute2-2.6.7/Makefile    2004-06-16 21:10:12.256728104 +0200
+@@ -4,13 +4,10 @@
+ CONFDIR=/etc/iproute2
+ DOCDIR=/usr/doc/iproute2
+-KERNEL_INCLUDE=/usr/include
+-LIBC_INCLUDE=/usr/include
+-
+ DEFINES= -DRESOLVE_HOSTNAMES
+ #options if you have a bind>=4.9.4 libresolv (or, maybe, glibc)
+-LDLIBS=-lresolv
++LDLIBS=
+ ADDLIB=
+ #options if you compile with libc5, and without a bind>=4.9.4 libresolv
+@@ -23,19 +20,9 @@
+ #options for ipx
+ ADDLIB+=ipx_ntop.o ipx_pton.o
+-ifeq ($(LIBC_INCLUDE)/socketbits.h,$(wildcard $(LIBC_INCLUDE)/socketbits.h))
+-  ifeq ($(LIBC_INCLUDE)/net/if_packet.h,$(wildcard $(LIBC_INCLUDE)/net/if_packet.h))
+-    GLIBCFIX=-I../include-glibc -include ../include-glibc/glibc-bugs.h
+-  endif
+-endif
+-ifeq ($(LIBC_INCLUDE)/bits/socket.h,$(wildcard $(LIBC_INCLUDE)/bits/socket.h))
+-  GLIBCFIX=-I../include-glibc -I/usr/include/db3 -include ../include-glibc/glibc-bugs.h
+-endif
+-
+-
+ CC = gcc
+-CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g
+-CFLAGS = $(CCOPTS) $(GLIBCFIX) -I$(KERNEL_INCLUDE) -I../include $(DEFINES)
++CCOPTS = -D_GNU_SOURCE $(OPT) -Wstrict-prototypes -Wall -g
++CFLAGS = $(CCOPTS) -I../include $(DEFINES)
+ LDLIBS += -L../lib -lnetlink -lutil
This page took 0.315638 seconds and 4 git commands to generate.