]> git.pld-linux.org Git - packages/iproute2.git/commitdiff
- fix compiler warning:
authorPaweł Sikora <pluto@pld-linux.org>
Tue, 25 Jan 2005 09:36:51 +0000 (09:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  `implicit declaration of function `__constant_htons'`
  and linker error:
  `iptunnel.c: undefined reference to `__constant_htons'`.

Changed files:
    iproute2-build.patch -> 1.5

iproute2-build.patch

index 9d5038889022f429bc7f41ea199a5c04f3dbdf1b..a88f5bbc435d3caa684633fbd3f180912ad3f861 100644 (file)
@@ -19,3 +19,13 @@ diff -urN iproute2-2.6.8.org/Makefile iproute2-2.6.8/Makefile
  CFLAGS = $(CCOPTS) -I../include $(DEFINES)
  
  LDLIBS += -L../lib -lnetlink -lutil
+--- iproute2-050124/ip/iptunnel.c.orig 2005-01-25 01:13:46.000000000 +0100
++++ iproute2-050124/ip/iptunnel.c      2005-01-25 10:26:02.716547608 +0100
+@@ -16,6 +16,7 @@
+  * Phil Karn <karn@ka9q.ampr.org>     990408: "pmtudisc" flag
+  */
++#include <asm/byteorder.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
This page took 0.193484 seconds and 4 git commands to generate.