]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- for time being use tetex deps in Titanium
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - fix iface_descr patch
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 #%bcond_with    iface_descr     # build with interface description support
12 #
13 Summary:        Utility to control Networking behavior in.X kernels
14 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl.UTF-8):      Narzędzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
19 Version:        2.6.34
20 Release:        3
21 License:        GPL
22 Group:          Networking/Admin
23 Source0:        http://devresources.linux-foundation.org/dev/iproute2/download/%{name}-%{version}.tar.bz2
24 # Source0-md5:  5c5742bdac05a1688f266512e685b83c
25 Source1:        libnetlink.3
26 Patch0:         %{name}-build.patch
27 Patch1:         %{name}-arp.patch
28 Patch3:         %{name}-iptables.patch
29 Patch4:         %{name}-iptables64.patch
30 Patch5:         %{name}-LDFLAGS.patch
31 # extensions
32 Patch10:        %{name}-2.2.4-wrr.patch
33 Patch11:        esfq-%{name}.patch
34 Patch12:        001-net-dev-iface-descr-0.1.diff
35 Patch13:        %{name}-q_atm_c.patch
36 Patch14:        %{name}-q_srr.v0.4.patch
37 URL:            http://linux-net.osdl.org/index.php/Iproute2
38 BuildRequires:  bison
39 BuildRequires:  db-devel
40 BuildRequires:  flex
41 BuildRequires:  iptables-devel >= 0:1.4.3
42 %if %{with atm}
43 BuildRequires:  linux-atm-devel
44 %endif
45 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
46 %if %{with doc}
47 BuildRequires:  psutils
48 BuildRequires:  sgml-tools
49 %if "%{pld_release}" != "th"
50 BuildRequires:  tetex-dvips
51 BuildRequires:  tetex-fonts-jknappen
52 BuildRequires:  tetex-format-latex
53 BuildRequires:  tetex-metafont
54 BuildRequires:  tetex-tex-babel
55 %else
56 BuildRequires:  texlive-dvips
57 BuildRequires:  texlive-fonts-cmsuper
58 BuildRequires:  texlive-fonts-jknappen
59 BuildRequires:  texlive-latex
60 BuildRequires:  texlive-tex-babel
61 %endif
62 %endif
63 Obsoletes:      ifstat
64 Obsoletes:      iproute
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _sbindir        /sbin
68 %define         _sysconfdir     /etc/iproute2
69
70 %description
71 Linux maintains compatibility with the basic configuration utilities
72 of the network (ifconfig, route) but a new utility is required to
73 exploit the new characteristics and features of the kernel. This
74 package includes the new utilities.
75
76 %description -l es.UTF-8
77 Linux mantiene compatibilidad con los utilitarios estándares de
78 configuración de la red, pero se necesitan nuevos utilitarios para
79 usar los recursos y características del nuevo núcleo. Este paquete
80 incluye los nuevos utilitarios.
81
82 %description -l pl.UTF-8
83 Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
84 aspektów dotyczących sieci.
85
86 %description -l pt_BR.UTF-8
87 O Linux mantém compatibilidade com os utilitários padrão de
88 configuração da rede, mas novos utilitários são necessários para fazer
89 uso das características e recursos da nova kernel. This package
90 includes the new utilities.
91
92 %package -n libnetlink-devel
93 Summary:        Library for the netlink interface
94 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
95 Group:          Development/Libraries
96
97 %description -n libnetlink-devel
98 This library provides an interface for kernel-user netlink interface.
99
100 %description -n libnetlink-devel -l pl.UTF-8
101 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
102 a przestrzenią użytkownika.
103
104 %prep
105 %setup -q
106 #rm -rf include/linux
107 %patch0 -p1
108 %patch1 -p1
109
110 %if "%{_lib}" == "lib64"
111 %patch4 -p1
112 %else
113 %patch3 -p1
114 %endif
115 %patch5 -p1
116
117 # extensions:
118 %patch10 -p1
119 %patch11 -p1
120 #%{?with_iface_descr:%patch12 -p1}
121 %patch13 -p0
122 %patch14 -p1
123
124 %build
125 %{__make} \
126 %if %{with uClibc}
127         CC="%{_target_cpu}-uclibc-gcc" \
128         LD="%{_target_cpu}-uclibc-gcc" \
129 %else
130         CC="%{__cc}" \
131         LD="%{__cc}" \
132 %endif
133         HOSTCC="%{__cc}" \
134         OPT="%{rpmcflags}" \
135         LDFLAGS="%{rpmldflags} -Wl,-export-dynamic" \
136         %{!?with_tc:SUBDIRS="lib ip misc"}
137
138 %{?with_doc:%{__make} -C doc}
139
140 # make sure we don't produce broken ip binary
141 ./ip/ip link add type vlan help 2>&1 | grep -q "VLANID :=" || exit 1
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man{3,8},%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
146
147 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
148 install etc/iproute2/rt_protos \
149         etc/iproute2/rt_realms \
150         etc/iproute2/rt_scopes \
151         etc/iproute2/rt_tables \
152         $RPM_BUILD_ROOT%{_sysconfdir}
153
154 cp -a man/man8/*        $RPM_BUILD_ROOT%{_mandir}/man8
155 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
156 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
157 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man3
158
159 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
160 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
161 %{?with_tc:install tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %files
167 %defattr(644,root,root,755)
168 %doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
169 %doc ChangeLog %{?with_doc:doc/*.ps}
170 %attr(755,root,root) %{_sbindir}/ifstat
171 %attr(755,root,root) %{_sbindir}/ip
172 %attr(755,root,root) %{_sbindir}/lnstat
173 %attr(755,root,root) %{_sbindir}/nstat
174 %attr(755,root,root) %{_sbindir}/routel
175 %attr(755,root,root) %{_sbindir}/rtacct
176 %attr(755,root,root) %{_sbindir}/rtmon
177 %attr(755,root,root) %{_sbindir}/ss
178 %attr(755,root,root) %{_sbindir}/tc
179 %dir %{_sysconfdir}
180 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_protos
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_realms
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_scopes
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_tables
184 %{_mandir}/man8/*
185 %{?with_tc:%dir %{_libdir}/tc}
186 %{?with_tc:%attr(755,root,root) %{_libdir}/tc/*.so}
187
188 %files -n libnetlink-devel
189 %defattr(644,root,root,755)
190 %{_libdir}/libnetlink.a
191 %{_includedir}/libnetlink.h
192 %{_mandir}/man3/libnetlink.3*
This page took 0.121528 seconds and 4 git commands to generate.