]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- s/Conflicts/Obsoletes ifstat
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_with     uClibc          # do some hacks to build with uClibc
9 %bcond_with     iec_complaint   # fix bitrate calculations
10 #
11 Summary:        Utility to control Networking behavior in.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define sdate   040702
17 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
18 Version:        2.6.8
19 Release:        2
20 License:        GPL
21 Vendor:         Stephen Hemminger <shemminger@osdl.org>
22 Group:          Networking/Admin
23 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-2.6.X-ss%{sdate}.tar.gz
24 # Source0-md5:  cecf5ee39e8d9033ad0a6f6af274cdab
25 Patch0:         %{name}-build.patch
26 Patch2:         %{name}-arp.patch
27 Patch4:         %{name}-ipaddress.patch
28 # extensions
29 Patch10:        %{name}-2.2.4-wrr.patch
30 Patch11:        %{name}-2.2.4-esfq.patch
31 Patch13:        %{name}-rates-1024-fix.patch
32 URL:            http://developer.osdl.org/dev/iproute2/
33 BuildRequires:  bison
34 BuildRequires:  linux-libc-headers >= 7:2.6.7.0-7
35 %if %{with doc}
36 BuildRequires:  psutils
37 BuildRequires:  sgml-tools
38 BuildRequires:  tetex-dvips
39 BuildRequires:  tetex-fonts-jknappen
40 BuildRequires:  tetex-format-latex
41 BuildRequires:  tetex-metafont
42 BuildRequires:  tetex-tex-babel
43 %endif
44 Obsoletes:      iproute
45 Obsoletes:      ifstat
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _sbindir        /sbin
49 %define         _sysconfdir     /etc/iproute2
50
51 %description
52 Linux maintains compatibility with the basic configuration
53 utilities of the network (ifconfig, route) but a new utility is
54 required to exploit the new characteristics and features of the
55 kernel. This package includes the new utilities.
56
57 %description -l es
58 Linux mantiene compatibilidad con los utilitarios estándares de
59 configuración de la red, pero se necesitan nuevos utilitarios para
60 usar los recursos y características del nuevo núcleo. Este paquete
61 incluye los nuevos utilitarios.
62
63 %description -l pl
64 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
65 aspektów dotycz±cych sieci.
66
67 %description -l pt_BR
68 O Linux mantém compatibilidade com os utilitários padrão de
69 configuração da rede, mas novos utilitários são necessários para fazer
70 uso das características e recursos da nova kernel. This package
71 includes the new utilities.
72
73 %package -n libnetlink-devel
74 Summary:        Library for the netlink interface
75 Summary(pl):    Biblioteka do interfejsu netlink
76 Group:          Development/Libraries
77
78 %description -n libnetlink-devel
79 This library provides an interface for kernel-user netlink interface.
80
81 %description -n libnetlink-devel -l pl
82 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
83 a przestrzeni± u¿ytkownika.
84
85 %prep
86 %setup -q
87 rm -rf include-glibc
88 %patch0 -p1
89 %patch2 -p1
90 %patch4 -p1
91
92 %patch10 -p1
93 %patch11 -p1
94 %{?with_iec_complaint:%patch13 -p1}
95
96 %build
97 %{__make} \
98         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
99         OPT="%{rpmcflags}" \
100         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
101
102 %{?with_doc:%{__make} -C doc}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
107
108 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
109 install etc/iproute2/rt_protos \
110         etc/iproute2/rt_realms \
111         etc/iproute2/rt_scopes \
112         etc/iproute2/rt_tables \
113         $RPM_BUILD_ROOT%{_sysconfdir}
114
115 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
116 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
117 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
118
119 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
120 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
128 %attr(755,root,root) %{_sbindir}/*
129 %dir %{_sysconfdir}
130 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
131 %{_mandir}/man8/*
132
133 %files -n libnetlink-devel
134 %defattr(644,root,root,755)
135 %{_libdir}/lib*.a
136 %{_includedir}/*.h
This page took 0.048188 seconds and 3 git commands to generate.