]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- BR: tetex-format-latex
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_with     uClibc          # do some hacks to build with uClibc
9 %bcond_with     iec_complaint   # fix bitrate calculations
10 #
11 Summary:        Utility to control Networking behavior in.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define sdate   040702
17 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
18 Version:        2.6.8
19 Release:        1
20 License:        GPL
21 Vendor:         Stephen Hemminger <shemminger@osdl.org>
22 Group:          Networking/Admin
23 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-2.6.X-ss%{sdate}.tar.gz
24 # Source0-md5:  cecf5ee39e8d9033ad0a6f6af274cdab
25 Patch0:         %{name}-build.patch
26 Patch2:         %{name}-arp.patch
27 Patch4:         %{name}-ipaddress.patch
28 # extensions
29 Patch10:        %{name}-2.2.4-wrr.patch
30 Patch11:        %{name}-2.2.4-esfq.patch
31 Patch13:        %{name}-rates-1024-fix.patch
32 URL:            http://developer.osdl.org/dev/iproute2/
33 BuildRequires:  bison
34 BuildRequires:  linux-libc-headers >= 7:2.6.7.0-7
35 %if %{with doc}
36 BuildRequires:  psutils
37 BuildRequires:  sgml-tools
38 BuildRequires:  tetex-dvips
39 BuildRequires:  tetex-format-latex
40 BuildRequires:  tetex-tex-babel
41 %endif
42 Obsoletes:      iproute
43 Conflicts:      ifstat
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _sbindir        /sbin
47 %define         _sysconfdir     /etc/iproute2
48
49 %description
50 Linux maintains compatibility with the basic configuration
51 utilities of the network (ifconfig, route) but a new utility is
52 required to exploit the new characteristics and features of the
53 kernel. This package includes the new utilities.
54
55 %description -l es
56 Linux mantiene compatibilidad con los utilitarios estándares de
57 configuración de la red, pero se necesitan nuevos utilitarios para
58 usar los recursos y características del nuevo núcleo. Este paquete
59 incluye los nuevos utilitarios.
60
61 %description -l pl
62 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
63 aspektów dotycz±cych sieci.
64
65 %description -l pt_BR
66 O Linux mantém compatibilidade com os utilitários padrão de
67 configuração da rede, mas novos utilitários são necessários para fazer
68 uso das características e recursos da nova kernel. This package
69 includes the new utilities.
70
71 %package -n libnetlink-devel
72 Summary:        Library for the netlink interface
73 Summary(pl):    Biblioteka do interfejsu netlink
74 Group:          Development/Libraries
75
76 %description -n libnetlink-devel
77 This library provides an interface for kernel-user netlink interface.
78
79 %description -n libnetlink-devel -l pl
80 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
81 a przestrzeni± u¿ytkownika.
82
83 %prep
84 %setup -q
85 rm -rf include-glibc
86 %patch0 -p1
87 %patch2 -p1
88 %patch4 -p1
89
90 %patch10 -p1
91 %patch11 -p1
92 %{?with_iec_complaint:%patch13 -p1}
93
94 %build
95 %{__make} \
96         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
97         OPT="%{rpmcflags}" \
98         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
99
100 %{?with_doc:%{__make} -C doc}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
105
106 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
107 install etc/iproute2/rt_protos \
108         etc/iproute2/rt_realms \
109         etc/iproute2/rt_scopes \
110         etc/iproute2/rt_tables \
111         $RPM_BUILD_ROOT%{_sysconfdir}
112
113 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
114 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
115 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
116
117 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
118 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
126 %attr(755,root,root) %{_sbindir}/*
127 %dir %{_sysconfdir}
128 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
129 %{_mandir}/man8/*
130
131 %files -n libnetlink-devel
132 %defattr(644,root,root,755)
133 %{_libdir}/lib*.a
134 %{_includedir}/*.h
This page took 0.043515 seconds and 3 git commands to generate.