]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
54df6f34cf05f6156e16cf6de56eb2ea49fd3a09
[packages/iproute2.git] / iproute2.spec
1 # conditional build
2 # --without tetex       # with tetex-2 there shuld be BR tetex-tex-babel
3 # --without tc (don't build tc program, it break static linkage)
4 # --without dist_kernel
5
6 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
7 %define mainver         2.4.7
8 %define snapshot        ss020116
9 Summary:        Utility to control Networking behavior in 2.2.X kernels
10 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
11 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
12 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
13 Name:           iproute2
14 Version:        %{mainver}.%{snapshot}
15 %define _rel    10
16 Release:        %{_rel}@%{_kernel_ver_str}
17 License:        GPL
18 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
19 Group:          Networking/Admin
20 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
21 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
22 Source1:        %{name}-owl-man.tar.bz2
23 # Source1-md5: cd4425df972a4ab001db31a5eb1c5da5
24 Patch0:         %{name}-make.patch
25 Patch1:         %{name}-uClibc.patch
26 Patch2:         %{name}-fix-2_2.patch
27 Patch3:         %{name}-label.patch
28 Patch4:         %{name}-latest.patch
29 Patch5:         %{name}-htb2_tc.patch
30 Patch6:         wrr-iproute2-2.2.4.patch
31 Patch7:         htb3.6_tc.patch
32 Patch8:         %{name}-no_libresolv.patch
33 Patch9:         %{name}-2.2.4-now-ss001007-esfq.diff
34 %{!?_without_tc:BuildRequires:  db-devel}
35 BuildRequires:  bison
36 %{!?_without_tetex:BuildRequires:       latex2html}
37 %{!?_without_tetex:BuildRequires:       psutils}
38 %{!?_without_tetex:BuildRequires:       sgml-tools}
39 %{!?_without_tetex:BuildRequires:       tetex-dvips}
40 %{!?_without_tetex:BuildRequires:       tetex-latex}
41 %{!?_without_tetex:BuildRequires:       tetex-tex-babel}
42 Obsoletes:      iproute
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sbindir        /sbin
46 %define         _sysconfdir     /etc/iproute2
47
48 %description
49 Linux 2.2 maintains compatibility with the basic configuration
50 utilities of the network (ifconfig, route) but a new utility is
51 required to exploit the new characteristics and features of the
52 kernel. This package includes the new utilities.
53
54 %description -l es
55 Linux mantiene compatibilidad con los utilitarios estándares de
56 configuración de la red, pero se necesitan nuevos utilitarios para
57 usar los recursos y características del nuevo núcleo. Este paquete
58 incluye los nuevos utilitarios.
59
60 %description -l pl
61 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
62 aspektów dotycz±cych sieci.
63
64 %description -l pt_BR
65 O Linux mantém compatibilidade com os utilitários padrão de
66 configuração da rede, mas novos utilitários são necessários para fazer
67 uso das características e recursos da nova kernel. This package
68 includes the new utilities.
69
70 %package -n libnetlink-devel
71 Summary:        Library for the netlink interface
72 Summary(pl):    Biblioteka do interfejsu netlink
73 Group:          Development/Libraries
74
75 %description -n libnetlink-devel
76 This library provides an interface for kernel-user netlink interface.
77
78 %description -n libnetlink-devel -l pl
79 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
80 a przestrzeni± u¿ytkownika.
81
82 %prep
83 %setup -q -n %{name} -a1
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 #%%patch3 -p1
88 #%%patch4 -p1
89 %if %{_kernel24}
90 %patch7 -p1
91 %else
92 %patch5 -p1
93 %endif
94 %patch6 -p1
95 %patch8 -p1
96 %patch9 -p1
97
98 %build
99 WRRDEF=""
100 grep -q tc_wrr_class_weight %{_kernelsrcdir}/include/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"
101
102 %{__make} \
103         CC="%{__cc}" \
104         OPT="%{rpmcflags} ${WRRDEF}" \
105         KERNEL_INCLUDE="%{_kernelsrcdir}/include" \
106         %{?_without_tc:SUBDIRS="lib ip" LDFLAGS="%{rpmldflags}"}
107 %{!?_without_tetex:%{__make} -C doc}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
112
113 install ip/{ip,rtmon,routel} %{!?_without_tc:tc/tc} $RPM_BUILD_ROOT%{_sbindir}
114 install etc/iproute2/rt_protos \
115         etc/iproute2/rt_realms \
116         etc/iproute2/rt_scopes \
117         etc/iproute2/rt_tables \
118         $RPM_BUILD_ROOT%{_sysconfdir}
119 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
120 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
121 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc README README.iproute2+tc RELNOTES
129 %{!?_without_tetex:%doc doc/*.ps}
130 %attr(755,root,root) %{_sbindir}/*
131 %dir %{_sysconfdir}
132 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
133 %{_mandir}/man8/*
134
135 %files -n libnetlink-devel
136 %defattr(644,root,root,755)
137 %{_libdir}/lib*.a
138 %{_includedir}/*.h
This page took 0.039587 seconds and 2 git commands to generate.