]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- small update: infiniband address decode added.
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - remove -DCONFIG_CLS_U32_PERF=1 when llh will be fixed
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 %bcond_with     iec_complaint   # fix bitrate calculations
12 #
13 Summary:        Utility to control Networking behavior in.X kernels
14 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 %define sdate   050209
19 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
20 Version:        2.6.10
21 Release:        0.3
22 License:        GPL
23 Vendor:         Stephen Hemminger <shemminger@osdl.org>
24 Group:          Networking/Admin
25 #Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-ss%{sdate}.tar.gz
26 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
27 # Source0-md5:  c00d07df1b9e574e4f6b66f79342c93b
28 #Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{sdate}.tar.gz
29 Patch0:         %{name}-build.patch
30 Patch1:         %{name}-arp.patch
31 # extensions
32 Patch10:        %{name}-2.2.4-wrr.patch
33 Patch11:        %{name}-2.2.4-esfq.patch
34 Patch13:        %{name}-rates-1024-fix.patch
35 URL:            http://developer.osdl.org/dev/iproute2/
36 BuildRequires:  bison
37 BuildRequires:  db-devel
38 %if %{with atm}
39 BuildRequires:  linux-atm-devel
40 %endif
41 BuildRequires:  linux-libc-headers >= 7:2.6.10.0-2
42 %if %{with doc}
43 BuildRequires:  psutils
44 BuildRequires:  sgml-tools
45 BuildRequires:  tetex-dvips
46 BuildRequires:  tetex-fonts-jknappen
47 BuildRequires:  tetex-format-latex
48 BuildRequires:  tetex-metafont
49 BuildRequires:  tetex-tex-babel
50 %endif
51 Obsoletes:      iproute
52 Obsoletes:      ifstat
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         _sbindir        /sbin
56 %define         _sysconfdir     /etc/iproute2
57
58 %description
59 Linux maintains compatibility with the basic configuration
60 utilities of the network (ifconfig, route) but a new utility is
61 required to exploit the new characteristics and features of the
62 kernel. This package includes the new utilities.
63
64 %description -l es
65 Linux mantiene compatibilidad con los utilitarios estándares de
66 configuración de la red, pero se necesitan nuevos utilitarios para
67 usar los recursos y características del nuevo núcleo. Este paquete
68 incluye los nuevos utilitarios.
69
70 %description -l pl
71 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
72 aspektów dotycz±cych sieci.
73
74 %description -l pt_BR
75 O Linux mantém compatibilidade com os utilitários padrão de
76 configuração da rede, mas novos utilitários são necessários para fazer
77 uso das características e recursos da nova kernel. This package
78 includes the new utilities.
79
80 %package -n libnetlink-devel
81 Summary:        Library for the netlink interface
82 Summary(pl):    Biblioteka do interfejsu netlink
83 Group:          Development/Libraries
84
85 %description -n libnetlink-devel
86 This library provides an interface for kernel-user netlink interface.
87
88 %description -n libnetlink-devel -l pl
89 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
90 a przestrzeni± u¿ytkownika.
91
92 %prep
93 %setup -q -n %{name}-2.6.9-%{sdate}
94 rm -rf include-glibc
95 %patch0 -p1
96 %patch1 -p1
97
98 %patch10 -p1
99 %patch11 -p1
100 %{?with_iec_complaint:%patch13 -p1}
101
102 %build
103 rm -rf include/linux
104
105 %{__make} \
106         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
107         OPT="%{rpmcflags} -DCONFIG_CLS_U32_PERF=1" \
108         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
109
110 %{?with_doc:%{__make} -C doc}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
115
116 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
117 install etc/iproute2/rt_protos \
118         etc/iproute2/rt_realms \
119         etc/iproute2/rt_scopes \
120         etc/iproute2/rt_tables \
121         $RPM_BUILD_ROOT%{_sysconfdir}
122
123 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
124 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
125 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
126
127 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
128 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
136 %attr(755,root,root) %{_sbindir}/*
137 %dir %{_sysconfdir}
138 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
139 %{_mandir}/man8/*
140
141 %files -n libnetlink-devel
142 %defattr(644,root,root,755)
143 %{_libdir}/lib*.a
144 %{_includedir}/*.h
This page took 0.038341 seconds and 3 git commands to generate.