]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- useless.
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_with     uClibc          # do some hacks to build with uClibc
9 %bcond_with     iec_complaint   # fix bitrate calculations
10 #
11 Summary:        Utility to control Networking behavior in 2.2.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define         mainver         2.4.7
17 %define         snapshot        ss020116
18 Version:        %{mainver}.%{snapshot}
19 Release:        17
20 License:        GPL
21 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
22 Group:          Networking/Admin
23 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
24 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
25 Source1:        %{name}-owl-man.tar.bz2
26 # Source1-md5:  cd4425df972a4ab001db31a5eb1c5da5
27 Patch0:         %{name}-llh.patch
28 Patch1:         %{name}-Makefile.patch
29 Patch2:         %{name}-diffserv-config.patch
30 Patch3:         %{name}-netlink.patch
31 Patch4:         %{name}-ipaddress.patch
32 Patch5:         %{name}-iprule.patch
33 # uClibc hacks
34 Patch6:         %{name}-uClibc.patch
35 # extensions
36 Patch10:        %{name}-htb3.6_tc.patch
37 Patch11:        %{name}-2.2.4-wrr.patch
38 Patch12:        %{name}-2.2.4-esfq.patch
39 Patch13:        %{name}-hfsc.patch
40 Patch14:        %{name}-rates-1024-fix.patch
41 BuildRequires:  bison
42 BuildRequires:  linux-libc-headers >= 7:2.6.5.1-4
43 %if %{with doc}
44 BuildRequires:  psutils
45 BuildRequires:  sgml-tools
46 BuildRequires:  tetex-dvips
47 BuildRequires:  tetex-latex
48 BuildRequires:  tetex-tex-babel
49 %endif
50 Obsoletes:      iproute
51 Conflicts:      ifstat
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _sbindir        /sbin
55 %define         _sysconfdir     /etc/iproute2
56
57 %description
58 Linux 2.2 maintains compatibility with the basic configuration
59 utilities of the network (ifconfig, route) but a new utility is
60 required to exploit the new characteristics and features of the
61 kernel. This package includes the new utilities.
62
63 %description -l es
64 Linux mantiene compatibilidad con los utilitarios estándares de
65 configuración de la red, pero se necesitan nuevos utilitarios para
66 usar los recursos y características del nuevo núcleo. Este paquete
67 incluye los nuevos utilitarios.
68
69 %description -l pl
70 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
71 aspektów dotycz±cych sieci.
72
73 %description -l pt_BR
74 O Linux mantém compatibilidade com os utilitários padrão de
75 configuração da rede, mas novos utilitários são necessários para fazer
76 uso das características e recursos da nova kernel. This package
77 includes the new utilities.
78
79 %package -n libnetlink-devel
80 Summary:        Library for the netlink interface
81 Summary(pl):    Biblioteka do interfejsu netlink
82 Group:          Development/Libraries
83
84 %description -n libnetlink-devel
85 This library provides an interface for kernel-user netlink interface.
86
87 %description -n libnetlink-devel -l pl
88 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
89 a przestrzeni± u¿ytkownika.
90
91 %prep
92 %setup -q -n %{name} -a1
93 rm -rf include-glibc
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98 %patch4 -p1
99 %patch5 -p1
100 %{?with_uClibc:%patch6 -p1}
101 %patch10 -p1
102 %patch11 -p1
103 %patch12 -p1
104 %patch13 -p1
105 %{?with_iec_complaint:%patch14 -p1}
106
107 %build
108 %{__make} \
109         CC="%{__cc}" \
110         OPT="%{rpmcflags}" \
111         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
112
113 %{?with_doc:%{__make} -C doc}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
118
119 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
120 install etc/iproute2/rt_protos \
121         etc/iproute2/rt_realms \
122         etc/iproute2/rt_scopes \
123         etc/iproute2/rt_tables \
124         $RPM_BUILD_ROOT%{_sysconfdir}
125 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
126 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
127 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
135 %attr(755,root,root) %{_sbindir}/*
136 %dir %{_sysconfdir}
137 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
138 %{_mandir}/man8/*
139
140 %files -n libnetlink-devel
141 %defattr(644,root,root,755)
142 %{_libdir}/lib*.a
143 %{_includedir}/*.h
This page took 0.039285 seconds and 3 git commands to generate.