]> git.pld-linux.org Git - packages/intel-graphics-compiler.git/commitdiff
up to 1.0.5353 auto/th/intel-graphics-compiler-1.0.5353-1
authorJan Palus <atler@pld-linux.org>
Fri, 30 Oct 2020 10:05:35 +0000 (11:05 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 30 Oct 2020 10:05:35 +0000 (11:05 +0100)
- disabled vector compiler (requires spirv sources)

cxx_flags.patch
intel-graphics-compiler.spec

index 8828f542c9c69e8816bb3760d7519202f25a709f..8c2029dc08251e959c3621d914eba4a663a1c1bf 100644 (file)
@@ -19,14 +19,14 @@ diff -dur -x '*~' intel-graphics-compiler-igc-1.0.8.orig/IGC/CMakeLists.txt inte
            -Wno-unknown-pragmas
            -fPIC
        )
-@@ -2838,7 +2834,6 @@
+@@ -2853,7 +2845,6 @@
          -Wno-gnu
          -finline
          -fkeep-inline-functions
 -        -msse4.2
-       )
-       if(NOT CMAKE_C_COMPILER_VERSION LESS "4.0")
-     igc_config_flag_apply_settings(
+     )
+     if(NOT CMAKE_C_COMPILER_VERSION LESS "4.0")
+       igc_config_flag_apply_settings(
 diff -dur -x '*~' intel-graphics-compiler-igc-1.0.8.orig/visa/iga/BuildSetup.cmake intel-graphics-compiler-igc-1.0.8/visa/iga/BuildSetup.cmake
 --- intel-graphics-compiler-igc-1.0.8.orig/visa/iga/BuildSetup.cmake   2019-06-08 02:25:42.000000000 +0200
 +++ intel-graphics-compiler-igc-1.0.8/visa/iga/BuildSetup.cmake        2019-07-03 08:50:44.202349668 +0200
index 70d5c9b1ab221568e30e98329f941f0d3a72ba9c..4af10032369438d13f3d2e9b9eb483dfd4cce17e 100644 (file)
@@ -1,17 +1,17 @@
 
 # requires the OpenCL patches
-%define llvm_version 10.0.0
+%define llvm_version 11.0.0
 
-%define opencl_clang_version 10.0.0
+%define opencl_clang_version 11.0.0
 
 Summary:       The Intel Graphics Compiler for OpenCL
 Name:          intel-graphics-compiler
-Version:       1.0.3698
+Version:       1.0.5353
 Release:       1
 License:       MIT
 Group:         Libraries
 Source0:       https://github.com/intel/intel-graphics-compiler/archive/igc-%{version}/igc-%{version}.tar.gz
-# Source0-md5: f43e51a3692bcdeae9c9715ac2802620
+# Source0-md5: bf101f596f63d1c9d6cddca10b9623ef
 Patch0:                pkgconfig.patch
 Patch1:                cxx_flags.patch
 URL:           https://github.com/intel/intel-graphics-compiler/
@@ -52,6 +52,8 @@ Pliki nagłówkowe biblioteki %{name}.
 %patch0 -p1
 %patch1 -p1
 
+%{__sed} -i -e 's/-Werror/-Werror -Wno-error=deprecated-declarations/' IGC/CMakeLists.txt
+
 %build
 install -d build
 cd build
@@ -60,6 +62,7 @@ cd build
        -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
        -DCCLANG_FROM_SYSTEM=ON \
        -DIGC_PREFERRED_LLVM_VERSION=%{llvm_version} \
+       -DIGC_BUILD__VC_ENABLED=OFF \
        ../
 %{__make}
 
This page took 0.02951 seconds and 4 git commands to generate.