]> git.pld-linux.org Git - packages/intel-graphics-compiler.git/blob - intel-graphics-compiler.spec
up to 1.0.2990
[packages/intel-graphics-compiler.git] / intel-graphics-compiler.spec
1
2 # requires the OpenCL patches
3 %define llvm_version 9.0.0
4
5 %define opencl_clang_version 9.0.0
6
7 Summary:        The Intel Graphics Compiler for OpenCL
8 Name:           intel-graphics-compiler
9 Version:        1.0.2990
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://github.com/intel/intel-graphics-compiler/archive/igc-%{version}/igc-%{version}.tar.gz
14 # Source0-md5:  094962e98106aa5781ab0965915c42b9
15 Patch0:         pkgconfig.patch
16 Patch1:         cxx_flags.patch
17 URL:            https://github.com/intel/intel-graphics-compiler/
18 BuildRequires:  llvm-devel >= %{llvm_version}
19 BuildRequires:  opencl-clang-devel >= %{opencl_clang_version}
20 BuildRequires:  cmake >= 3.2.0
21 BuildRequires:  pkgconfig
22 Requires:       %{name}-libs = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Intel Graphics Compiler for OpenCL is an LLVM based compiler for OpenCL
27 targeting Intel Gen graphics hardware architecture.
28
29 %package libs
30 Summary:        The Intel Graphics Compiler for OpenCL libraries
31 Group:          Libraries
32
33 %description libs
34 The Intel Graphics Compiler for OpenCL libraries.
35
36 %package devel
37 Summary:        Header files for %{name} library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
39 Group:          Development/Libraries
40 Requires:       llvm-devel >= %{llvm_version}
41 Requires:       %{name}-libs = %{version}-%{release}
42
43 %description devel
44 Header files for %{name} library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki %{name}.
48
49 %prep
50 %setup -qn %{name}-igc-%{version}
51
52 %patch0 -p1
53 %patch1 -p1
54
55 %build
56 install -d build
57 cd build
58 %cmake \
59         -DCMAKE_BUILD_TYPE=Release \
60         -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
61         -DCCLANG_FROM_SYSTEM=ON \
62         -DIGC_PREFERRED_LLVM_VERSION=%{llvm_version} \
63         ../
64 %{__make}
65
66 cd ..
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.md
80 %attr(755,root,root) %{_bindir}/GenX_IR
81 %ifarch %{x8664}
82 %attr(755,root,root) %{_bindir}/iga64
83 %else
84 %attr(755,root,root) %{_bindir}/iga32
85 %endif
86
87 %files libs
88 %defattr(644,root,root,755)
89 %ifarch %{x8664}
90 %attr(755,root,root) %{_libdir}/libiga64.so.1.*.*
91 %ghost %attr(755,root,root) %{_libdir}/libiga64.so.1
92 %else
93 %attr(755,root,root) %{_libdir}/libiga32.so.1.*.*
94 %ghost %attr(755,root,root) %{_libdir}/libiga32.so.1
95 %endif
96 %attr(755,root,root) %{_libdir}/libigc.so.1.*.*
97 %ghost %attr(755,root,root) %{_libdir}/libigc.so.1
98 %attr(755,root,root) %{_libdir}/libigdfcl.so.1.*.*
99 %ghost %attr(755,root,root) %{_libdir}/libigdfcl.so.1
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/iga
104 %{_includedir}/igc
105 %{_includedir}/visa
106 %ifarch %{x8664}
107 %attr(755,root,root) %{_libdir}/libiga64.so
108 %else
109 %attr(755,root,root) %{_libdir}/libiga32.so
110 %endif
111 %attr(755,root,root) %{_libdir}/libigc.so
112 %attr(755,root,root) %{_libdir}/libigdfcl.so
113 %{_pkgconfigdir}/igc-opencl.pc
This page took 0.158245 seconds and 4 git commands to generate.