]> git.pld-linux.org Git - packages/intel-graphics-compiler.git/blob - intel-graphics-compiler.spec
Release: 2
[packages/intel-graphics-compiler.git] / intel-graphics-compiler.spec
1
2 # requires the OpenCL patches
3 %define llvm_version 7.0.1-3
4
5 %define opencl_clang_version 8.0.1
6
7 Summary:        The Intel Graphics Compiler for OpenCL
8 Name:           intel-graphics-compiler
9 Version:        1.0.8
10 Release:        2
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://github.com/intel/intel-graphics-compiler/archive/igc-%{version}/igc-%{version}.tar.gz
14 # Source0-md5:  9999fd7b6947b2ed0a11f7b07b1e7acc
15 Patch0:         pkgconfig.patch
16 Patch1:         cxx_flags.patch
17 URL:            https://github.com/intel/intel-graphics-compiler/
18 BuildRequires:  llvm-devel >= %{llvm_version}
19 BuildRequires:  opencl-clang-devel >= %{opencl_clang_version}
20 BuildRequires:  cmake >= 3.2.0
21 BuildRequires:  pkgconfig
22 Requires:       %{name}-libs = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Intel Graphics Compiler for OpenCL is an LLVM based compiler for OpenCL
27 targeting Intel Gen graphics hardware architecture.
28
29 %package libs
30 Summary:        The Intel Graphics Compiler for OpenCL libraries
31 Group:          Libraries
32
33 %description libs
34 The Intel Graphics Compiler for OpenCL libraries.
35
36 %package devel
37 Summary:        Header files for %{name} library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
39 Group:          Development/Libraries
40 Requires:       llvm-devel >= %{llvm_version}
41 Requires:       %{name}-libs = %{version}-%{release}
42
43 %description devel
44 Header files for %{name} library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki %{name}.
48
49 %prep
50 %setup -qn %{name}-igc-%{version}
51
52 %patch0 -p1
53 %patch1 -p1
54
55 %build
56 install -d build
57 cd build
58 %cmake \
59         -DCMAKE_BUILD_TYPE=Release \
60         -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
61         -DCCLANG_FROM_SYSTEM=ON \
62         ../
63 %{__make}
64
65 cd ..
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README.md
79 %attr(755,root,root) %{_bindir}/GenX_IR
80 %ifarch %{x8664}
81 %attr(755,root,root) %{_bindir}/iga64
82 %else
83 %attr(755,root,root) %{_bindir}/iga32
84 %endif
85
86 %files libs
87 %defattr(644,root,root,755)
88 %ifarch %{x8664}
89 %attr(755,root,root) %{_libdir}/libiga64.so.1.*.*
90 %ghost %attr(755,root,root) %{_libdir}/libiga64.so.1
91 %else
92 %attr(755,root,root) %{_libdir}/libiga32.so.1.*.*
93 %ghost %attr(755,root,root) %{_libdir}/libiga32.so.1
94 %endif
95 %attr(755,root,root) %{_libdir}/libigc.so.1.*.*
96 %ghost %attr(755,root,root) %{_libdir}/libigc.so.1
97 %attr(755,root,root) %{_libdir}/libigdfcl.so.1.*.*
98 %ghost %attr(755,root,root) %{_libdir}/libigdfcl.so.1
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_includedir}/igc
103 %ifarch %{x8664}
104 %attr(755,root,root) %{_libdir}/libiga64.so
105 %else
106 %attr(755,root,root) %{_libdir}/libiga32.so
107 %endif
108 %attr(755,root,root) %{_libdir}/libigc.so
109 %attr(755,root,root) %{_libdir}/libigdfcl.so
110 %{_pkgconfigdir}/igc-opencl.pc
This page took 0.100759 seconds and 4 git commands to generate.