]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- fix building with poppler 0.69
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_with     dbus            # DBus interface
4 %bcond_with     gtk3            # GTK+ 3 interface [experimental]
5 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
6 %bcond_with     relocation      # Enable binary relocation support
7 #
8
9 Summary:        Scalable vector graphics editor
10 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
11 Name:           inkscape
12 Version:        0.92.3
13 Release:        4
14 License:        GPL v2+, LGPL v2.1+
15 Group:          X11/Applications/Graphics
16 Source0:        https://media.inkscape.org/dl/resources/file/%{name}-%{version}.tar.bz2
17 # Source0-md5:  4ef7171cc1de9e1608d8c49b77fed99e
18 Patch0:         %{name}-man.patch
19 Patch1:         %{name}-gtk3.patch
20 Patch2:         %{name}-poppler.patch
21 Patch3:         poppler0.69.patch
22 URL:            http://www.inkscape.org/
23 BuildRequires:  ImageMagick-c++-devel
24 BuildRequires:  aspell-devel
25 BuildRequires:  autoconf >= 2.64
26 BuildRequires:  automake >= 1:1.9.4-2
27 BuildRequires:  boost-devel >= 1.36
28 BuildRequires:  cairo-devel >= 1.10
29 BuildRequires:  cairomm-devel >= 1.9.8
30 %{?with_dbus:BuildRequires:     dbus-glib-devel}
31 BuildRequires:  freetype-devel >= 2.0
32 BuildRequires:  gc-devel >= 7.2
33 BuildRequires:  gettext-tools >= 0.17
34 BuildRequires:  glib2-devel >= 1:2.28
35 BuildRequires:  glibmm-devel >= 2.28
36 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
37 BuildRequires:  gsl-devel
38 BuildRequires:  intltool >= 0.40.0
39 BuildRequires:  lcms2-devel >= 2
40 BuildRequires:  libcdr-devel >= 0.1
41 BuildRequires:  libexif-devel
42 BuildRequires:  libgomp-devel
43 BuildRequires:  libjpeg-devel
44 BuildRequires:  libpng-devel >= 1.2
45 BuildRequires:  librevenge-devel
46 BuildRequires:  libsigc++-devel >= 2.0.17
47 BuildRequires:  libstdc++-devel >= 6:4.7
48 BuildRequires:  libtool >= 2:2.2
49 BuildRequires:  libvisio-devel >= 0.1
50 BuildRequires:  libwpd-devel >= 0.9
51 BuildRequires:  libwpg-devel >= 0.3
52 BuildRequires:  libxml2-devel >= 1:2.6.26
53 BuildRequires:  libxslt-devel >= 1.1.17
54 BuildRequires:  pango-devel >= 1:1.24
55 BuildRequires:  pkgconfig
56 BuildRequires:  poppler-glib-devel >= 0.29.0
57 BuildRequires:  popt-devel
58 BuildRequires:  potrace-devel
59 BuildRequires:  rpm-pythonprov
60 BuildRequires:  sed >= 4.0
61 BuildRequires:  zlib-devel
62 %if %{with gtk3}
63 BuildRequires:  gdl-devel >= 3.6
64 BuildRequires:  gtk+3-devel >= 3.8
65 BuildRequires:  gtkmm3-devel >= 3.10
66 BuildRequires:  gtkspell3-devel >= 3.0
67 %else
68 BuildRequires:  gtk+2-devel >= 2:2.24
69 BuildRequires:  gtkmm-devel >= 2.24
70 BuildRequires:  gtkspell-devel >= 2.0.11
71 %endif
72 Requires(post,postun):  desktop-file-utils
73 Requires:       cairo >= 1.10
74 Requires:       cairomm >= 1.9.8
75 Requires:       gc >= 7.2
76 Requires:       glib2 >= 1:2.28
77 Requires:       glibmm >= 2.28
78 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
79 Requires:       libsigc++ >= 2.0.17
80 Requires:       libxml2 >= 1:2.6.26
81 Requires:       libxslt >= 1.1.17
82 Requires:       pango >= 1:1.24
83 Requires:       perl-XML-XQL
84 Requires:       poppler-glib >= 0.29.0
85 %if %{with gtk3}
86 Requires:       gdl >= 3.6
87 Requires:       gtk+3 >= 3.8
88 Requires:       gtkmm3 >= 3.10
89 %else
90 Requires:       gtk+2 >= 2:2.24
91 Requires:       gtkmm >= 2.24
92 Requires:       gtkspell >= 2.0.11
93 %endif
94 Suggests:       python-lxml
95 # sr@Latn vs. sr@latin
96 Conflicts:      glibc-misc < 6:2.7
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %description
100 Inkscape is a program for viewing, making, and editing two-dimensional
101 vector drawings.
102
103 %description -l pl.UTF-8
104 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
105 dwuwymiarowej grafiki wektorowej.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111 %patch2 -p1
112 %patch3 -p1
113
114 %{__sed} -i -e 's,po/Makefile.in,,' configure.ac
115
116 %build
117 %{__libtoolize}
118 %{__gettextize}
119 %{__intltoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         %{?with_relocation:--enable-binreloc} \
126         %{?with_dbus:--enable-dbusapi} \
127         %{?with_gtk3:--enable-gtk3-experimental} \
128         --disable-silent-rules \
129         %{!?with_gnomevfs:--without-gnome-vfs}
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 # localized manuals cleanup
140 for manlang in de el fr ja sk zh_TW ; do
141         %{__mv} $RPM_BUILD_ROOT%{_mandir}/${manlang}/man1/{inkscape.${manlang}.1,inkscape.1}
142         %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/inkscape.${manlang}.1
143 done
144
145 # unify locale name, overwrite outdated bn
146 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{bn_BD,bn}/LC_MESSAGES/inkscape.mo
147 # joke language, unsupported
148 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en_US@piglatin
149 # unify names
150 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@aran,ks}
151 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@deva,ks@devanagari}
152 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sd@deva,sd@devanagari}
153 # unsupported variants
154 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{kok@latin,mni@beng,sat@deva}
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 %update_desktop_database_post
163
164 %postun
165 %update_desktop_database_postun
166
167 %files -f %{name}.lang
168 %defattr(644,root,root,755)
169 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
170 %lang(ca) %doc README.ca.txt
171 %lang(de) %doc README.de.txt doc/HACKING.de.txt
172 %lang(es) %doc README.es.txt
173 %lang(fr) %doc README.fr.txt doc/HACKING.fr.txt
174 %lang(it) %doc README.it.txt doc/HACKING.it.txt
175 %lang(pt_BR) %doc README.pt_BR.txt doc/HACKING.pt_BR.txt
176 %lang(sk) %doc README.sk.txt
177 %lang(sr) %doc README.sr.txt
178 %attr(755,root,root) %{_bindir}/inkscape
179 %attr(755,root,root) %{_bindir}/inkview
180 %dir %{_datadir}/inkscape
181 %{_datadir}/inkscape/[!e]*
182 %{_datadir}/inkscape/examples
183 %dir %{_datadir}/inkscape/extensions
184 %dir %{_datadir}/inkscape/extensions/Barcode
185 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
186 %{_datadir}/inkscape/extensions/Poly3DObjects
187 %{_datadir}/inkscape/extensions/alphabet_soup
188 %dir %{_datadir}/inkscape/extensions/ink2canvas
189 %attr(755,root,root) %{_datadir}/inkscape/extensions/ink2canvas/*.py
190 %{_datadir}/inkscape/extensions/test
191 %{_datadir}/inkscape/extensions/xaml2svg
192 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
193 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
194 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
195 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
196 %{_datadir}/inkscape/extensions/*.inx
197 %{_datadir}/inkscape/extensions/*.js
198 %{_datadir}/inkscape/extensions/*.svg
199 %{_datadir}/inkscape/extensions/*.xml
200 %{_datadir}/inkscape/extensions/*.xsl
201 %{_datadir}/inkscape/extensions/*.xslt
202 %{_datadir}/inkscape/extensions/fontfix.conf
203 %{_datadir}/inkscape/extensions/inkscape.extension.rng
204 %{_datadir}/appdata/inkscape.appdata.xml
205 %{_iconsdir}/hicolor/*/apps/inkscape.png
206 %{_desktopdir}/inkscape.desktop
207 %{_mandir}/man1/inkscape.1*
208 %{_mandir}/man1/inkview.1*
209 %lang(de) %{_mandir}/de/man1/inkscape.1*
210 %lang(el) %{_mandir}/el/man1/inkscape.1*
211 %lang(fr) %{_mandir}/fr/man1/inkscape.1*
212 %lang(ja) %{_mandir}/ja/man1/inkscape.1*
213 %lang(sk) %{_mandir}/sk/man1/inkscape.1*
214 %lang(zh_TW) %{_mandir}/zh_TW/man1/inkscape.1*
This page took 0.046878 seconds and 3 git commands to generate.