]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
703c0f5dabe06d96217fa64a84e411d626b25207
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.45.1
16 Release:        5
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  1ac63dfd5d78a676599bf5cf6d22e493
21 Patch0:         %{name}-ac.patch
22 Patch1:         %{name}-desktop.patch
23 URL:            http://www.inkscape.org/
24 BuildRequires:  autoconf >= 2.59-3
25 BuildRequires:  automake >= 1:1.9.4-2
26 BuildRequires:  boost-any-devel
27 BuildRequires:  boost-bind-devel
28 BuildRequires:  freetype-devel >= 2.0
29 BuildRequires:  gcc-c++ >= 6:4.2.2-2
30 BuildRequires:  gc-devel >= 6.4
31 BuildRequires:  gettext-devel
32 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
33 BuildRequires:  gtk+2-devel >= 2:2.9.4
34 BuildRequires:  gtkmm-devel >= 2.4
35 BuildRequires:  gtkspell-devel >= 2.0.11
36 BuildRequires:  intltool >= 0.35.0
37 BuildRequires:  lcms-devel >= 1.15
38 BuildRequires:  libart_lgpl-devel >= 2.3.10
39 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
40 BuildRequires:  libpng-devel >= 1.2
41 BuildRequires:  libsigc++-devel >= 2.0.17
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.26
44 BuildRequires:  libxslt-devel >= 1.1.17
45 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
46 BuildRequires:  pkgconfig
47 BuildRequires:  popt-devel
48 BuildRequires:  rpm-pythonprov
49 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
50 BuildRequires:  zlib-devel
51 Requires(post,postun):  shared-mime-info
52 Requires:       gc >= 6.4
53 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
54 Requires:       gtk+2 >= 2:2.9.4
55 Requires:       perl-XML-XQL
56 # sr@Latn vs. sr@latin
57 Conflicts:      glibc-misc < 6:2.7
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Inkscape is a program for viewing, making, and editing two-dimensional
62 vector drawings.
63
64 %description -l pl.UTF-8
65 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
66 dwuwymiarowej grafiki wektorowej.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72 rm -f po/en_US@piglatin.po
73 sed -i -e 's|en_US@piglatin||' configure.ac
74
75 %build
76 %{__libtoolize}
77 %{__glib_gettextize}
78 %{__intltoolize}
79 %{__aclocal}
80 %{__autoheader}
81 %{__automake}
82 %{__autoconf}
83 %configure \
84         %{!?with_xft: --without-xft} \
85         %{!?with_gnomeprint:--without-gnome-print} \
86         %{?with_gnomeprint:--with-gnome-print} \
87         %{!?with_gnomevfs:--without-gnome-vfs} \
88         %{!?with_mmx:--disable-mmx} \
89         %{?with_relocation:--enable-binreloc} \
90         %{?with_inkboard:--enable-inkboard} \
91         --disable-static
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
102         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
103 %find_lang %{name}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108
109 %post
110 umask 022
111 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
112 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
113
114 %postun
115 umask 022
116 update-mime-database %{_datadir}/mime >/dev/null 2>&1
117 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
122 %lang(ca) %doc README.ca.txt
123 %lang(de) %doc README.de.txt
124 %lang(es) %doc README.es.txt
125 %lang(fr) %doc README.fr.txt
126 %lang(it) %doc README.it.txt
127 %lang(de) %doc HACKING.de.txt
128 %lang(fr) %doc HACKING.fr.txt
129 %lang(it) %doc HACKING.it.txt
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_datadir}/inkscape
132 %{_datadir}/inkscape/[!e]*
133 %{_datadir}/inkscape/examples
134 %dir %{_datadir}/inkscape/extensions
135 %{_datadir}/inkscape/extensions/*.cmd
136 %{_datadir}/inkscape/extensions/*.inx
137 %{_datadir}/inkscape/extensions/*.txt
138 %{_datadir}/inkscape/extensions/*.xslt
139 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
140 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
141 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
142 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
143 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
144 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
145 %{_mandir}/man1/*
146 %lang(fr) %{_mandir}/fr/man1/*
147 %{_pixmapsdir}/*.png
148 %{_desktopdir}/*.desktop
This page took 0.055792 seconds and 3 git commands to generate.