]> git.pld-linux.org Git - packages/igb.git/commitdiff
- simpler fix for linux 3.15 auto/th/igb-5.2.5-3
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Jul 2014 10:51:40 +0000 (12:51 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Jul 2014 10:51:40 +0000 (12:51 +0200)
- rel 3

igb.spec
linux-3.15.patch

index 1f87ed29d9c3671b18984333394fd36cf0a57d5e..b1825d101ae43975d6b2afaf6e3d3459df25fb3e 100644 (file)
--- a/igb.spec
+++ b/igb.spec
@@ -21,7 +21,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define                rel     2
+%define                rel     3
 %define                pname   igb
 Summary:       Intel(R) PRO/1000 driver for Linux
 Summary(pl.UTF-8):     Sterownik do karty Intel(R) PRO/1000
index 9ed7f7b49056d6260e9e33f9ab146d0c7babda57..a515d4ab1f883a72bc3d11d34e3bdbfa09d51a39 100644 (file)
@@ -1,33 +1,15 @@
 --- a/src/igb_main.c
 +++ b/src/igb_main.c
-@@ -7366,7 +7366,8 @@ static inline void igb_rx_hash(struct igb_ring *ring,
+@@ -7366,7 +7366,12 @@ static inline void igb_rx_hash(struct igb_ring *ring,
                               struct sk_buff *skb)
  {
        if (netdev_ring(ring)->features & NETIF_F_RXHASH)
--              skb->rxhash = le32_to_cpu(rx_desc->wb.lower.hi_dword.rss);
++#if ( LINUX_VERSION_CODE < KERNEL_VERSION(3,14,0) )
+               skb->rxhash = le32_to_cpu(rx_desc->wb.lower.hi_dword.rss);
++#else
 +              skb_set_hash(skb, le32_to_cpu(rx_desc->wb.lower.hi_dword.rss),
 +                           PKT_HASH_TYPE_L3);
++#endif
  }
  
  #endif
---- a/src/kcompat.h
-+++ b/src/kcompat.h
-@@ -3831,4 +3831,15 @@ static inline struct sk_buff *__kc__vlan_hwaccel_put_tag(struct sk_buff *skb,
- #define HAVE_ENCAP_TSO_OFFLOAD
- #endif /* >= 3.10.0 */
-+#if ( LINUX_VERSION_CODE < KERNEL_VERSION(3,14,0) )
-+#ifdef NETIF_F_RXHASH
-+#define PKT_HASH_TYPE_L3 0
-+static inline void
-+skb_set_hash(struct sk_buff *skb, __u32 hash, __always_unused int type)
-+{
-+      skb->rxhash = hash;
-+}
-+#endif /* NETIF_F_RXHASH */
-+#endif /* < 3.14.0 */
-+
- #endif /* _KCOMPAT_H_ */
--- 
-1.9.1
-
This page took 0.03725 seconds and 4 git commands to generate.