]> git.pld-linux.org Git - packages/icmake.git/blob - icmake.spec
up to 9.03.01
[packages/icmake.git] / icmake.spec
1 Summary:        Icmake - an Intelligent C-like Maker
2 Summary(pl.UTF-8):      Icmake - inteligentny C-podobny "maker"
3 Name:           icmake
4 Version:        9.03.01
5 Release:        1
6 License:        GPL v3
7 Group:          Development/Building
8 Source0:        https://gitlab.com/fbb-git/icmake/-/archive/%{version}/%{name}-%{version}.tar.bz2
9 # Source0-md5:  aa906c6f3769ddd2684c7baab9adf160
10 Patch0:         verbose-build.patch
11 URL:            https://fbb-git.gitlab.io/icmake/
12 BuildRequires:  bash
13 BuildRequires:  sed >= 4.0
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Icmake is yet another maker - but this time, one that uses a C-like
18 syntaxis. The Icmake scripts should feel `natural' to all C
19 programmers. Icmake is furthermore a powerful shell script language:
20 it can be used for program maintenance as well as for system
21 administrative tasks.
22
23 %description -l pl.UTF-8
24 Icmake jest kolejnym programem typu "make" - ale takim, który używa
25 składni podobnej do C. Skrypty Icmake powinny być dość 'naturalne' dla
26 programistów C. Icmake jest ponadto potężnym narzędziem skryptowym:
27 może być używany równie dobrze do tworzenia programów z równym
28 powodzeniem jak do wykonywania zadań administracyjnych.
29
30 %prep
31 %setup -q
32 %patch0 -p0
33 %{__sed} -i -e 's#/lib/#/%{_lib}/#g' icmake/INSTALL.im
34
35 %build
36 cd icmake
37 ./icm_prepare /
38 CC="%{__cc}" \
39 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
40 LDFLAGS="%{rpmldflags}" \
41 ./icm_bootstrap /
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 cd icmake
47 ./icm_install all $RPM_BUILD_ROOT
48
49 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/icmake{,-doc}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc icmake/changelog icmake/doc/icmake.ps icmake/doc/icmake.doc
57 %dir %{_sysconfdir}/icmake
58 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icmake/icmstart.rc
59 %attr(755,root,root) %{_bindir}/icmake
60 %attr(755,root,root) %{_bindir}/icmbuild
61 %attr(755,root,root) %{_bindir}/icmstart
62 %dir %{_libdir}/%{name}
63 %attr(755,root,root) %{_libdir}/%{name}/icm-comp
64 %attr(755,root,root) %{_libdir}/%{name}/icm-dep
65 %attr(755,root,root) %{_libdir}/%{name}/icm-exec
66 %attr(755,root,root) %{_libdir}/%{name}/icm-pp
67 %attr(755,root,root) %{_libdir}/%{name}/icmbuild
68 %attr(755,root,root) %{_libdir}/%{name}/icmun
69 %dir %{_datadir}/%{name}
70 %dir %{_datadir}/%{name}/parser
71 %{_datadir}/%{name}/parser/grammar
72 %{_datadir}/%{name}/[!p]*
73 %{_mandir}/man1/icmake.1*
74 %{_mandir}/man1/icmbuild.1*
75 %{_mandir}/man1/icmstart.1*
76 %{_mandir}/man7/icmconf.7*
77 %{_mandir}/man7/icmstart.rc.7*
This page took 1.193866 seconds and 3 git commands to generate.