]> git.pld-linux.org Git - packages/icedove.git/commitdiff
- prepare for 6.0
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 26 Aug 2011 23:48:02 +0000 (23:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    icedove-install.patch -> 1.6
    icedove-libpng.patch -> 1.5
    icedove-makefile.patch -> 1.2
    icedove.spec -> 1.121

icedove-install.patch
icedove-libpng.patch [deleted file]
icedove-makefile.patch
icedove.spec

index a62d5a47b65bcb90c0a8c315dbeb3aa08895f5dd..7464b0470dd75879ecb46316cab04f87930588a7 100644 (file)
@@ -1,36 +1,66 @@
---- ./mozilla/toolkit/mozapps/installer/packager.mk.org        2010-01-21 21:10:00.234466295 +0100
-+++ ./mozilla/toolkit/mozapps/installer/packager.mk    2010-01-21 21:10:29.847369216 +0100
-@@ -362,13 +362,13 @@
+--- ./mozilla/toolkit/mozapps/installer/packager.mk.orig       2011-03-19 00:34:12.000000000 +0100
++++ ./mozilla/toolkit/mozapps/installer/packager.mk    2011-03-22 23:53:43.877485659 +0100
+@@ -496,30 +496,30 @@
+ endif
+ stage-package: $(MOZ_PKG_MANIFEST) $(MOZ_PKG_REMOVALS_GEN) elfhack
+-      @rm -rf $(DIST)/$(MOZ_PKG_DIR) $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
++      @rm -rf $(DESTDIR)/$(MOZ_PKG_DIR) $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
  # NOTE: this must be a tar now that dist links into the tree so that we
  # do not strip the binaries actually in the tree.
        @echo "Creating package directory..."
 -      @mkdir $(DIST)/$(MOZ_PKG_DIR)
-+      @mkdir -p $(DESTDIR)/$(MOZ_PKG_APPDIR)
++      @mkdir -p $(DESTDIR)/$(MOZ_PKG_DIR)
+ ifndef UNIVERSAL_BINARY
+ # If UNIVERSAL_BINARY, the package will be made from an already-prepared
+ # STAGEPATH
  ifdef MOZ_PKG_MANIFEST
-       $(RM) -rf $(DIST)/xpt
+       $(RM) -rf $(DIST)/xpt $(DIST)/manifests
        $(call PACKAGER_COPY, "$(call core_abspath,$(DIST))",\
--               "$(call core_abspath,$(DIST)/$(MOZ_PKG_DIR))", \
-+               "$(call core_abspath,$(DESTDIR)/$(MOZ_PKG_APPDIR))", \
-               "$(MOZ_PKG_MANIFEST)", "$(PKGCP_OS)", 1, 0, 1)
+-        "$(call core_abspath,$(DIST)/$(MOZ_PKG_DIR))", \
++        "$(call core_abspath,$(DESTDIR)/$(MOZ_PKG_DIR))", \
+         "$(MOZ_PKG_MANIFEST)", "$(PKGCP_OS)", 1, 0, 1)
 -      $(PERL) $(MOZILLA_DIR)/xpinstall/packager/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
-+      $(PERL) $(MOZILLA_DIR)/xpinstall/packager/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DESTDIR)/$(MOZ_PKG_APPDIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
++      $(PERL) $(MOZILLA_DIR)/xpinstall/packager/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
+       $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/link-manifests.py \
+-        $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/components/components.manifest \
++        $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/components/components.manifest \
+         $(patsubst %,$(DIST)/manifests/%/components,$(MOZ_NONLOCALIZED_PKG_LIST))
+       $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/link-manifests.py \
+-        $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/nonlocalized.manifest \
++        $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/nonlocalized.manifest \
+         $(patsubst %,$(DIST)/manifests/%/chrome,$(MOZ_NONLOCALIZED_PKG_LIST))
+       $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/link-manifests.py \
+-        $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/localized.manifest \
++        $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/localized.manifest \
+         $(patsubst %,$(DIST)/manifests/%/chrome,$(MOZ_LOCALIZED_PKG_LIST))
+-      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
++      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
  else # !MOZ_PKG_MANIFEST
  ifeq ($(MOZ_PKG_FORMAT),DMG)
- # If UNIVERSAL_BINARY, the package will be made from an already-prepared
-@@ -377,11 +377,11 @@
  ifndef STAGE_SDK
-       @cd $(DIST) && rsync -auv --copy-unsafe-links $(_APPNAME) $(MOZ_PKG_DIR)
+@@ -529,10 +529,10 @@
+       @$(NSINSTALL) -D $(DIST)/xpt
+       @($(XPIDL_LINK) $(DIST)/xpt/$(MOZ_PKG_APPNAME).xpt $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/*.xpt && rm -f $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/*.xpt && cp $(DIST)/xpt/$(MOZ_PKG_APPNAME).xpt $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components && printf "interfaces $(MOZ_PKG_APPNAME).xpt\n" >$(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/interfaces.manifest) || echo No *.xpt files found in: $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/.  Continuing...
  else
 -      @cd $(DIST)/bin && tar $(TAR_CREATE_FLAGS) - * | (cd ../$(MOZ_PKG_DIR); tar -xf -)
-+      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_APPDIR)
- endif
++      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_DIR)
  endif
  else
 -      @cd $(DIST)/bin && tar $(TAR_CREATE_FLAGS) - * | (cd ../$(MOZ_PKG_DIR); tar -xf -)
-+      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_APPDIR)
++      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_DIR)
        @echo "Linking XPT files..."
        @rm -rf $(DIST)/xpt
        @$(NSINSTALL) -D $(DIST)/xpt
+@@ -620,7 +620,7 @@
+       cd $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH) && $(PACK_OMNIJAR)
+ endif
+       $(NSINSTALL) -D $(DESTDIR)$(installdir)
+-      (cd $(DIST)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
++      (cd $(DESTDIR)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
+         (cd $(DESTDIR)$(installdir) && tar -xf -)
+       $(NSINSTALL) -D $(DESTDIR)$(bindir)
+       $(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
 --- comm-1.9.1/mail/app/Makefile.in.orig       2009-12-18 14:49:43.990647725 +0100
 +++ comm-1.9.1/mail/app/Makefile.in    2009-12-18 14:49:53.830739781 +0100
 @@ -48,7 +48,7 @@
diff --git a/icedove-libpng.patch b/icedove-libpng.patch
deleted file mode 100644 (file)
index 1dc0ecd..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- mozilla/modules/libpr0n/encoders/png/nsPNGEncoder.cpp.orig 2010-01-17 00:15:53.979744638 +0100
-+++ mozilla/modules/libpr0n/encoders/png/nsPNGEncoder.cpp      2010-01-17 00:16:07.855993411 +0100
-@@ -135,7 +135,7 @@
-   // initialize
-   mPNG = png_create_write_struct(PNG_LIBPNG_VER_STRING,
--                                 png_voidp_NULL,
-+                                 NULL,
-                                  ErrorCallback,
-                                  ErrorCallback);
-   if (! mPNG)
index 180a16615b34e4a007ff7df56abfae7d6670988c..ef2f8496bef3a8c37717fb7f6d45cf90f69ef80d 100644 (file)
@@ -1,11 +1,18 @@
---- Makefile.in.orig   2010-06-23 19:43:07.000000000 +0200
-+++ Makefile.in        2010-07-08 09:24:01.055067815 +0200
-@@ -58,21 +58,7 @@
+--- icedove-6.0/mozilla/Makefile.in~   2011-08-12 16:52:03.000000000 +0300
++++ icedove-6.0/mozilla/Makefile.in    2011-08-26 13:00:59.373870016 +0300
+@@ -58,8 +58,6 @@
  
  include $(topsrcdir)/config/config.mk
  
 -default alldep all:: $(topsrcdir)/configure config.status
 -
+ ifndef INCLUDED_BRIDGE_MK
+ include $(topsrcdir)/bridge/bridge.mk
+ endif
+@@ -67,19 +65,7 @@
+ # workaround Bug 599809 by making these makefiles be generated here
+ SUBMAKEFILES += $(addsuffix /Makefile, $(APP_LIBXUL_DIRS) $(APP_LIBXUL_STATICDIRS))
 -$(topsrcdir)/configure: $(topsrcdir)/configure.in
 -      @echo "STOP!  configure.in has changed, and your configure is out of date."
 -      @echo "Please rerun autoconf and configure."
 -      @echo "To ignore this message, touch 'config.status' in the build directory."
 -      @exit 1
 -
--default export libs clean realclean distclean alldep maybe_clobber_profiledbuild uploadsymbols all::
-+default export libs clean realclean distclean maybe_clobber_profiledbuild uploadsymbols::
+-default export libs clean realclean distclean alldep \
++default export libs clean realclean distclean \
+ maybe_clobber_profiledbuild uploadsymbols all:: $(SUBMAKEFILES)
        $(MAKE) -C mozilla $@
  
- ifdef ENABLE_TESTS
+--- icedove-6.0/mozilla/client.mk~     2011-08-26 13:10:08.000000000 +0300
++++ icedove-6.0/mozilla/client.mk      2011-08-26 13:10:11.365956960 +0300
+@@ -278,8 +278,8 @@
+       $(TOPSRCDIR)/mozilla/js/src/aclocal.m4 \
+       $(NULL)
+-$(CONFIGURES): %: %.in $(EXTRA_CONFIG_DEPS)
+-      @echo Generating $@ using autoconf
++$(CONFIGURES): 
++      echo Generating $@ using autoconf
+       cd $(@D); $(AUTOCONF)
+ CONFIG_STATUS_DEPS := \
index 41ac3647c3a8f29a5e360694e5a791eeb3d31234..0c05dd05089a2a6dbfec28f8f77e26485b9b43f5 100644 (file)
@@ -10,7 +10,7 @@
 %bcond_without gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
 %bcond_without  lightning      # disable sunbird calendar
-%bcond_with            xulrunner       # build with xulrunner
+%bcond_without xulrunner       # build with xulrunner
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
 
 %if %{without gnome}
 %undefine      with_gnomevfs
 %endif
 
-%if %{?_enable_debug_packages} != 1
+%if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver            1.1.2
+%define                enigmail_ver    1.1.2
+%define                nspr_ver                4.8.8
+%define                nss_ver                 3.12.10
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       3.1.11
-Release:       2
+Version:       6.0
+Release:       0.1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 25833b3f90925d96285630d22c85cd5c
+# Source0-md5: 9ac741d238e95790cdeb5222e9b23ae8
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
 # Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
 Source2:       %{name}-branding.tar.bz2
@@ -54,7 +56,6 @@ Patch5:               %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-Patch9:                %{name}-libpng.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
@@ -76,8 +77,8 @@ BuildRequires:        libjpeg-devel >= 6b
 BuildRequires: libnotify-devel >= 0.4
 BuildRequires: libpng-devel >= 1.2.0
 BuildRequires: libstdc++-devel
-BuildRequires: nspr-devel >= 1:4.8
-BuildRequires: nss-devel >= 1:3.12.0
+BuildRequires: nspr-devel >= 1:%{nspr_ver}
+BuildRequires: nss-devel >= 1:%{nss_ver}
 BuildRequires: pango-devel >= 1:1.1.0
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
@@ -91,8 +92,8 @@ Requires(post):       mktemp >= 1.5-18
 %if %{with xulrunner}
 %else
 Requires:      myspell-common
-Requires:      nspr >= 1:4.6.1
-Requires:      nss >= 1:3.11.3
+Requires:      nspr >= 1:%{nspr_ver}
+Requires:      nss >= 1:%{nss_ver}
 Requires:      sqlite3 >= %{sqlite_build_version}
 %endif
 Obsoletes:     mozilla-thunderbird
@@ -171,7 +172,7 @@ Główne możliwości:
 
 %prep
 %setup -qc
-mv -f comm-1.9.2 mozilla
+mv comm-release mozilla
 %setup -q -T -D -a2
 cd mozilla
 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
@@ -184,8 +185,7 @@ cd mozilla
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p0
-%patch9 -p0
+%patch8 -p2
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
@@ -194,7 +194,7 @@ cd mozilla
 cd mozilla
 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
-cp -f %{_datadir}/automake/config.* directory/sdks/c-sdk/config/autoconf
+cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
 
 install -d libxul-sdk
 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
@@ -293,10 +293,12 @@ ac_add_options --enable-xinerama
 ac_add_options --with-distribution-id=org.pld-linux
 ac_add_options --with-branding=icedove/branding
 %if %{with xulrunner}
-ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
+#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
+ac_add_options --with-system-libxul
 ac_add_options --enable-shared
+ac_add_options --enable-libxul
 %else
-ac_add_options --enable-static
+ac_add_options --disable-xul
 %endif
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
This page took 0.085462 seconds and 4 git commands to generate.