]> git.pld-linux.org Git - packages/icedove.git/commitdiff
- added libpng patch to fix build with libpng 1.5.x
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 21 Jan 2012 18:07:11 +0000 (18:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    icedove-libpng.patch -> 1.6
    icedove.spec -> 1.138

icedove-libpng.patch [new file with mode: 0644]
icedove.spec

diff --git a/icedove-libpng.patch b/icedove-libpng.patch
new file mode 100644 (file)
index 0000000..13e1658
--- /dev/null
@@ -0,0 +1,21 @@
+--- xulrunner-9.0.1/mozilla/modules/libpr0n/decoders/nsPNGDecoder.h.orig       2011-12-21 00:28:33.000000000 +0100
++++ xulrunner-9.0.1/mozilla/modules/libpr0n/decoders/nsPNGDecoder.h    2012-01-16 18:43:35.830209631 +0100
+@@ -76,7 +76,7 @@
+   // Checks if the info header contains valid information
+   bool HasValidInfo() const 
+   {
+-    return mInfo && mInfo->valid;
++    return mInfo && png_get_valid(mPNG, mInfo, 0xFFFFFFFFU);
+   }
+   // Obtain the pixel depth if available or 0 otherwise
+@@ -85,7 +85,8 @@
+     if (!mInfo) {
+       return 0;
+     }
+-    return mInfo->pixel_depth;
++    // XXX: shouldn't png_get_pixel_depth() be available?
++    return png_get_bit_depth(mPNG, mInfo) * png_get_channels(mPNG, mInfo);
+   }
+ public:
index f3ddcd9b388c37cc7e2f3322b06462f83193cc3e..1b9498fca5b8d417730364c9adf428d5dee05101 100644 (file)
@@ -29,7 +29,7 @@
 %define                nspr_ver        4.8.8
 %define                nss_ver         3.12.10
 
-# convert firefox release number to platform version: 7.0.x -> 7.0.x
+# convert firefox release number to platform version: 9.0.x -> 9.0.x
 %define                xulrunner_main  9.0
 %define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#9.0})
 
@@ -63,6 +63,7 @@ Patch5:               %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
+Patch9:                %{name}-libpng.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
@@ -202,6 +203,7 @@ cd mozilla
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
+%patch9 -p1
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
This page took 0.095867 seconds and 4 git commands to generate.