]> git.pld-linux.org Git - packages/icedove.git/commitdiff
- up to 10.0.1 auto/th/icedove-10_0_1-1
authorAndrzej Zawadzki <zawadaa@gmail.com>
Tue, 14 Feb 2012 15:46:35 +0000 (15:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    icedove-branding.patch -> 1.23
    icedove-extensiondir.patch -> 1.2
    icedove-install.patch -> 1.7
    icedove.spec -> 1.143

icedove-branding.patch
icedove-extensiondir.patch
icedove-install.patch
icedove.spec

index ecc5129d234664fa9d6a4f49dda4b470c3ad253d..b6d937aed558b10c7659d5903d0ef65aa4a3f811 100644 (file)
  
  // Controls enabling of the extension system logging (can reduce performance)
  pref("extensions.logging.enabled", false);
-@@ -138,10 +138,10 @@
+@@ -145,10 +145,10 @@
  // Preferences for AMO integration
  pref("extensions.getAddons.cache.enabled", true);
  pref("extensions.getAddons.maxResults", 15);
 -pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
 -pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/%APP%/search?q=%TERMS%");
--pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
+-pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
 -pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/%APP%/discovery/pane/%VERSION%/%OS%");
 +pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
 +pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/search?q=%TERMS%");
-+pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
++pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
 +pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/discovery/pane/%VERSION%/%OS%");
+
  // Blocklist preferences
  pref("extensions.blocklist.enabled", true);
 @@ -165,7 +165,7 @@
index b8487b536dd91c6bda2bf68859c258423f6dd984..836c0b5341ec152aae3b995c5cf42992a6282125 100644 (file)
@@ -1,17 +1,17 @@
 --- icedove-3.1.2/mozilla/mozilla/toolkit/xre/nsXREDirProvider.cpp~    2010-08-03 02:28:31.000000000 +0300
 +++ icedove-3.1.2/mozilla/mozilla/toolkit/xre/nsXREDirProvider.cpp     2010-08-17 15:46:17.972676534 +0300
-@@ -320,7 +320,7 @@
- #endif
+@@ -328,7 +328,7 @@
  #if defined(XP_UNIX) && !defined(XP_MACOSX)
    else if (!strcmp(aProperty, XRE_SYS_SHARE_EXTENSION_PARENT_DIR)) {
+ #ifdef ENABLE_SYSTEM_EXTENSION_DIRS
 -    static const char *const sysLExtDir = "/usr/share/mozilla/extensions";
 +    static const char *const sysLExtDir = "/usr/share/icedove/extensions";
      return NS_NewNativeLocalFile(nsDependentCString(sysLExtDir),
-                                  PR_FALSE, (nsILocalFile**)(nsIFile**) aFile);
-   }
-@@ -1231,9 +1231,9 @@
+                                  false, (nsILocalFile**)(nsIFile**) aFile);
+ #else
+@@ -1129,9 +1129,9 @@
  #elif defined(XP_UNIX)
-   static const char *const sysSExtDir = 
+   static const char *const sysSExtDir =
  #ifdef HAVE_USR_LIB64_DIR
 -    "/usr/lib64/mozilla/extensions";
 +    "/usr/lib64/icedove/extensions";
@@ -19,5 +19,6 @@
 -    "/usr/lib/mozilla/extensions";
 +    "/usr/lib/icedove/extensions";
  #endif
-   rv = NS_NewNativeLocalFile(nsDependentCString(sysSExtDir), PR_FALSE,
+
+   rv = NS_NewNativeLocalFile(nsDependentCString(sysSExtDir), false,
+  rv = NS_NewNativeLocalFile(nsDependentCString(sysSExtDir), PR_FALSE,
index 7464b0470dd75879ecb46316cab04f87930588a7..78474ed63f42395c11755b0ea1b2c5455f96fac6 100644 (file)
    -DAB_CD=$(AB_CD) \
    -DGRE_MILESTONE=$(GRE_MILESTONE) \
    -DGRE_BUILDID=$(GRE_BUILDID) \
-@@ -359,7 +359,7 @@
- endif
-       mkdir -p $(DIST)/$(APP_NAME).app/Contents/Library/Spotlight
-       rsync -a --copy-unsafe-links $(DIST)/package/Thunderbird.mdimporter $(DIST)/$(APP_NAME).app/Contents/Library/Spotlight
--      cp -RL $(DIST)/branding/thunderbird.icns $(DIST)/$(APP_NAME).app/Contents/Resources/thunderbird.icns
-+      cp -RL $(DIST)/branding/thunderbird.icns $(DIST)/branding/$(MOZ_APP_NAME).icns
-       printf APPLMOZM > $(DIST)/$(APP_NAME).app/Contents/PkgInfo
- #       remove CVS dirs from packaged app
-       find $(DIST)/$(APP_NAME).app -type d -name "CVS" -prune -exec rm -rf {} \;
index 7ba5d2f1c31bfb92683bb2e487305e1ef5d23e0a..cd4adff3039941043faaedb44ede2de917a554b1 100644 (file)
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.3.4
+%define                enigmail_ver    1.3.5
 %define                nspr_ver        4.8.8
 %define                nss_ver         3.12.10
 
 # convert firefox release number to platform version: 9.0.x -> 9.0.x
-%define                xulrunner_main  9.0
-%define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#9.0})
+%define                xulrunner_main  10.0
+%define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#10.0})
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       9.0.1
-Release:       2
+Version:       10.0.1
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: a5904751dbd33074682b438b732fdbab
+# Source0-md5: 623c32d9deae370383e1422b1ea48061
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 2b5f188791811d248b6ff1fc51a5806a
+# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
@@ -58,7 +58,7 @@ Patch5:               %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-Patch9:                %{name}-libpng.patch
+#Patch9:               %{name}-libpng.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
@@ -198,7 +198,7 @@ cd mozilla
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
-%patch9 -p1
+#%patch9 -p1
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
This page took 0.041907 seconds and 4 git commands to generate.