]> git.pld-linux.org Git - packages/icedove.git/commitdiff
- started update to 31.3.0
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 3 Dec 2014 21:15:07 +0000 (22:15 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 3 Dec 2014 21:15:07 +0000 (22:15 +0100)
enable-addons.patch
gyp-slashism.patch [deleted file]
icedove-branding.patch
icedove-fonts.patch
icedove-sh.patch [deleted file]
icedove.spec
system-mozldap.patch
system-virtualenv.patch

index daff8d16bdd3fb87a757f4f22e4a91bb414d1864..5f62b448c524302be572beb34f0b6c6c5cb174a8 100644 (file)
@@ -9,18 +9,18 @@
  
  // Preferences for AMO integration
  pref("extensions.getAddons.cache.enabled", true);
---- comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm.addons     2011-11-21 11:28:32.000000000 +0100
-+++ comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm    2011-12-14 12:43:42.461184351 +0100
+--- comm-release/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons    2011-11-21 11:28:32.000000000 +0100
++++ comm-release/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm   2011-12-14 12:43:42.461184351 +0100
 @@ -1591,8 +1591,8 @@ var XPIProvider = {
-       this.showUpgradeUI();
-       flushCaches = true;
-     }
--    else if (aAppChanged === undefined) {
--      // For new profiles we will never need to show the add-on selection UI
-+    else {
-+      // For all profiles we will never need to show the add-on selection UI
-       Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
-     }
+         this.showUpgradeUI();
+         flushCaches = true;
+       }
+-      else if (aAppChanged === undefined) {
+-        // For new profiles we will never need to show the add-on selection UI
++      else {
++        // For all profiles we will never need to show the add-on selection UI
+         Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
+       }
  
 --- comm-release/suite/browser/browser-prefs.js~       2013-11-06 19:54:38.789734061 +0100
 +++ comm-release/suite/browser/browser-prefs.js        2013-11-06 20:55:33.765611935 +0100
diff --git a/gyp-slashism.patch b/gyp-slashism.patch
deleted file mode 100644 (file)
index 5100011..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
---- xulrunner-18.0/mozilla/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py.orig    2013-01-05 00:44:41.000000000 +0100
-+++ xulrunner-18.0/mozilla/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py 2013-01-13 20:13:40.033894757 +0100
-@@ -114,6 +114,12 @@
-   if dir and not os.path.exists(dir):
-     os.makedirs(dir)
-+def append_relative(base, rel):
-+  if rel == '':
-+    return base
-+  else:
-+    return base + '/' + rel
-+
- def GetFlavor(params):
-   """Returns |params.flavor| if it's set, the system's default flavor else."""
-   flavors = {
-@@ -142,9 +148,9 @@
- def WriteMakefile(filename, data, build_file, depth, topsrcdir, srcdir, relative_path, extra_data=None):
-   if not os.path.isabs(topsrcdir):
--    topsrcdir = depth + "/" + topsrcdir
-+    topsrcdir = append_relative(depth, topsrcdir)
-   if not os.path.isabs(srcdir):
--    srcdir = depth + "/" + srcdir
-+    srcdir = append_relative(depth, srcdir)
-   #TODO: should compare with the existing file and not overwrite it if the
-   # contents are the same!
-   ensure_directory_exists(filename)
-@@ -261,7 +267,7 @@
-       qualified_target)
-     build_file = os.path.abspath(build_file)
-     rel_path, output_file = self.CalculateMakefilePath(build_file, target)
--    subdepth = self.depth + "/" + getdepth(rel_path)
-+    subdepth = append_relative(self.depth, getdepth(rel_path))
-     if self.WriteTargetMakefile(output_file, rel_path, qualified_target, spec, build_file, subdepth):
-         # If WriteTargetMakefile returns True, then this is a useful target
-       dirs.append(rel_path)
-@@ -399,7 +405,7 @@
-   # The relative path from objdir to gyp_file_dir
-   srcdir = gyp.common.RelativePath(gyp_file_dir, objdir)
-   # The absolute path to the source dir
--  abs_srcdir = topsrcdir + "/" + relative_srcdir
-+  abs_srcdir = append_relative(topsrcdir, relative_srcdir)
-   # The path to get up to the root of the objdir from the output dir.
-   depth = getdepth(relative_srcdir)
-   # The output directory.
-@@ -408,9 +414,9 @@
-   makefile_path = os.path.join(output_dir, "Makefile")
-   def topsrcdir_path(path):
--    return "$(topsrcdir)/" + swapslashes(gyp.common.RelativePath(path, topsrcdir))
-+    return append_relative("$(topsrcdir)", swapslashes(gyp.common.RelativePath(path, topsrcdir)))
-   def objdir_path(path):
--    return "$(DEPTH)/" + swapslashes(gyp.common.RelativePath(path, objdir))
-+    return append_relative("$(DEPTH)", swapslashes(gyp.common.RelativePath(path, objdir)))
-   # Find the list of targets that derive from the gyp file(s) being built.
-   needed_targets = set()
index d4386c233ae6a5fb6a041e3a3a93c6a34a64c16a..a2bae15dc53397e28e130e51a88020e34db72e3f 100644 (file)
  
  // Enables some extra Extension System Logging (can reduce performance) 
  pref("extensions.logging.enabled", false); 
+@@ -208,6 +207,7 @@ pref("extensions.update.url", "https://versioncheck.addons.mozilla.org/update/Ve
+ pref("extensions.update.interval", 86400);  // Check for updates to Extensions and
+                                             // Themes every day
++pref("extensions.getMoreThemesURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/themes/");
+ pref("extensions.dss.enabled", false);          // Dynamic Skin Switching                                               
+ pref("extensions.dss.switchPending", false);    // Non-dynamic switch pending after next
 @@ -391,7 +391,7 @@
  
  pref("spellchecker.dictionary", "");
  
  // Windows taskbar support
  #ifdef XP_WIN
---- mozilla/mail/base/content/baseMenuOverlay.xul~     2011-08-12 15:52:04.000000000 +0200
-+++ mozilla/mail/base/content/baseMenuOverlay.xul      2011-09-17 15:29:32.946531066 +0200
-@@ -73,9 +73,6 @@
-       <menuitem id="whatsNew"
-                 label="&whatsNewCmd.label;" accesskey="&whatsNewCmd.accesskey;"
-                 oncommand="openWhatsNew();"/>
--      <menuitem id="releaseNotes"
--                label="&releaseCmd2.label;" accesskey="&releaseCmd2.accesskey;"
--                oncommand="openFormattedURL('app.releaseNotesURL');"/>
-       <menuseparator id="functionsSeparator"/>
-       <menuitem id="featureConfigurator"
-                 label="&featureConfiguratorCmd.label;"
+--- mozilla/mail/locales/en-US/chrome/messenger/accountCreation.dtd~
++++ mozilla/mail/locales/en-US/chrome/messenger/accountCreation.dtd
+@@ -78,7 +78,7 @@
+ <!ENTITY changeSettings.label            "Change Settings">
+ <!ENTITY changeSettings.accesskey        "S">
+-<!ENTITY contactYourProvider.description "&brandShortName; can allow you to get to your mail using the provided configurations. However, you should contact your administrator or email provider regarding these improper connections. See the Thunderbird FAQ for more information.">
++<!ENTITY contactYourProvider.description "&brandShortName; can allow you to get to your mail using the provided configurations. However, you should contact your administrator or email provider regarding these improper connections. See the Icedove FAQ for more information.">
+ <!ENTITY insecureServer.tooltip.title    "Warning! This is an insecure server.">
+ <!ENTITY insecureServer.tooltip.details  "Click circle for more details.">
 --- mozilla/mail/confvars.sh~  2011-08-12 15:52:05.000000000 +0200
 +++ mozilla/mail/confvars.sh   2011-09-17 15:34:33.613167078 +0200
 @@ -36,8 +36,8 @@
  MOZ_UPDATER=1
  MOZ_THUNDERBIRD=1
  MOZ_CHROME_FILE_FORMAT=omni
---- mozilla/mozilla/toolkit/xre/nsAppRunner.cpp~       2011-08-12 16:16:45.000000000 +0200
-+++ mozilla/mozilla/toolkit/xre/nsAppRunner.cpp        2011-09-17 15:36:16.599823973 +0200
-@@ -1324,8 +1324,7 @@
- static inline void
- DumpVersion()
- {
--  printf("%s %s %s", 
--         gAppData->vendor ? gAppData->vendor : "", gAppData->name, gAppData->version);
-+  printf("%s %s", gAppData->name, gAppData->version);
-   if (gAppData->copyright)
-       printf(", %s", gAppData->copyright);
-   printf("\n");
index 8dc6fabe6c6cfa896024227dddf4d6d12d99a470..f0eac8f1f12d22f0abb876d8169970b54c08510c 100644 (file)
@@ -123,9 +123,9 @@ diff -ur comm-1.9.1/mozilla/modules/libpref/src/init/all.js comm-1.9.1.new/mozil
  
  pref("font.default.x-devanagari", "serif");
  pref("font.size.variable.x-devanagari", 16);
-@@ -2138,25 +2138,25 @@
- pref("font.size.variable.x-tamil", 16);
- pref("font.size.fixed.x-tamil", 13);
+@@ -2138,13 +2138,13 @@
+ pref("font.size.variable.x-tibt", 16);
+ pref("font.size.fixed.x-tibt", 13);
  
 -pref("font.default.x-unicode", "serif");
 +pref("font.default.x-unicode", "sans-serif");
@@ -139,23 +139,5 @@ diff -ur comm-1.9.1/mozilla/modules/libpref/src/init/all.js comm-1.9.1.new/mozil
 -pref("font.size.fixed.x-western", 13);
 +pref("font.size.fixed.x-western", 14);
  
--pref("font.default.zh-CN", "serif");
-+pref("font.default.zh-CN", "sans-serif");
+ pref("font.default.zh-CN", "sans-serif");
  pref("font.size.variable.zh-CN", 16);
--pref("font.size.fixed.zh-CN", 16);
-+pref("font.size.fixed.zh-CN", 14);
--pref("font.default.zh-TW", "serif");
-+pref("font.default.zh-TW", "sans-serif");
- pref("font.size.variable.zh-TW", 16);
--pref("font.size.fixed.zh-TW", 16);
-+pref("font.size.fixed.zh-TW", 14);
--pref("font.default.zh-HK", "serif");
-+pref("font.default.zh-HK", "sans-serif");
- pref("font.size.variable.zh-HK", 16);
--pref("font.size.fixed.zh-HK", 16);
-+pref("font.size.fixed.zh-HK", 14);
- pref("netinst.profile.show_profile_wizard", true); 
diff --git a/icedove-sh.patch b/icedove-sh.patch
deleted file mode 100644 (file)
index 5666d73..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- mozilla/configure.orig     2014-04-24 18:27:27.000000000 +0200
-+++ mozilla/configure  2014-05-11 15:43:20.989605097 +0200
-@@ -1091,9 +1091,6 @@
- files = [
- EOF
--for out in ; do
--  echo "    '$out'," >> $CONFIG_STATUS
--done
- cat >> $CONFIG_STATUS <<\EOF
- ]
index 657b75720532acc5004586aa80ed17f28aa579de..5558feb0cfb9fc4fb486ba98ce0a325ed8241f07 100644 (file)
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       24.8.1
-Release:       1
+Version:       31.3.0
+Release:       0.1
 License:       MPL v2.0
 Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 24f90b2a2da3b0eee1ffc527bcf765a8
+# Source0-md5: 3781dfb541412c7f6b530a654b834ce5
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: d8e6897870bf288fdf264c0e9ef85f7d
 Source3:       %{name}-rm_nonfree.sh
 Source4:       %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
-Patch2:                %{name}-sh.patch
 Patch3:                %{name}-fonts.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
@@ -46,7 +45,6 @@ Patch10:      %{name}-extensiondir.patch
 Patch12:       no-subshell.patch
 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
 Patch13:       system-virtualenv.patch
-Patch14:       gyp-slashism.patch
 Patch15:       enable-addons.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 BuildRequires: GConf2-devel >= 1.2.1
@@ -146,12 +144,11 @@ funkcjonalność kalendarza.
 
 %prep
 %setup -qc
-mv comm-esr24 mozilla
+%{__mv} comm-esr31 mozilla
 %setup -q -T -D -a2
 cd mozilla
 /bin/sh %{SOURCE3}
 %patch0 -p1
-%patch2 -p1
 %patch3 -p1
 %patch6 -p1
 %patch7 -p1
@@ -159,7 +156,6 @@ cd mozilla
 %patch10 -p2
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
 %patch15 -p1
 
 %build
index 3fe1c4e3cc996b2abe8339cdf2bd039e5e90bbdc..6f38f72441d112b04d49d61926405bd27c0636b4 100644 (file)
@@ -27,9 +27,9 @@
 +    LDAP_COMPONENT=mozldap
 +    LDAP_MODULE="MODULE(nsLDAPProtocolModule)"
 +elif test "$MOZ_LDAP_XPCOM"; then
-     MOZ_ARG_ENABLE_BOOL(incomplete-toolkit-ldap-autocomplete,
-     [  --enable-incomplete-toolkit-ldap-autocomplete Builds a JavaScript component that implements an LDAP autocomplete component using the toolkit interfaces rather than the C++ component using the obsolete XPFE interfaces. ],
-         MOZ_INCOMPLETE_TOOLKIT_LDAP_AUTOCOMPLETE=1,
+     LDAP_CFLAGS='-I${DIST}/public/ldap'
+     if test "$OS_ARCH" = "WINNT"; then
+         if test -n "$GNU_CC"; then
 @@ -118,7 +130,7 @@
  
  # if we're building the LDAP XPCOM component, we need to build
index a2d150ff8ac26a4d3defa301da506f462b755971..3650d5697d974a2f36573b77a98fd3a6ebd9e257 100644 (file)
@@ -1,5 +1,5 @@
---- xulrunner-21.0/mozilla/build/virtualenv/populate_virtualenv.py~    2013-05-11 21:19:23.000000000 +0200
-+++ xulrunner-21.0/mozilla/build/virtualenv/populate_virtualenv.py     2013-05-14 22:51:32.136719267 +0200
+--- xulrunner-27.0/mozilla/python/mozbuild/mozbuild/virtualenv.py~     2013-05-11 21:19:23.000000000 +0200
++++ xulrunner-27.0/mozilla/python/mozbuild/mozbuild/virtualenv.py      2013-05-14 22:51:32.136719267 +0200
 @@ -37,8 +37,7 @@
      @property
      def virtualenv_script_path(self):
This page took 0.058147 seconds and 4 git commands to generate.