]> git.pld-linux.org Git - packages/icedove.git/commitdiff
- up to 12.0
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 16 May 2012 19:52:29 +0000 (19:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bug-722975-workaround.patch -> 1.1
    icedove.spec -> 1.155

bug-722975-workaround.patch [new file with mode: 0644]
icedove.spec

diff --git a/bug-722975-workaround.patch b/bug-722975-workaround.patch
new file mode 100644 (file)
index 0000000..1e91631
--- /dev/null
@@ -0,0 +1,37 @@
+https://bugzilla.mozilla.org/show_bug.cgi?id=722975
+https://bug722975.bugzilla.mozilla.org/attachment.cgi?id=595000
+
+--- firefox/gfx/thebes/gfxPlatform.cpp~        2012-02-07 11:59:39.717184907 +0000
++++ firefox/gfx/thebes/gfxPlatform.cpp 2012-02-07 13:06:01.084668445 +0000
+@@ -446,6 +446,7 @@
+   static_cast<SourceSurface*>(srcBuffer)->Release();
+ }
++#ifdef MOZ_TREE_CAIRO
+ void SourceSnapshotDetached(cairo_surface_t *nullSurf)
+ {
+   gfxImageSurface* origSurf =
+@@ -453,6 +454,7 @@
+   origSurf->SetData(&kSourceSurface, NULL, NULL);
+ }
++#endif
+ RefPtr<SourceSurface>
+ gfxPlatform::GetSourceSurfaceForSurface(DrawTarget *aTarget, gfxASurface *aSurface)
+@@ -522,6 +524,7 @@
+                                                      imgSurface->Stride(),
+                                                      format);
++    #ifdef MOZ_TREE_CAIRO
+     cairo_surface_t *nullSurf =
+       cairo_null_surface_create(CAIRO_CONTENT_COLOR_ALPHA);
+     cairo_surface_set_user_data(nullSurf,
+@@ -530,6 +533,7 @@
+                               NULL);
+     cairo_surface_attach_snapshot(imgSurface->CairoSurface(), nullSurf, SourceSnapshotDetached);
+     cairo_surface_destroy(nullSurf);
++    #endif
+   }
+   srcBuffer->AddRef();
index 1c561ecd8262834ceb01bc47ae46136477b1fb98..3a105f429642a3faa8ec66ade98371b3491a7def 100644 (file)
@@ -23,8 +23,8 @@
 %define                nspr_ver        4.9
 %define                nss_ver         3.13.3
 
-# convert thunderbird release number to platform version: 11.0.x -> 11.0.x
-%define                xulrunner_main  11.0
+# convert thunderbird release number to platform version: 12.0.x -> 12.0.x
+%define                xulrunner_main  12.0
 %define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#11.0})
 
 %if %{without xulrunner}
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       11.0
-Release:       2
+Version:       12.0
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 1d7127a3282e62d95eb9b59d47291b70
+# Source0-md5: 7b30b72472a65bce74ba0ae60e4d4e6c
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
 # Source1-md5: 5cf3d9720ed1cda1b22eabe5457772c2
 Source2:       %{name}-branding.tar.bz2
@@ -57,7 +57,8 @@ Patch5:               %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-
+# this is only workaround, check if it is fixed with newer firefox
+Patch9:                bug-722975-workaround.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
@@ -83,7 +84,7 @@ BuildRequires:        libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
-BuildRequires: pango-devel >= 1:1.1.0
+BuildRequires: pango-devel >= 1:1.14.0
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5
@@ -196,6 +197,9 @@ cd mozilla
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
+cd mozilla
+%patch9 -p1
+cd -
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
@@ -435,6 +439,8 @@ cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ex
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
 # mozldap
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
+# testpilot quiz
+%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.036574 seconds and 4 git commands to generate.