]> git.pld-linux.org Git - packages/hwloc.git/blob - hwloc.spec
65630eda9cfde016dacbc143ab3109cce463aee9
[packages/hwloc.git] / hwloc.spec
1 # TODO: CUDA >= 30.20, NVML/nvidia-ml on bcond?
2 # NOTES (as of 1.9-1.11):
3 # - kerrighed library (>= 2.0) is only checked for; kerrighed support in hwloc uses /proc filesystem
4 # - myriexpress (open-mx) library is only checked for, but not used by hwloc code
5 #   (just in one test); in binary packages only interface header is included
6 # - same with libibverbs
7 Summary:        Portable Hardware Locality
8 Summary(pl.UTF-8):      Przenośna lokalizacja sprzętu
9 Name:           hwloc
10 Version:        1.11.13
11 Release:        1
12 License:        BSD
13 Group:          Applications/System
14 #Future TODO (breaks API): https://www.open-mpi.org/software/hwloc/v2.0/
15 #Source0Download: https://www.open-mpi.org/software/hwloc/v1.11/
16 Source0:        https://download.open-mpi.org/release/hwloc/v1.11/%{name}-%{version}.tar.bz2
17 # Source0-md5:  3c792e23c209e9e1bafe9bdbc613d401
18 URL:            https://www.open-mpi.org/projects/hwloc/
19 BuildRequires:  OpenCL-devel
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  cairo-devel
22 BuildRequires:  libXNVCtrl-devel
23 BuildRequires:  libltdl-devel >= 2:2.2.6
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  ncurses-devel
27 BuildRequires:  numactl-devel
28 BuildRequires:  pkgconfig >= 1:0.9.0
29 BuildRequires:  udev-devel
30 BuildRequires:  xorg-lib-libX11-devel
31 BuildRequires:  xorg-lib-libXext-devel
32 BuildRequires:  xorg-lib-libpciaccess-devel
33 BuildRequires:  xorg-proto-xproto-devel
34 %if %{with tests}
35 BuildRequires:  libibverbs-devel
36 BuildRequires:  open-mx-devel
37 %endif
38 Requires:       %{name}-libs = %{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 The Portable Hardware Locality (hwloc) software package provides a
43 portable abstraction (across OS, versions, architectures, ...) of the
44 hierarchical topology of modern architectures, including NUMA memory
45 nodes, sockets, shared caches, cores and simultaneous multithreading.
46 It also gathers various system attributes such as cache and memory
47 information. It primarily aims at helping applications with gathering
48 information about modern computing hardware so as to exploit it
49 accordingly and efficiently.
50
51 %description -l pl.UTF-8
52 Pakiet HWLOC (Portable Hardware Locality) zapewnia przenośną (między
53 systemami operacyjnymi, werjami, architekturami...) abstrakcję
54 hierarchicznej topologii współczesnych architektur, w tym węzłów z
55 pamięcią NUMA, gniazd, współdzielonych pamięci podręcznych, rdzeni i
56 wielowątkowości. Gromadzi też różne właściwości systemów, takie jak
57 informacje o pamięci głównej i podręcznej. Głównym celem jest pomoc
58 aplikacjom w gromadzeniu informacji o współczesnym sprzęcie
59 obliczeniowym w celu jego właściwego i wydajnego wykorzystania.
60
61 %package libs
62 Summary:        Portable Hardware Locality (hwloc) library
63 Summary(pl.UTF-8):      Biblioteka przenośnej lokalizacji sprzętu (hwloc)
64 Group:          Libraries
65
66 %description libs
67 Portable Hardware Locality (hwloc) library.
68
69 %description libs -l pl.UTF-8
70 Biblioteka przenośnej lokalizacji sprzętu (hwloc).
71
72 %package devel
73 Summary:        Header files for hwloc library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki hwloc
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       libltdl-devel >= 2:2.2.6
78 Requires:       numactl-devel
79 Requires:       udev-devel
80
81 %description devel
82 Header files for hwloc library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki hwloc.
86
87 %prep
88 %setup -q
89
90 %build
91 %configure \
92         --enable-plugins \
93         --disable-silent-rules
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhwloc.la \
103         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
104
105 # packaged as %doc
106 %{__rm} $RPM_BUILD_ROOT%{_docdir}/hwloc/hwloc*.pdf
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   libs -p /sbin/ldconfig
112 %postun libs -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_bindir}/hwloc-*
117 %attr(755,root,root) %{_bindir}/lstopo
118 %attr(755,root,root) %{_bindir}/lstopo-no-graphics
119 %attr(755,root,root) %{_sbindir}/hwloc-dump-hwdata
120 %dir %{_libdir}/%{name}
121 %attr(755,root,root) %{_libdir}/%{name}/hwloc_opencl.so
122 %attr(755,root,root) %{_libdir}/%{name}/hwloc_pci.so
123 %attr(755,root,root) %{_libdir}/%{name}/hwloc_xml_libxml.so
124 %{_datadir}/%{name}
125 %{_desktopdir}/lstopo.desktop
126 %{_mandir}/man1/hwloc-*.1*
127 %{_mandir}/man1/lstopo.1*
128 %{_mandir}/man1/lstopo-no-graphics.1*
129 %{_mandir}/man7/hwloc.7*
130
131 %files libs
132 %defattr(644,root,root,755)
133 %doc AUTHORS COPYING NEWS README
134 %attr(755,root,root) %{_libdir}/libhwloc.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libhwloc.so.5
136
137 %files devel
138 %defattr(644,root,root,755)
139 %doc doc/doxygen-doc/html doc/doxygen-doc/hwloc-a4.pdf
140 %attr(755,root,root) %{_libdir}/libhwloc.so
141 %{_pkgconfigdir}/hwloc.pc
142 %{_includedir}/hwloc
143 %{_includedir}/hwloc.h
144 %{_mandir}/man3/HWLOC_*.3*
145 %{_mandir}/man3/hwloc_*.3*
146 %{_mandir}/man3/hwlocality_*.3*
This page took 0.06259 seconds and 2 git commands to generate.