]> git.pld-linux.org Git - packages/hhvm.git/commitdiff
fix gd symbols overlap with real gd lib
authorElan Ruusamäe <glen@delfi.ee>
Sun, 6 Oct 2013 14:12:39 +0000 (17:12 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 6 Oct 2013 14:12:39 +0000 (17:12 +0300)
gd-syms.patch [new file with mode: 0644]
hiphop-php.spec

diff --git a/gd-syms.patch b/gd-syms.patch
new file mode 100644 (file)
index 0000000..1c4c885
--- /dev/null
@@ -0,0 +1,29 @@
+--- hiphop-php-HPHP-2.1.0/hphp/runtime/ext/ext_image.cpp~      2013-07-12 18:00:55.000000000 +0000
++++ hiphop-php-HPHP-2.1.0/hphp/runtime/ext/ext_image.cpp       2013-10-06 12:44:00.105141356 +0000
+@@ -4188,7 +4188,7 @@
+   return false;
+ }
+-// gdImageConvolution does not exist in our libgd.a, copied from
++// hphp_gdImageConvolution does not exist in our libgd.a, copied from
+ // php's libgd/gd.c
+ /* Filters function added on 2003/12
+@@ -4200,7 +4200,7 @@
+   (src->trueColor?gdImageGetTrueColorPixel:gdImageGetPixel)
+ #endif
+-static int gdImageConvolution(gdImagePtr src, float filter[3][3],
++static int hphp_gdImageConvolution(gdImagePtr src, float filter[3][3],
+                               float filter_div, float offset) {
+   int x, y, i, j, new_a;
+   float new_r, new_g, new_b;
+@@ -4290,7 +4290,7 @@
+       }
+     }
+   }
+-  if (gdImageConvolution(im_src, mtx, div, offset)) {
++  if (hphp_gdImageConvolution(im_src, mtx, div, offset)) {
+     return true;
+   } else {
+     return false;
index c512fafb49ef9962fc5c4b70e05e959a38d6bc15..c0f713a9d6339ea5894cec03d628290ad1af00c9 100644 (file)
@@ -29,6 +29,7 @@ Patch4:               system-libafdt.patch
 Patch5:                system-folly.patch
 Patch6:                boost-system-category.patch
 Patch7:                gcc4.8.patch
+Patch8:                gd-syms.patch
 URL:           http://wiki.github.com/facebook/hiphop-php/
 BuildRequires: binutils-devel
 BuildRequires: bison >= 2.3
@@ -82,6 +83,7 @@ Apache and mod_php.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 ln -s libevent-1.4.*-stable libevent
 %{__patch} -d libevent -p1 < hphp/third_party/libevent-1.4.14.fb-changes.diff
This page took 0.040135 seconds and 4 git commands to generate.