]> git.pld-linux.org Git - packages/hdf.git/blob - hdf.spec
- shared,szip patches rediffed for fuzz 0
[packages/hdf.git] / hdf.spec
1 #
2 # Conditional build:
3 %bcond_without  szip    # build without SZIP support
4 #
5 Summary:        Hierarchical Data Format library
6 Summary(pl.UTF-8):      Biblioteka HDF (Hierarchical Data Format)
7 Name:           hdf
8 Version:        4.2.15
9 Release:        1
10 Epoch:          1
11 Group:          Libraries
12 License:        Nearly BSD, but changed sources must be marked
13 Source0:        https://support.hdfgroup.org/ftp/HDF/releases/HDF%{version}/src/hdf-%{version}.tar.bz2
14 # Source0-md5:  27ab87b22c31906883a0bfaebced97cb
15 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
16 # Source1-md5:  607df78cacc131b37dfdb443e61e789a
17 Patch0:         %{name}-shared.patch
18 Patch1:         %{name}-morearchs.patch
19 Patch2:         %{name}-link.patch
20 Patch3:         %{name}-szip.patch
21 Patch4:         %{name}-tirpc.patch
22 URL:            http://portal.hdfgroup.org/display/HDF4/HDF4
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  bison
26 BuildRequires:  flex
27 BuildRequires:  gcc-fortran
28 BuildRequires:  groff
29 BuildRequires:  libjpeg-devel >= 6b
30 BuildRequires:  libtirpc-devel
31 BuildRequires:  libtool >= 2:1.4d-3
32 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
33 BuildRequires:  which
34 BuildRequires:  zlib-devel >= 1.1.4
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 HDF is a multi-object file format that facilitates the transfer of
39 various types of scientific data between machines and operating
40 systems. Machines currently supported include the Cray, HP, Vax, Sun,
41 IBM RS/6000, Silicon Graphics, Macintosh, and IBM PC computers. HDF
42 allows self-definitions of data content and easy extensibility for
43 future enhancements or compatibility with other standard formats. HDF
44 includes Fortran and C calling interfaces,and utilities to prepare raw
45 image of data files or for use with other NCSA software. The HDF
46 library contains interfaces for storing and retrieving compressed or
47 uncompressed 8-bit and 24-bit raster images with palettes,
48 n-Dimensional scientific datasets and binary tables. An interface is
49 also included that allows arbitray grouping of other HDF objects.
50
51 %description -l pl.UTF-8
52 HDF jest wieloobiektowym formatem plików ułatwiającym przenoszenie
53 różnych danych naukowych pomiędzy różnymi komputerami i systemami
54 operacyjnymi. Aktualnie obsługiwane są m.in. Cray, HP, Vax, Sun, IBM
55 RS/6000, Silicon Graphics, Macintosh i IBM PC. HDF zawiera interfejsy
56 do Fortranu i C oraz narzędzia do przygotowywania plików z danymi.
57 Biblioteka pozwala na przechowywanie i odczytywanie skompresowanych
58 lub nie 8-bitowych i 24-bitowych obrazków z paletą, wielowymiarowych
59 zestawów danych itp.
60
61 %package devel
62 Summary:        HDF library development package
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF
64 Group:          Development/Libraries
65 Requires:       %{name} = %{epoch}:%{version}-%{release}
66 Requires:       libjpeg-devel >= 6b
67 Requires:       libtirpc-devel
68 %{?with_szip:Requires:  szip-devel >= 2.0}
69 Requires:       zlib-devel >= 1.1.4
70
71 %description devel
72 Header files for HDF library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki HDF.
76
77 %package static
78 Summary:        HDF static library
79 Summary(pl.UTF-8):      Statyczna biblioteka HDF
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
82
83 %description static
84 Static version of HDF library.
85
86 %description static -l pl.UTF-8
87 Statyczna wersja biblioteki HDF.
88
89 %package progs
90 Summary:        HDF utilities
91 Summary(pl.UTF-8):      Narzędzia do plików HDF
92 Group:          Applications/File
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94
95 %description progs
96 Utilities to convert from/to HDF format.
97
98 %description progs -l pl.UTF-8
99 Narzędzia do konwersji z i do formatu HDF.
100
101 %package examples
102 Summary:        HDF example programs (source code)
103 Summary(pl.UTF-8):      Przykładowe programy dla biblioteki HDF (w postaci źródłowej)
104 Group:          Documentation
105
106 %description examples
107 HDF example programs (source code).
108
109 %description examples -l pl.UTF-8
110 Przykładowe programy dla biblioteki HDF (w postaci źródłowej).
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117 %patch3 -p1
118 %patch4 -p1
119
120 %build
121 %{__libtoolize}
122 %{__aclocal}
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 # need to pass F77 to override F77=g77 in config/linux-gnu
127 %configure \
128 %ifarch x32
129         F77="x86_64-pld-linux-gnux32-gfortran" \
130 %else
131         F77="%{_target_cpu}-pld-linux-gfortran" \
132 %endif
133         --enable-shared \
134         %{?with_szip:--with-szlib}
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{%{_mandir}/man{3,7},%{_includedir}/hdf}
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
145         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c \
146
147 %{__mv} $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
148
149 cp -p man/gr_chunk.3 $RPM_BUILD_ROOT%{_mandir}/man3
150 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/hdf.1 $RPM_BUILD_ROOT%{_mandir}/man7/hdf.7
151
152 # resolve conflict with netcdf
153 for i in ncdump ncgen ; do
154         %{__mv} $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_bindir}/hdf$i
155         %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/$i.1 $RPM_BUILD_ROOT%{_mandir}/man1/hdf$i.1
156 done
157
158 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
159 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.hdf-man-pages
160 %{__rm} $RPM_BUILD_ROOT%{_mandir}/diff.*
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -p /sbin/ldconfig
166 %postun -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc COPYING README.txt release_notes/{HISTORY,RELEASE,bugs_fixed,misc_docs}.txt
171 %attr(755,root,root) %{_libdir}/libdf.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libdf.so.0
173 %attr(755,root,root) %{_libdir}/libmfhdf.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libmfhdf.so.0
175 %{_libdir}/libhdf4.settings
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libdf.so
180 %attr(755,root,root) %{_libdir}/libmfhdf.so
181 %{_libdir}/libdf.la
182 %{_libdir}/libmfhdf.la
183 %{_includedir}/hdf
184 %{_mandir}/man3/gr_chunk.3*
185 %{_mandir}/man7/hdf.7*
186
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libdf.a
190 %{_libdir}/libmfhdf.a
191
192 %files progs
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/gif2hdf
195 %attr(755,root,root) %{_bindir}/h4cc
196 %attr(755,root,root) %{_bindir}/h4fc
197 %attr(755,root,root) %{_bindir}/h4redeploy
198 %attr(755,root,root) %{_bindir}/hdf24to8
199 %attr(755,root,root) %{_bindir}/hdf2gif
200 %attr(755,root,root) %{_bindir}/hdf2jpeg
201 %attr(755,root,root) %{_bindir}/hdf8to24
202 %attr(755,root,root) %{_bindir}/hdfcomp
203 %attr(755,root,root) %{_bindir}/hdfed
204 %attr(755,root,root) %{_bindir}/hdfimport
205 %attr(755,root,root) %{_bindir}/hdfls
206 %attr(755,root,root) %{_bindir}/hdfncdump
207 %attr(755,root,root) %{_bindir}/hdfncgen
208 %attr(755,root,root) %{_bindir}/hdfpack
209 %attr(755,root,root) %{_bindir}/hdftopal
210 %attr(755,root,root) %{_bindir}/hdftor8
211 %attr(755,root,root) %{_bindir}/hdfunpac
212 %attr(755,root,root) %{_bindir}/hdiff
213 %attr(755,root,root) %{_bindir}/hdp
214 %attr(755,root,root) %{_bindir}/hrepack
215 %attr(755,root,root) %{_bindir}/jpeg2hdf
216 %attr(755,root,root) %{_bindir}/paltohdf
217 %attr(755,root,root) %{_bindir}/r8tohdf
218 %attr(755,root,root) %{_bindir}/ristosds
219 %attr(755,root,root) %{_bindir}/vmake
220 %attr(755,root,root) %{_bindir}/vshow
221 %{_mandir}/man1/fp2hdf.1*
222 %{_mandir}/man1/gif2hdf.1*
223 %{_mandir}/man1/hdf24to8.1*
224 %{_mandir}/man1/hdf2gif.1*
225 %{_mandir}/man1/hdf2jpeg.1*
226 %{_mandir}/man1/hdf8to24.1*
227 %{_mandir}/man1/hdfcomp.1*
228 %{_mandir}/man1/hdfed.1*
229 %{_mandir}/man1/hdfls.1*
230 %{_mandir}/man1/hdfncdump.1*
231 %{_mandir}/man1/hdfncgen.1*
232 %{_mandir}/man1/hdfpack.1*
233 %{_mandir}/man1/hdftopal.1*
234 %{_mandir}/man1/hdftor8.1*
235 %{_mandir}/man1/hdp.1*
236 %{_mandir}/man1/jpeg2hdf.1*
237 %{_mandir}/man1/paltohdf.1*
238 %{_mandir}/man1/r8tohdf.1*
239 %{_mandir}/man1/ristosds.1*
240 %{_mandir}/man1/vmake.1*
241 %{_mandir}/man1/vshow.1*
242
243 %files examples
244 %defattr(644,root,root,755)
245 %dir %{_examplesdir}/%{name}-%{version}
246 %{_examplesdir}/%{name}-%{version}/README
247 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
248 %dir %{_examplesdir}/%{name}-%{version}/c
249 %{_examplesdir}/%{name}-%{version}/c/*.c
250 %{_examplesdir}/%{name}-%{version}/c/*.f
251 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/c/run-c-ex.sh
252 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/c/run-fortran-ex.sh
This page took 0.051391 seconds and 3 git commands to generate.