]> git.pld-linux.org Git - packages/hdf.git/blob - hdf.spec
0c481bb543fa25e81371282b54bf9aa99eb0ccf4
[packages/hdf.git] / hdf.spec
1 #
2 # Conditional build:
3 %bcond_without  szip    # build without SZIP support
4 #
5 Summary:        Hierarchical Data Format library
6 Summary(pl.UTF-8):      Biblioteka HDF (Hierarchical Data Format)
7 Name:           hdf
8 Version:        4.2.9
9 Release:        1
10 Epoch:          1
11 Group:          Libraries
12 License:        Nearly BSD, but changed sources must be marked
13 Source0:        ftp://ftp.hdfgroup.org/HDF/HDF_Current/src/hdf-%{version}.tar.bz2
14 # Source0-md5:  c268a703f334ee4987fa710a0de9b9fc
15 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
16 # Source1-md5:  607df78cacc131b37dfdb443e61e789a
17 Patch0:         %{name}-shared.patch
18 Patch1:         %{name}-morearchs.patch
19 Patch2:         %{name}-link.patch
20 URL:            http://hdf.ncsa.uiuc.edu/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  bison
24 BuildRequires:  flex
25 BuildRequires:  gcc-fortran
26 BuildRequires:  groff
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libtool >= 2:1.4d-3
29 BuildRequires:  netcdf-devel
30 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
31 BuildRequires:  which
32 BuildRequires:  zlib-devel >= 1.1.4
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 HDF is a multi-object file format that facilitates the transfer of
37 various types of scientific data between machines and operating
38 systems. Machines currently supported include the Cray, HP, Vax, Sun,
39 IBM RS/6000, Silicon Graphics, Macintosh, and IBM PC computers. HDF
40 allows self-definitions of data content and easy extensibility for
41 future enhancements or compatibility with other standard formats. HDF
42 includes Fortran and C calling interfaces,and utilities to prepare raw
43 image of data files or for use with other NCSA software. The HDF
44 library contains interfaces for storing and retrieving compressed or
45 uncompressed 8-bit and 24-bit raster images with palettes,
46 n-Dimensional scientific datasets and binary tables. An interface is
47 also included that allows arbitray grouping of other HDF objects.
48
49 %description -l pl.UTF-8
50 HDF jest wieloobiektowym formatem plików ułatwiającym przenoszenie
51 różnych danych naukowych pomiędzy różnymi komputerami i systemami
52 operacyjnymi. Aktualnie obsługiwane są m.in. Cray, HP, Vax, Sun, IBM
53 RS/6000, Silicon Graphics, Macintosh i IBM PC. HDF zawiera interfejsy
54 do Fortranu i C oraz narzędzia do przygotowywania plików z danymi.
55 Biblioteka pozwala na przechowywanie i odczytywanie skompresowanych
56 lub nie 8-bitowych i 24-bitowych obrazków z paletą, wielowymiarowych
57 zestawów danych itp.
58
59 %package devel
60 Summary:        HDF library development package
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF
62 Group:          Development/Libraries
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 Requires:       libjpeg-devel >= 6b
65 %{?with_szip:Requires:  szip-devel >= 2.0}
66 Requires:       zlib-devel >= 1.1.4
67
68 %description devel
69 Header files for HDF library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki HDF.
73
74 %package static
75 Summary:        HDF static library
76 Summary(pl.UTF-8):      Statyczna biblioteka HDF
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
79
80 %description static
81 Static version of HDF library.
82
83 %description static -l pl.UTF-8
84 Statyczna wersja biblioteki HDF.
85
86 %package progs
87 Summary:        HDF utilities
88 Summary(pl.UTF-8):      Narzędzia do plików HDF
89 Group:          Applications/File
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91
92 %description progs
93 Utilities to convert from/to HDF format.
94
95 %description progs -l pl.UTF-8
96 Narzędzia do konwersji z i do formatu HDF.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 # evil -R
105 sed -i '/^if HDF_BUILD_XDR/,/^endif/d;/^if HDF_BUILD_SHARED/,/^endif/d' config/commence.am
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 # need to pass F77 to override F77=g77 in config/linux-gnu
114 %configure \
115         F77="%{_target_cpu}-pld-linux-gfortran" \
116         --enable-shared \
117         %{?with_szip:--with-szlib}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_mandir}/man{3,7},%{_includedir}/hdf}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 mv -f $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
129
130 install man/gr_chunk.3 $RPM_BUILD_ROOT%{_mandir}/man3
131 mv -f $RPM_BUILD_ROOT%{_mandir}/man1/hdf.1 $RPM_BUILD_ROOT%{_mandir}/man7/hdf.7
132
133 # resolve conflict with netcdf
134 for i in ncdump ncgen ; do
135         mv -f $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_bindir}/hdf$i
136         mv -f $RPM_BUILD_ROOT%{_mandir}/man1/$i.1 $RPM_BUILD_ROOT%{_mandir}/man1/hdf$i.1
137 done
138
139 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
140 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.hdf-man-pages
141 %{__rm} $RPM_BUILD_ROOT%{_mandir}/diff.*
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc COPYING README.txt release_notes/{HISTORY,RELEASE,bugs_fixed,misc_docs}.txt
152 %attr(755,root,root) %{_libdir}/libdf.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libdf.so.0
154 %attr(755,root,root) %{_libdir}/libmfhdf.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libmfhdf.so.0
156 %{_libdir}/libhdf4.settings
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libdf.so
161 %attr(755,root,root) %{_libdir}/libmfhdf.so
162 %{_libdir}/libdf.la
163 %{_libdir}/libmfhdf.la
164 %{_includedir}/hdf
165 %{_mandir}/man3/gr_chunk.3*
166 %{_mandir}/man7/hdf.7*
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libdf.a
171 %{_libdir}/libmfhdf.a
172
173 %files progs
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/gif2hdf
176 %attr(755,root,root) %{_bindir}/h4cc
177 %attr(755,root,root) %{_bindir}/h4fc
178 %attr(755,root,root) %{_bindir}/h4redeploy
179 %attr(755,root,root) %{_bindir}/hdf24to8
180 %attr(755,root,root) %{_bindir}/hdf2gif
181 %attr(755,root,root) %{_bindir}/hdf2jpeg
182 %attr(755,root,root) %{_bindir}/hdf8to24
183 %attr(755,root,root) %{_bindir}/hdfcomp
184 %attr(755,root,root) %{_bindir}/hdfed
185 %attr(755,root,root) %{_bindir}/hdfimport
186 %attr(755,root,root) %{_bindir}/hdfls
187 %attr(755,root,root) %{_bindir}/hdfncdump
188 %attr(755,root,root) %{_bindir}/hdfncgen
189 %attr(755,root,root) %{_bindir}/hdfpack
190 %attr(755,root,root) %{_bindir}/hdftopal
191 %attr(755,root,root) %{_bindir}/hdftor8
192 %attr(755,root,root) %{_bindir}/hdfunpac
193 %attr(755,root,root) %{_bindir}/hdiff
194 %attr(755,root,root) %{_bindir}/hdp
195 %attr(755,root,root) %{_bindir}/hrepack
196 %attr(755,root,root) %{_bindir}/jpeg2hdf
197 %attr(755,root,root) %{_bindir}/paltohdf
198 %attr(755,root,root) %{_bindir}/r8tohdf
199 %attr(755,root,root) %{_bindir}/ristosds
200 %attr(755,root,root) %{_bindir}/vmake
201 %attr(755,root,root) %{_bindir}/vshow
202 %{_mandir}/man1/fp2hdf.1*
203 %{_mandir}/man1/gif2hdf.1*
204 %{_mandir}/man1/hdf24to8.1*
205 %{_mandir}/man1/hdf2gif.1*
206 %{_mandir}/man1/hdf2jpeg.1*
207 %{_mandir}/man1/hdf8to24.1*
208 %{_mandir}/man1/hdfcomp.1*
209 %{_mandir}/man1/hdfed.1*
210 %{_mandir}/man1/hdfls.1*
211 %{_mandir}/man1/hdfncdump.1*
212 %{_mandir}/man1/hdfncgen.1*
213 %{_mandir}/man1/hdfpack.1*
214 %{_mandir}/man1/hdftopal.1*
215 %{_mandir}/man1/hdftor8.1*
216 %{_mandir}/man1/hdp.1*
217 %{_mandir}/man1/jpeg2hdf.1*
218 %{_mandir}/man1/paltohdf.1*
219 %{_mandir}/man1/r8tohdf.1*
220 %{_mandir}/man1/ristosds.1*
221 %{_mandir}/man1/vmake.1*
222 %{_mandir}/man1/vshow.1*
This page took 0.061923 seconds and 2 git commands to generate.