]> git.pld-linux.org Git - packages/h2o.git/blob - h2o.spec
b0c3d850c2630b41e45a929504aed63b270cda48
[packages/h2o.git] / h2o.spec
1 # TODO
2 # - libwslay for websockets
3 #
4 # Conditional build:
5 %bcond_without  mruby           # using mruby scripting support (Rack-based)
6
7 Summary:        H2O - an optimized HTTP server with support for HTTP/1.x and HTTP/2
8 Name:           h2o
9 Version:        2.2.2
10 Release:        0.1
11 License:        MIT
12 Group:          Networking/Daemons/HTTP
13 Source0:        https://github.com/h2o/h2o/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  efc3a98cd21d3b91d66b2a99b1518255
15 URL:            https://h2o.examp1e.net/
16 BuildRequires:  cmake >= 2.8.11
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libuv-devel >= 1.0.0
19 BuildRequires:  openssl-devel >= 1.0.2
20 BuildRequires:  pkgconfig
21 BuildRequires:  yaml-devel
22 BuildRequires:  zlib-devel
23 %if %{with mruby}
24 BuildRequires:  bison
25 BuildRequires:  ruby-devel
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 H2O is a very fast HTTP server written in C. It can also be used as a
31 library.
32
33 %package devel
34 Summary:        Header files for h2o library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki h2o
36 Group:          Development/Libraries
37 Requires:       %{name}-libs = %{version}-%{release}
38
39 %description devel
40 Header files for h2o library.
41
42 %prep
43 %setup -q
44
45 %build
46 install -d build
47 cd build
48 %cmake \
49         -DWITH_MRUBY=%{!?with_mruby:OFF}%{?with_mruby:ON} \
50         ..
51 %{__make} \
52         V=1
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %{__make} install -C build \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README.md Changes LICENSE
70 %attr(755,root,root) %{_bindir}/h2o
71 %{_libdir}/libh2o.so.0.13
72 %attr(755,root,root) %{_libdir}/libh2o.so.*.*.*
73 %{_libdir}/libh2o-evloop.so.0.13
74 %attr(755,root,root) %{_libdir}/libh2o-evloop.so.*.*.*
75 %dir %{_datadir}/%{name}
76 %{_datadir}/%{name}/status
77 %attr(755,root,root) %{_datadir}/%{name}/annotate-backtrace-symbols
78 %attr(755,root,root) %{_datadir}/%{name}/fastcgi-cgi
79 %attr(755,root,root) %{_datadir}/%{name}/fetch-ocsp-response
80 %attr(755,root,root) %{_datadir}/%{name}/kill-on-close
81 %attr(755,root,root) %{_datadir}/%{name}/setuidgid
82 %attr(755,root,root) %{_datadir}/%{name}/start_server
83 # TODO: use ca-certificates package
84 %{_datadir}/%{name}/ca-bundle.crt
85
86 %if %{with mruby}
87 %{_datadir}/%{name}/mruby
88 %endif
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/h2o.h
93 %{_includedir}/h2o
94 %{_libdir}/libh2o.so
95 %{_libdir}/libh2o-evloop.so
96 %{_pkgconfigdir}/libh2o.pc
97 %{_pkgconfigdir}/libh2o-evloop.pc
This page took 0.066136 seconds and 2 git commands to generate.