]> git.pld-linux.org Git - packages/gupnp.git/blob - gupnp.spec
d35dace05c245a802d46bcdb182300f42a82b4a7
[packages/gupnp.git] / gupnp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala API
4 #
5 Summary:        UPnP library based on GObject and libsoup
6 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
7 Name:           gupnp
8 # note: 0.20.x is stable, 0.21.x unstable
9 Version:        0.20.15
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp/0.20/%{name}-%{version}.tar.xz
14 # Source0-md5:  bd014927da034361de79fdc657508bf7
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  docbook-dtd44-xml
20 BuildRequires:  glib2-devel >= 1:2.40.0
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 BuildRequires:  gssdp-devel >= 0.14.13
23 BuildRequires:  gtk-doc >= 1.14
24 BuildRequires:  libsoup-devel >= 2.48.0
25 BuildRequires:  libtool >= 2:2.2
26 BuildRequires:  libuuid-devel >= 1.36
27 BuildRequires:  libxml2-devel >= 1:2.6.30
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  tar >= 1:1.22
31 %{?with_vala:BuildRequires:     vala >= 2:0.20}
32 %{?with_vala:BuildRequires:     vala-gssdp >= 0.14.13}
33 BuildRequires:  xz
34 Requires:       glib2 >= 1:2.40.0
35 Requires:       gssdp >= 0.14.13
36 Requires:       libsoup >= 2.48.0
37 Requires:       libuuid >= 1.36
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 GUPnP is an object-oriented open source framework for creating UPnP
42 devices and control points, written in C using GObject and libsoup.
43 The GUPnP API is intended to be easy to use, efficient and flexible.
44
45 %description -l pl.UTF-8
46 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
47 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
48 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
49 i elastyczne.
50
51 %package devel
52 Summary:        Header files for gupnp
53 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       glib2-devel >= 1:2.40.0
57 Requires:       gssdp-devel >= 0.14.13
58 Requires:       libsoup-devel >= 2.48.0
59 Requires:       libuuid-devel >= 1.36
60 Requires:       libxml2-devel >= 1:2.6.30
61
62 %description devel
63 This package contains header files for the Linux SDK for UPnP Devices
64 (gupnp).
65
66 %description devel -l pl.UTF-8
67 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
68 programistycznego do urządzeń UPnP (gupnp).
69
70 %package static
71 Summary:        Static gupnp libraries
72 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static gupnp libraries.
78
79 %description static -l pl.UTF-8
80 Statyczne biblioteki gupnp.
81
82 %package apidocs
83 Summary:        gupnp API documentation
84 Summary(pl.UTF-8):      Dokumentacja API gupnp
85 Group:          Documentation
86 Requires:       gtk-doc-common
87
88 %description apidocs
89 gupnp API documentation.
90
91 %description apidocs -l pl.UTF-8
92 Dokumentacja API gupnp.
93
94 %package -n vala-gupnp
95 Summary:        Vala API for gupnp library
96 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Requires:       vala >= 2:0.20
100 Requires:       vala-gssdp >= 0.14.13
101
102 %description -n vala-gupnp
103 Vala API for gupnp library.
104
105 %description -n vala-gupnp -l pl.UTF-8
106 API języka Vala dla biblioteki gupnp.
107
108 %prep
109 %setup -q
110
111 %build
112 %{__gtkdocize}
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         --disable-silent-rules \
120         --enable-gtk-doc \
121         --with-html-dir=%{_gtkdocdir} \
122         --with-context-manager=network-manager
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README
143 %attr(755,root,root) %{_bindir}/gupnp-binding-tool
144 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.0.so.4
146 %{_libdir}/girepository-1.0/GUPnP-1.0.typelib
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so
151 %{_datadir}/gir-1.0/GUPnP-1.0.gir
152 %{_includedir}/gupnp-1.0
153 %{_pkgconfigdir}/gupnp-1.0.pc
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libgupnp-1.0.a
158
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/gupnp
162
163 %if %{with vala}
164 %files -n vala-gupnp
165 %defattr(644,root,root,755)
166 %{_datadir}/vala/vapi/gupnp-1.0.deps
167 %{_datadir}/vala/vapi/gupnp-1.0.vapi
168 %endif
This page took 0.056629 seconds and 2 git commands to generate.