]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview3.spec
- updated to 3.14.1
[packages/gtksourceview5.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 %bcond_without  vala    # do not build Vala API
5 #
6 Summary:        Text widget that extends the standard GTK+ 3.x
7 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
8 Name:           gtksourceview3
9 Version:        3.14.1
10 Release:        1
11 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.14/gtksourceview-%{version}.tar.xz
14 # Source0-md5:  a769939c7a3e3a07d365740404de1bd7
15 URL:            http://www.gnome.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  gettext-devel >= 0.17
20 BuildRequires:  glib2-devel >= 1:2.38.0
21 BuildRequires:  gnome-common >= 2.24.0
22 BuildRequires:  gobject-introspection-devel >= 0.10.0
23 BuildRequires:  gtk+3-devel >= 3.14.0
24 BuildRequires:  gtk-doc >= 1.11
25 BuildRequires:  intltool >= 0.40.0
26 %if %{with glade}
27 BuildRequires:  libgladeui-devel >= 3.9.0
28 %endif
29 BuildRequires:  libtool >= 2:2.2.6
30 BuildRequires:  libxml2-devel >= 1:2.6.31
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  vala
35 BuildRequires:  xz
36 Requires:       glib2 >= 1:2.38.0
37 Requires:       gtk+3 >= 3.14.0
38 Requires:       libxml2 >= 1:2.6.31
39 # sr@Latn vs. sr@latin
40 Conflicts:      glibc-misc < 6:2.7
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
45 widget GtkTextView. It improves GtkTextView by implementing syntax
46 highlighting and other features typical of a source editor.
47
48 %description -l pl.UTF-8
49 GtkSourceView to widget tekstowy rozszerzający standardowy widget
50 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
51 zaimplementowanie podświetlania składni i innych możliwości typowych
52 dla edytora źródeł.
53
54 %package apidocs
55 Summary:        GtkSourceView API documentation
56 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
57 Group:          Documentation
58 Requires:       gtk-doc-common
59
60 %description apidocs
61 GtkSourceView API documentation.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API GtkSourceView.
65
66 %package devel
67 Summary:        Header files for GtkSourceView
68 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
69 Group:          X11/Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       glib2-devel >= 1:2.38.0
72 Requires:       gtk+3-devel >= 3.14.0
73 Requires:       libxml2-devel >= 1:2.6.31
74
75 %description devel
76 Header files for GtkSourceView.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe dla GtkSourceView.
80
81 %package static
82 Summary:        Static GtkSourceView library
83 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
84 Group:          X11/Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static GtkSourceView library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka GtkSourceView.
92
93 %package -n glade3-gtksourceview
94 Summary:        Glade3 catalog entry for GtkSourceView library
95 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Requires:       libgladeui >= 3.9.0
99
100 %description -n glade3-gtksourceview
101 Glade3 catalog entry for GtkSourceView library.
102
103 %description -n glade3-gtksourceview -l pl.UTF-8
104 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
105
106 %package -n vala-gtksourceview
107 Summary:        GtkSourceView API for Vala language
108 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111 Requires:       vala
112
113 %description -n vala-gtksourceview
114 GtkSourceView API for Vala language.
115
116 %description -n vala-gtksourceview -l pl.UTF-8
117 API GtkSourceView dla języka Vala.
118
119 %prep
120 %setup -q -n gtksourceview-%{version}
121
122 %build
123 %{__gtkdocize}
124 %{__intltoolize}
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         %{__enable glade glade-catalog} \
132         --enable-gtk-doc \
133         --enable-providers \
134         --disable-silent-rules \
135         --enable-static \
136         --with-html-dir=%{_gtkdocdir}
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
146
147 %find_lang gtksourceview-3.0
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files -f gtksourceview-3.0.lang
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.1
159 %{_datadir}/gtksourceview-3.0
160 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
161
162 %files apidocs
163 %defattr(644,root,root,755)
164 %{_gtkdocdir}/gtksourceview-3.0
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
169 %{_includedir}/gtksourceview-3.0
170 %{_pkgconfigdir}/gtksourceview-3.0.pc
171 %{_datadir}/gir-1.0/GtkSource-3.0.gir
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libgtksourceview-3.0.a
176
177 %if %{with glade}
178 %files -n glade3-gtksourceview
179 %defattr(644,root,root,755)
180 %{_datadir}/glade3/catalogs/gtksourceview.xml
181 %endif
182
183 %if %{with vala}
184 %files -n vala-gtksourceview
185 %defattr(644,root,root,755)
186 %{_datadir}/vala/vapi/gtksourceview-3.0.deps
187 %{_datadir}/vala/vapi/gtksourceview-3.0.vapi
188 %endif
This page took 0.211614 seconds and 3 git commands to generate.