]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview3.spec
- updated to 3.2.0; merged from DEVEL
[packages/gtksourceview5.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 #
5 Summary:        Text widget that extends the standard GTK+ 3.x
6 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
7 Name:           gtksourceview3
8 Version:        3.2.0
9 Release:        1
10 License:        GPL v2+ and LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.2/gtksourceview-%{version}.tar.xz
13 # Source0-md5:  305d62e8d8effe809c63109c2bf6d3a1
14 URL:            http://www.gnome.org/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  glib2-devel >= 1:2.28
20 BuildRequires:  gnome-common >= 2.24.0
21 BuildRequires:  gobject-introspection-devel >= 0.10.0
22 BuildRequires:  gtk+3-devel >= 3.0.0
23 BuildRequires:  gtk-doc >= 1.11
24 BuildRequires:  intltool >= 0.40.0
25 %if %{with glade}
26 BuildRequires:  libgladeui-devel >= 3.9.0
27 %endif
28 BuildRequires:  libtool >= 2:2.2.6
29 BuildRequires:  libxml2-devel >= 1:2.6.31
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires:       glib2 >= 1:2.28.0
35 # sr@Latn vs. sr@latin
36 Conflicts:      glibc-misc < 6:2.7
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
41 widget GtkTextView. It improves GtkTextView by implementing syntax
42 highlighting and other features typical of a source editor.
43
44 %description -l pl.UTF-8
45 GtkSourceView to widget tekstowy rozszerzający standardowy widget
46 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
47 zaimplementowanie podświetlania składni i innych możliwości typowych
48 dla edytora źródeł.
49
50 %package apidocs
51 Summary:        GtkSourceView API documentation
52 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
53 Group:          Documentation
54 Requires:       gtk-doc-common
55
56 %description apidocs
57 GtkSourceView API documentation.
58
59 %description apidocs -l pl.UTF-8
60 Dokumentacja API GtkSourceView.
61
62 %package devel
63 Summary:        Header files for GtkSourceView
64 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
65 Group:          X11/Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       gtk+3-devel >= 3.0.0
68 Requires:       libxml2-devel >= 1:2.6.31
69
70 %description devel
71 Header files for GtkSourceView.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe dla GtkSourceView.
75
76 %package static
77 Summary:        Static GtkSourceView library
78 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
79 Group:          X11/Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static GtkSourceView library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka GtkSourceView.
87
88 %package -n glade3-gtksourceview
89 Summary:        Glade3 catalog entry for GtkSourceView library
90 Group:          X11/Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description -n glade3-gtksourceview
94 Glade3 catalog entry for GtkSourceView library.
95
96 %prep
97 %setup -q -n gtksourceview-%{version}
98
99 %build
100 %{__gtkdocize}
101 %{__intltoolize}
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --enable-gtk-doc \
109         --enable-static \
110         --with-html-dir=%{_gtkdocdir} \
111         %{__enable glade glade-catalog} \
112         --enable-providers \
113         --disable-silent-rules
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
123
124 %find_lang gtksourceview-3.0
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files -f gtksourceview-3.0.lang
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.0
136 %{_datadir}/gtksourceview-3.0
137 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
138
139 %files apidocs
140 %defattr(644,root,root,755)
141 %{_gtkdocdir}/gtksourceview-3.0
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
146 %{_includedir}/gtksourceview-3.0
147 %{_pkgconfigdir}/gtksourceview-3.0.pc
148 %{_datadir}/gir-1.0/GtkSource-3.0.gir
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libgtksourceview-3.0.a
153
154 %if %{with glade}
155 %files -n glade3-gtksourceview
156 %defattr(644,root,root,755)
157 %{_datadir}/glade3/catalogs/gtksourceview.xml
158 %endif
This page took 0.080645 seconds and 3 git commands to generate.