]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview3.spec
- up to 2.91.9
[packages/gtksourceview5.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 #
5 Summary:        Text widget that extends the standard GTK+ 3.x
6 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
7 Name:           gtksourceview3
8 Version:        2.91.9
9 Release:        1
10 License:        GPL v2+ and LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/2.91/gtksourceview-%{version}.tar.bz2
13 # Source0-md5:  e29eea1295cc7d611e0aceb1d915167f
14 URL:            http://www.gnome.org/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.10.3
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gnome-common >= 2.24.0
20 BuildRequires:  gobject-introspection-devel >= 0.9.0
21 BuildRequires:  gtk+3-devel >= 3.0.0
22 BuildRequires:  gtk-doc >= 1.11
23 BuildRequires:  intltool >= 0.40.0
24 %if %{with glade}
25 BuildRequires:  libgladeui-devel >= 3.9.0
26 %endif
27 BuildRequires:  libtool >= 2:2.2.6
28 BuildRequires:  libxml2-devel >= 1:2.6.31
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpm-pythonprov
31 Requires:       glib2 >= 1:2.28.0
32 # sr@Latn vs. sr@latin
33 Conflicts:      glibc-misc < 6:2.7
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
38 widget GtkTextView. It improves GtkTextView by implementing syntax
39 highlighting and other features typical of a source editor.
40
41 %description -l pl.UTF-8
42 GtkSourceView to widget tekstowy rozszerzający standardowy widget
43 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
44 zaimplementowanie podświetlania składni i innych możliwości typowych
45 dla edytora źródeł.
46
47 %package apidocs
48 Summary:        GtkSourceView API documentation
49 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
50 Group:          Documentation
51 Requires:       gtk-doc-common
52
53 %description apidocs
54 GtkSourceView API documentation.
55
56 %description apidocs -l pl.UTF-8
57 Dokumentacja API GtkSourceView.
58
59 %package devel
60 Summary:        Header files for GtkSourceView
61 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
62 Group:          X11/Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       gtk+3-devel >= 3.0.0
65 Requires:       libxml2-devel >= 1:2.6.31
66
67 %description devel
68 Header files for GtkSourceView.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe dla GtkSourceView.
72
73 %package static
74 Summary:        Static GtkSourceView library
75 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static GtkSourceView library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka GtkSourceView.
84
85 %package -n glade3-gtksourceview
86 Summary:        Glade3 catalog entry for GtkSourceView library
87 Group:          X11/Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description -n glade3-gtksourceview
91 Glade3 catalog entry for GtkSourceView library.
92
93 %prep
94 %setup -q -n gtksourceview-%{version}
95
96 %build
97 %{__gtkdocize}
98 %{__intltoolize}
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         --enable-gtk-doc \
106         --enable-static \
107         --with-html-dir=%{_gtkdocdir} \
108         %{__enable glade glade-catalog} \
109         --enable-providers \
110         --disable-silent-rules
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
120
121 %find_lang gtksourceview-3.0
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f gtksourceview-3.0.lang
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.0
133 %{_datadir}/gtksourceview-3.0
134 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
135
136 %files apidocs
137 %defattr(644,root,root,755)
138 %{_gtkdocdir}/gtksourceview-3.0
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
143 %{_includedir}/gtksourceview-3.0
144 %{_pkgconfigdir}/gtksourceview-3.0.pc
145 %{_datadir}/gir-1.0/GtkSource-3.0.gir
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgtksourceview-3.0.a
150
151 %if %{with glade}
152 %files -n glade3-gtksourceview
153 %defattr(644,root,root,755)
154 %{_datadir}/glade3/catalogs/gtksourceview.xml
155 %endif
This page took 0.034544 seconds and 3 git commands to generate.