]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview3.spec
94e635046f57cf666af3ad71d8860fcbec040565
[packages/gtksourceview5.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 #
5 Summary:        Text widget that extends the standard GTK+ 3.x
6 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
7 Name:           gtksourceview3
8 Version:        3.0.5
9 Release:        1
10 License:        GPL v2+ and LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.0/gtksourceview-%{version}.tar.xz
13 # Source0-md5:  cfdf2674cbde0a079ee0b264c27cb15e
14 URL:            http://www.gnome.org/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.10.3
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gnome-common >= 2.24.0
20 BuildRequires:  gobject-introspection-devel >= 0.10.0
21 BuildRequires:  gtk+3-devel >= 3.0.0
22 BuildRequires:  gtk-doc >= 1.11
23 BuildRequires:  intltool >= 0.40.0
24 %if %{with glade}
25 BuildRequires:  libgladeui-devel >= 3.9.0
26 %endif
27 BuildRequires:  libtool >= 2:2.2.6
28 BuildRequires:  libxml2-devel >= 1:2.6.31
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires:       glib2 >= 1:2.28.0
34 # sr@Latn vs. sr@latin
35 Conflicts:      glibc-misc < 6:2.7
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
40 widget GtkTextView. It improves GtkTextView by implementing syntax
41 highlighting and other features typical of a source editor.
42
43 %description -l pl.UTF-8
44 GtkSourceView to widget tekstowy rozszerzający standardowy widget
45 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
46 zaimplementowanie podświetlania składni i innych możliwości typowych
47 dla edytora źródeł.
48
49 %package apidocs
50 Summary:        GtkSourceView API documentation
51 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
52 Group:          Documentation
53 Requires:       gtk-doc-common
54
55 %description apidocs
56 GtkSourceView API documentation.
57
58 %description apidocs -l pl.UTF-8
59 Dokumentacja API GtkSourceView.
60
61 %package devel
62 Summary:        Header files for GtkSourceView
63 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       gtk+3-devel >= 3.0.0
67 Requires:       libxml2-devel >= 1:2.6.31
68
69 %description devel
70 Header files for GtkSourceView.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe dla GtkSourceView.
74
75 %package static
76 Summary:        Static GtkSourceView library
77 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
78 Group:          X11/Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static GtkSourceView library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka GtkSourceView.
86
87 %package -n glade3-gtksourceview
88 Summary:        Glade3 catalog entry for GtkSourceView library
89 Group:          X11/Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description -n glade3-gtksourceview
93 Glade3 catalog entry for GtkSourceView library.
94
95 %prep
96 %setup -q -n gtksourceview-%{version}
97
98 %build
99 %{__gtkdocize}
100 %{__intltoolize}
101 %{__libtoolize}
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         --enable-gtk-doc \
108         --enable-static \
109         --with-html-dir=%{_gtkdocdir} \
110         %{__enable glade glade-catalog} \
111         --enable-providers \
112         --disable-silent-rules
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
122
123 %find_lang gtksourceview-3.0
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files -f gtksourceview-3.0.lang
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.0
135 %{_datadir}/gtksourceview-3.0
136 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
137
138 %files apidocs
139 %defattr(644,root,root,755)
140 %{_gtkdocdir}/gtksourceview-3.0
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
145 %{_includedir}/gtksourceview-3.0
146 %{_pkgconfigdir}/gtksourceview-3.0.pc
147 %{_datadir}/gir-1.0/GtkSource-3.0.gir
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libgtksourceview-3.0.a
152
153 %if %{with glade}
154 %files -n glade3-gtksourceview
155 %defattr(644,root,root,755)
156 %{_datadir}/glade3/catalogs/gtksourceview.xml
157 %endif
This page took 0.085919 seconds and 2 git commands to generate.