]> git.pld-linux.org Git - packages/gtksourceview3.git/blob - gtksourceview3.spec
- more verioned install time dependencies
[packages/gtksourceview3.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 #
5 Summary:        Text widget that extends the standard GTK+ 3.x
6 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
7 Name:           gtksourceview3
8 Version:        3.2.2
9 Release:        1
10 License:        GPL v2+ and LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.2/gtksourceview-%{version}.tar.xz
13 # Source0-md5:  08a5d0a468eec47db965cbeec52d811e
14 URL:            http://www.gnome.org/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  glib2-devel >= 1:2.28
20 BuildRequires:  gnome-common >= 2.24.0
21 BuildRequires:  gobject-introspection-devel >= 0.10.0
22 BuildRequires:  gtk+3-devel >= 3.0.0
23 BuildRequires:  gtk-doc >= 1.11
24 BuildRequires:  intltool >= 0.40.0
25 %if %{with glade}
26 BuildRequires:  libgladeui-devel >= 3.9.0
27 %endif
28 BuildRequires:  libtool >= 2:2.2.6
29 BuildRequires:  libxml2-devel >= 1:2.6.31
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires:       glib2 >= 1:2.28.0
35 Requires:       libxml2 >= 1:2.6.31
36 # sr@Latn vs. sr@latin
37 Conflicts:      glibc-misc < 6:2.7
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
42 widget GtkTextView. It improves GtkTextView by implementing syntax
43 highlighting and other features typical of a source editor.
44
45 %description -l pl.UTF-8
46 GtkSourceView to widget tekstowy rozszerzający standardowy widget
47 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
48 zaimplementowanie podświetlania składni i innych możliwości typowych
49 dla edytora źródeł.
50
51 %package apidocs
52 Summary:        GtkSourceView API documentation
53 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
54 Group:          Documentation
55 Requires:       gtk-doc-common
56
57 %description apidocs
58 GtkSourceView API documentation.
59
60 %description apidocs -l pl.UTF-8
61 Dokumentacja API GtkSourceView.
62
63 %package devel
64 Summary:        Header files for GtkSourceView
65 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
66 Group:          X11/Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       glib2-devel >= 1:2.28.0
69 Requires:       gtk+3-devel >= 3.0.0
70 Requires:       libxml2-devel >= 1:2.6.31
71
72 %description devel
73 Header files for GtkSourceView.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe dla GtkSourceView.
77
78 %package static
79 Summary:        Static GtkSourceView library
80 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
81 Group:          X11/Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static GtkSourceView library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka GtkSourceView.
89
90 %package -n glade3-gtksourceview
91 Summary:        Glade3 catalog entry for GtkSourceView library
92 Group:          X11/Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description -n glade3-gtksourceview
96 Glade3 catalog entry for GtkSourceView library.
97
98 %prep
99 %setup -q -n gtksourceview-%{version}
100
101 %build
102 %{__gtkdocize}
103 %{__intltoolize}
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --enable-gtk-doc \
111         --enable-static \
112         --with-html-dir=%{_gtkdocdir} \
113         %{__enable glade glade-catalog} \
114         --enable-providers \
115         --disable-silent-rules
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
125
126 %find_lang gtksourceview-3.0
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f gtksourceview-3.0.lang
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.0
138 %{_datadir}/gtksourceview-3.0
139 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
140
141 %files apidocs
142 %defattr(644,root,root,755)
143 %{_gtkdocdir}/gtksourceview-3.0
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
148 %{_includedir}/gtksourceview-3.0
149 %{_pkgconfigdir}/gtksourceview-3.0.pc
150 %{_datadir}/gir-1.0/GtkSource-3.0.gir
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libgtksourceview-3.0.a
155
156 %if %{with glade}
157 %files -n glade3-gtksourceview
158 %defattr(644,root,root,755)
159 %{_datadir}/glade3/catalogs/gtksourceview.xml
160 %endif
This page took 0.04268 seconds and 3 git commands to generate.