]> git.pld-linux.org Git - packages/gtkmm4.git/blob - gtkmm3.spec
- up to 2.99.8
[packages/gtkmm4.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        A C++ interface for the GTK+ (a GUI library for X)
6 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
7 Name:           gtkmm3
8 Version:        2.99.8
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.99/gtkmm-%{version}.tar.bz2
13 # Source0-md5:  feff6a84af1375b3b80ebf0691754a24
14 URL:            http://www.gtkmm.org/
15 BuildRequires:  atkmm-devel >= 2.22.0
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  cairomm-devel >= 1.9.2
19 BuildRequires:  gdk-pixbuf2-devel >= 2.22.1
20 BuildRequires:  glibmm-devel >= 2.27.93
21 BuildRequires:  gtk+3-devel >= 3.0.0
22 BuildRequires:  libsigc++-devel
23 BuildRequires:  libstdc++-devel >= 5:3.3.1
24 BuildRequires:  libtool >= 2:1.4d-3
25 BuildRequires:  mm-common >= 0.8
26 BuildRequires:  pangomm-devel >= 2.27.1
27 BuildRequires:  perl-base >= 1:5.6.0
28 BuildRequires:  pkgconfig
29 Requires:       atkmm >= 2.22.0
30 Requires:       cairomm >= 1.9.2
31 Requires:       glibmm >= 2.27.93
32 Requires:       pangomm >= 2.27.1
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
37 library. The interface provides a convenient interface for C++
38 programmers to create GUIs with GTK+'s flexible object-oriented
39 framework. Features include type safe callbacks, widgets that are
40 extensible using inheritance and over 110 classes that can be freely
41 combined to quickly create complex user interfaces.
42
43 %description -l pl.UTF-8
44 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
45 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
46 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
47
48 %package devel
49 Summary:        gtkmm and gdkmm header files
50 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       atkmm-devel >= 2.22.0
54 Requires:       glibmm-devel >= 2.27.93
55 Requires:       gtk+3-devel >= 3.0.0
56 Requires:       pangomm-devel >= 2.27.1
57
58 %description devel
59 Header files for gtkmm library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki gtkmm.
63
64 %package static
65 Summary:        gtkmm and gdkmm static libraries
66 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
67 Group:          X11/Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 gtkmm and gdkmm static libraries.
72
73 %description static -l pl.UTF-8
74 Biblioteki statyczne gtkmm i gdkmm.
75
76 %package apidocs
77 Summary:        Reference documentation for gtkmm and gdkmm
78 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
79 Group:          Documentation
80 Requires:       devhelp
81
82 %description apidocs
83 Reference documentation for gtkmm and gdkmm.
84
85 %description apidocs -l pl.UTF-8
86 Szczegółowa dokumentacja gtkmm i gdkmm.
87
88 %prep
89 %setup -q -n gtkmm-%{version}
90
91 %build
92 %{__libtoolize}
93 %{__aclocal} -I build
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         %{?with_static_libs:--enable-static}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS ChangeLog NEWS PORTING README
119 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
121 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
127 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
128 %{_libdir}/gdkmm-3.0
129 %{_libdir}/gtkmm-3.0
130 %{_includedir}/gdkmm-3.0
131 %{_includedir}/gtkmm-3.0
132 %{_pkgconfigdir}/gdkmm-3.0.pc
133 %{_pkgconfigdir}/gtkmm-3.0.pc
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libgdkmm-3.0.a
139 %{_libdir}/libgtkmm-3.0.a
140 %endif
141
142 %files apidocs
143 %defattr(644,root,root,755)
144 %{_docdir}/gtkmm-3.0
145 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.078783 seconds and 3 git commands to generate.