]> git.pld-linux.org Git - packages/gtkmm4.git/blame - gtkmm3.spec
- updated to 3.10.1
[packages/gtkmm4.git] / gtkmm3.spec
CommitLineData
33bee831
AF
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
a4ed03e8
JB
5%define glibmm_ver 2.38.0
6%define gtk3_ver 3.10.0
33bee831
AF
7Summary: A C++ interface for the GTK+ (a GUI library for X)
8Summary(pl.UTF-8): Wrapper C++ dla GTK+
9Name: gtkmm3
484e5b9b 10Version: 3.10.1
33bee831
AF
11Release: 1
12License: LGPL v2+
13Group: X11/Libraries
a4ed03e8 14Source0: http://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.10/gtkmm-%{version}.tar.xz
484e5b9b 15# Source0-md5: 993c6a53b8c736a475fcbb1fd4e9c393
33bee831 16URL: http://www.gtkmm.org/
31a8d119 17BuildRequires: atkmm-devel >= 2.22.2
33bee831 18BuildRequires: autoconf >= 2.59
31a8d119 19BuildRequires: automake >= 1:1.11
33bee831 20BuildRequires: cairomm-devel >= 1.9.2
4b35a8ba 21BuildRequires: gdk-pixbuf2-devel >= 2.22.1
e34bbb24 22BuildRequires: glibmm-devel >= %{glibmm_ver}
a4ed03e8 23BuildRequires: gtk+3-devel >= %{gtk3_ver}
33bee831
AF
24BuildRequires: libsigc++-devel
25BuildRequires: libstdc++-devel >= 5:3.3.1
e3273d66 26BuildRequires: libtool >= 2:2.0
362eec70 27BuildRequires: mm-common >= 0.9.6
31a8d119 28BuildRequires: pangomm-devel >= 2.28.0
33bee831
AF
29BuildRequires: perl-base >= 1:5.6.0
30BuildRequires: pkgconfig
e3273d66
JB
31BuildRequires: tar >= 1:1.22
32BuildRequires: xz
31a8d119 33Requires: atkmm >= 2.22.2
33bee831 34Requires: cairomm >= 1.9.2
b4b481d5 35Requires: gdk-pixbuf2 >= 2.22.1
e34bbb24 36Requires: glibmm >= %{glibmm_ver}
a4ed03e8 37Requires: gtk+3 >= %{gtk3_ver}
31a8d119 38Requires: pangomm >= 2.28.0
33bee831
AF
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
43library. The interface provides a convenient interface for C++
44programmers to create GUIs with GTK+'s flexible object-oriented
45framework. Features include type safe callbacks, widgets that are
46extensible using inheritance and over 110 classes that can be freely
47combined to quickly create complex user interfaces.
48
49%description -l pl.UTF-8
50gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
51służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
52także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
53
54%package devel
55Summary: gtkmm and gdkmm header files
56Summary(pl.UTF-8): Pliki nagłówkowe gtkmm i gdkmm
57Group: X11/Development/Libraries
58Requires: %{name} = %{version}-%{release}
31a8d119 59Requires: atkmm-devel >= 2.22.2
b4b481d5
JB
60Requires: cairomm-devel >= 1.9.2
61Requires: gdk-pixbuf2-devel >= 2.22.1
e34bbb24 62Requires: glibmm-devel >= %{glibmm_ver}
a4ed03e8 63Requires: gtk+3-devel >= %{gtk3_ver}
31a8d119 64Requires: pangomm-devel >= 2.28.0
33bee831
AF
65
66%description devel
67Header files for gtkmm library.
68
69%description devel -l pl.UTF-8
70Pliki nagłówkowe biblioteki gtkmm.
71
72%package static
73Summary: gtkmm and gdkmm static libraries
74Summary(pl.UTF-8): Biblioteki statyczne gtkmm i gdkmm
75Group: X11/Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77
78%description static
79gtkmm and gdkmm static libraries.
80
81%description static -l pl.UTF-8
82Biblioteki statyczne gtkmm i gdkmm.
83
84%package apidocs
85Summary: Reference documentation for gtkmm and gdkmm
86Summary(pl.UTF-8): Szczegółowa dokumentacja gtkmm i gdkmm
87Group: Documentation
88Requires: devhelp
89
90%description apidocs
91Reference documentation for gtkmm and gdkmm.
92
93%description apidocs -l pl.UTF-8
94Szczegółowa dokumentacja gtkmm i gdkmm.
95
96%prep
97%setup -q -n gtkmm-%{version}
98
99%build
100%{__libtoolize}
101%{__aclocal} -I build
102%{__autoconf}
103%{__autoheader}
104%{__automake}
105%configure \
106 %{?with_static_libs:--enable-static}
107
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113%{__make} install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
126%doc AUTHORS ChangeLog NEWS PORTING README
127%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
128%attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
129%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
130%attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
131
132%files devel
133%defattr(644,root,root,755)
134%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
135%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
136%{_libdir}/gdkmm-3.0
137%{_libdir}/gtkmm-3.0
138%{_includedir}/gdkmm-3.0
139%{_includedir}/gtkmm-3.0
140%{_pkgconfigdir}/gdkmm-3.0.pc
141%{_pkgconfigdir}/gtkmm-3.0.pc
142
143%if %{with static_libs}
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/libgdkmm-3.0.a
147%{_libdir}/libgtkmm-3.0.a
148%endif
149
150%files apidocs
151%defattr(644,root,root,755)
152%{_docdir}/gtkmm-3.0
153%{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.073563 seconds and 4 git commands to generate.